cancel
Showing results for 
Search instead for 
Did you mean: 

symbolic link

bitou
Frequent Advisor

symbolic link

hi everybody,
any help concerning this issue.
i have create a symbolic link using this command:
ln -s test database_test
and it is created normally, but after a few minutes or server restarted the symbolic link is disappeared.
any idea....
remark: test is a raw device
5 REPLIES
Dennis Handly
Acclaimed Contributor

Re: symbolic link

Somebody must be removing it?

>remark: test is a raw device

That shouldn't matter but it would be helpful if you could list the symlink's actual path and values.
P Arumugavel
Respected Contributor

Re: symbolic link

Change the path of destination file and try. Check any script does this.
Raw device is not an issue.

Rgds...
P Muralidhar Kini
Honored Contributor

Re: symbolic link

Hi bitou,

>> and it is created normally, but after a few minutes or server
>> restarted the symbolic link is disappeared.
This should not happen. The link file should exist.
May be something else is going on which is deleting the link file.

Regards,
Murali
Let There Be Rock - AC/DC
V. Nyga
Honored Contributor

Re: symbolic link

Hi,

where did you create the link /tmp?
At restart you can configure to delete /tmp contents, also check for a cron job doing this.

V.

Which os?
*** Say 'Thanks' with Kudos ***
Ismail Azad
Esteemed Contributor

Re: symbolic link

Hi,

>
but after a few minutes or server restarted the symbolic link is disappeared.

Hmmm but after a few minutes... Guess that's the clue to this troubleshooting loop. And I think the forumers have rightly mentioned because of the "after a few minutes" comment that it indeed should be a cron job or a script that runs. Posting output of crontab might help.....

Regards
Ismail Azad

Read, read and read... Then read again until you read "between the lines".....