cancel
Showing results for 
Search instead for 
Did you mean: 

tape drive

 
SOLVED
Go to solution
kunjuttan
Super Advisor

tape drive

my external tape drive is not getting detected ...what to do..
Server Model-ia64 hp server rx2620
OS - HP-UX11.23
23 REPLIES
Torsten.
Acclaimed Contributor

Re: tape drive

Where exactly is it connected?
What SCSI ID?
What drive model?
Cable OK?
Bent pins?
Terminated?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: tape drive

Is the stape driver already included?

If not, do

# kcmodule stape=static

and reboot.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
kunjuttan
Super Advisor

Re: tape drive

Hp-Storageworks Ultrium 960
Connected to SCSI/LVD port

cable and pin ok because I used the same drive with other box.
kunjuttan
Super Advisor

Re: tape drive

Am I have to reboot the Server???
Torsten.
Acclaimed Contributor

Re: tape drive

Is there a disk in the upper disk slot?

Please post

# ioscan -fn

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
kunjuttan
Super Advisor

Re: tape drive

Class I H/W Path Driver S/W State H/W Type Description
==============================================================================
root 0 root CLAIMED BUS_NEXUS
ioa 0 0 sba CLAIMED BUS_NEXUS System Bus Adapter (1229)
ba 0 0/0 lba CLAIMED BUS_NEXUS Local PCI-X Bus Adapter (122e)
OO 0 0/0/1/0 UsbOhci CLAIMED INTERFACE USB OHCI Interface
OO 1 0/0/1/1 UsbOhci CLAIMED INTERFACE USB OHCI Interface
OO 2 0/0/1/2 UsbEhci CLAIMED INTERFACE USB EHCI Interface
sideba 0 0/0/2/0 side_multi CLAIMED INTERFACE CMD IDE controller
ext_bus 0 0/0/2/0.0 side CLAIMED INTERFACE IDE Primary Channel
target 0 0/0/2/0.0.0 tgt CLAIMED DEVICE
disk 0 0/0/2/0.0.0.0 sdisk CLAIMED DEVICE TEAC DV-28E-N
/dev/dsk/c0t0d0 /dev/rdsk/c0t0d0
target 1 0/0/2/0.0.7 tgt CLAIMED DEVICE
ctl 0 0/0/2/0.0.7.0 sctl CLAIMED DEVICE Initiator
/dev/rscsi/c0t7d0
ext_bus 1 0/0/2/0.1 side CLAIMED INTERFACE IDE Secondary Channel
target 2 0/0/2/0.1.7 tgt CLAIMED DEVICE
ctl 1 0/0/2/0.1.7.0 sctl CLAIMED DEVICE Initiator
/dev/rscsi/c1t7d0
ba 1 0/1 lba CLAIMED BUS_NEXUS Local PCI-X Bus Adapter (122e)
ext_bus 2 0/1/1/0 mpt CLAIMED INTERFACE SCSI Ultra320
/dev/mpt2
target 3 0/1/1/0.0 tgt CLAIMED DEVICE
disk 1 0/1/1/0.0.0 sdisk CLAIMED DEVICE HP 146 GMAW3147NC
/dev/dsk/c2t0d0 /dev/rdsk/c2t0d0
target 4 0/1/1/0.1 tgt CLAIMED DEVICE
disk 2 0/1/1/0.1.0 sdisk CLAIMED DEVICE HP 146 GMAW3147NC
/dev/dsk/c2t1d0 /dev/dsk/c2t1d0s2 /dev/rdsk/c2t1d0 /dev/rdsk/c2t1d0s2
/dev/dsk/c2t1d0s1 /dev/dsk/c2t1d0s3 /dev/rdsk/c2t1d0s1 /dev/rdsk/c2t1d0s3
target 5 0/1/1/0.7 tgt CLAIMED DEVICE
ctl 2 0/1/1/0.7.0 sctl CLAIMED DEVICE Initiator
/dev/rscsi/c2t7d0
ext_bus 3 0/1/1/1 mpt CLAIMED INTERFACE SCSI Ultra320
/dev/mpt3
target 6 0/1/1/1.7 tgt CLAIMED DEVICE
ctl 3 0/1/1/1.7.0 sctl CLAIMED DEVICE Initiator
/dev/rscsi/c3t7d0
lan 0 0/1/2/0 iether CLAIMED INTERFACE HP PCI-X 1000Base-T Dual-port Built-in
lan 1 0/1/2/1 iether CLAIMED INTERFACE HP PCI-X 1000Base-T Dual-port Built-in
ba 2 0/2 lba CLAIMED BUS_NEXUS Local PCI-X Bus Adapter (122e)
ba 3 0/3 lba CLAIMED BUS_NEXUS Local PCI-X Bus Adapter (122e)
lan 2 0/3/1/0 igelan CLAIMED INTERFACE HP A6825-60101 PCI 1000Base-T Adapter
ba 4 0/4 lba CLAIMED BUS_NEXUS Local PCI-X Bus Adapter (122e)
lan 3 0/4/1/0 igelan CLAIMED INTERFACE HP A6825-60101 PCI 1000Base-T Adapter
ba 5 0/5 lba CLAIMED BUS_NEXUS Local PCI-X Bus Adapter (122e)
ba 6 0/6 lba CLAIMED BUS_NEXUS Local PCI-X Bus Adapter (122e)
tty 0 0/6/1/0 asio0 CLAIMED INTERFACE PCI SimpleComm (103c1290)
/dev/diag/mux0 /dev/mux0 /dev/tty0p0
tty 1 0/6/1/1 asio0 CLAIMED INTERFACE PCI Serial (103c1048)
/dev/GSPdiag1 /dev/diag/mux1 /dev/mux1 /dev/tty1p0 /dev/tty1p2 /dev/tty1p4
graphics 0 0/6/2/0 gvid_core CLAIMED INTERFACE PCI Display (10025159)
processor 0 120 processor CLAIMED PROCESSOR Processor
processor 1 121 processor CLAIMED PROCESSOR Processor
ba 7 250 pdh CLAIMED BUS_NEXUS Core I/O Adapter
ipmi 0 250/0 ipmi CLAIMED INTERFACE IPMI Controller
/dev/ipmi
tty 2 250/1 asio0 CLAIMED INTERFACE Built-in RS232C
/dev/diag/mux2 /dev/mux2 /dev/tty2p0
tty 3 250/2 asio0 CLAIMED INTERFACE Built-in RS232C
/dev/diag/mux3 /dev/mux3 /dev/tty3p0
acpi_node 0 250/3 acpi_node CLAIMED INTERFACE Acpi Hardware
V. Nyga
Honored Contributor

Re: tape drive

Hi,

I can't see the tape.
Can you post:
# ioscan -fnC tape

Is the power switch on?
Have you rebooted server after connecting the tape?

V.
*** Say 'Thanks' with Kudos ***
kunjuttan
Super Advisor

Re: tape drive


""I can't see the tape.
Can you post:
# ioscan -fnC tape

Is the power switch on?
Have you rebooted server after connecting the tape?""

this is what am also sayig...tape is not detecting....

# ioscan -fnC tape -- output is nothing

kunjuttan
Super Advisor

Re: tape drive

sever is not rebooted..
V. Nyga
Honored Contributor

Re: tape drive

Do like Thorsten mentioned:

Is the stape driver already included?
If not, do
# kcmodule stape=static
and reboot.

If the server never had a tape, it's maybe not yet configured. So do that above.
The server can't recognize the tape without a reboot. Nor will the device files be created.

V.
*** Say 'Thanks' with Kudos ***
johnsonpk
Honored Contributor

Re: tape drive

hi,

check the stape module status by
#kcmodule -v stape

and see the status

if it is not static , change it to static and reboot as per other's suggestion posted above

regards!
johnson
kunjuttan
Super Advisor

Re: tape drive

Output of kcmodule -v stape----
Module stape [463F5B4D]
Description SCSI Tape Driver
State static (as requested)
State at Next Boot static (as requested)
Capable static unused
Depends On module sctl:0.0.0
interface HPUX_11_23:1.0

And I cant reboot the server now..
Andrew Rutter
Honored Contributor

Re: tape drive

hi, create the device files for the tape drive

#insf -e

then do a full ioscan

#ioscan

Andy

Torsten.
Acclaimed Contributor
Solution

Re: tape drive

It should be here

ext_bus 3 0/1/1/1 mpt CLAIMED INTERFACE SCSI Ultra320
/dev/mpt3
target 6 0/1/1/1.7 tgt CLAIMED DEVICE
ctl 3 0/1/1/1.7.0 sctl CLAIMED DEVICE Initiator
/dev/rscsi/c3t7d0

but it isn't.

Double check cable and termination, please.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
kunjuttan
Super Advisor

Re: tape drive


"Double check cable and termination, please."

thanks Torsten..But how to check this.I already done a backup of other server with same cable and tape drive..so i think drive and cable is k.Now the termination..may i know how to check the same..

thanks Andy..I aready done what you mentioned....
Andrew Rutter
Honored Contributor

Re: tape drive

hi,

there is always a possibilty that a pin got bent when reconnecting the drive up.

check the pins in the cable carefully, only one pin needs to be bent missing for it not be picked up.

termination can be checked by checking the pins on the terminator too, and also depends if its an active terminator on the drive or not? does it have an led on it either red/green or orange coloured, when power is to the drive and it is connected up

Andy
kunjuttan
Super Advisor

Re: tape drive



I checkd the pins..its ok..On the server side it is showing like Internal automatic SCSI terminator..drive is having LEDs..
Server Model--ia64 hp server rx2620
Mike Miller_8
Regular Advisor

Re: tape drive

Check the SCSI address and make sure that it's using a unique address (doesn't conflict with other devices on the chain).
Shutdown the tape drive, change it's scsi address and power back up if there's a conflict.

# Rebuild drivers
insf -e

# Check to see it shows up
ioscan

Reboot to commit any pending updates
kunjuttan
Super Advisor

Re: tape drive

how to change the scsi address of tape drive..??
Torsten.
Acclaimed Contributor

Re: tape drive

This depends on the drive model, look for a switch at the back of the chassis.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
kunjuttan
Super Advisor

Re: tape drive

Model is Hp-Storageworks Ultrium 960.

ehind the drive it is showng 3 .. i think it is ths SCSI id..but dont know how to change this..because no switch is there..
Torsten.
Acclaimed Contributor

Re: tape drive

Do you see a small "+" and "-" next to the digit? Take a pencil or whatever and press it while the tape drive is off.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
kunjuttan
Super Advisor

Re: tape drive

Thanx Torsten..its done..