cancel
Showing results for 
Search instead for 
Did you mean: 

tape not responding

 
SOLVED
Go to solution
rosa maria_1
Advisor

tape not responding

Hi everyone !
I have an issue with my server tape. Trying to restoring information it`s sending:
frecover(5403): Unable to open or identify device at /dev/rmt/0m
frecover(5405): unable to open /dev/rmt/0m
frecover(5406): Do you wish to continue? (^[yY]/^[nN]) frecover(4302): frecover
interrupted, continue? (^[yY]/^[nN])

but checking this device with ioscan, I found the address isn`t responding:

ioscan -funC tape
Class I H/W Path Driver S/W State H/W Type Description
=====================================================================
tape 1 0/0/2/1.0.0 stape NO_HW DEVICE HP C1537A
/dev/rmt/0m /dev/rmt/c3t0d0BESTb
/dev/rmt/0mn /dev/rmt/c3t0d0BESTn
/dev/rmt/1m /dev/rmt/c3t0d0BESTnb
/dev/rmt/1mb /dev/rmt/c3t0d0DDS
/dev/rmt/1mn /dev/rmt/c3t0d0DDSb
/dev/rmt/1mnb /dev/rmt/c3t0d0DDSn
/dev/rmt/c3t0d0BEST /dev/rmt/c3t0d0DDSnb

my HP9000 has 11.0 o.s. version, one week ago we had an issue, the IP was unconfigure, technical support said it was because of new bundle to install.

does it can be for the same reason??
can I restore my information in other way ?? before installing bundles?

Thanks in advance


17 REPLIES
Torsten.
Acclaimed Contributor
Solution

Re: tape not responding

NO_HW indicates it WAS there, but it is no longer present.

Check for bad drive, bad cable, bad terminator, bad HBA.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Efrain Valencia
Valued Contributor

Re: tape not responding

Hello Rosa,

Whenever I see a something like this on a UX box, I try to check the hardware first,

Perhaps verify the connections for the tape drive are OK, (cables in good shape and properly seated)

Also verify the tape drive for any unusual LED indicators, check if there is no media stuck in the drive, etc.

I doubt the drive has stopped responding to the OS due to a missing bundle.

Regards,
rosa maria_1
Advisor

Re: tape not responding

Hi there !!

Actually, the drive is internal to the server. There isn´t media stuck in the drive, it doesn´t have HBA. LED indicator isn´t working, only the server´s LED indicator for attention is blinking.

The person who made the backup said it was working and it sent a message to continue with this process, but it didn´t work neither with a new tape nor cleaning tape.

Torsten.
Acclaimed Contributor

Re: tape not responding

What server model is it?


Sounds like a bad (dead) drive ...

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
rosa maria_1
Advisor

Re: tape not responding

it is an HP server rp5400 server (A5576B). Today the status changed, it is CLAIMED. I tried a backup with a new tape, but this is the error message:

ioscan -funC tape
Class I H/W Path Driver S/W State H/W Type Description
=====================================================================
tape 1 0/0/2/1.0.0 stape CLAIMED DEVICE HP C1537A
/dev/rmt/0m /dev/rmt/c3t0d0BESTb
/dev/rmt/0mn /dev/rmt/c3t0d0BESTn
/dev/rmt/1m /dev/rmt/c3t0d0BESTnb
/dev/rmt/1mb /dev/rmt/c3t0d0DDS
/dev/rmt/1mn /dev/rmt/c3t0d0DDSb
/dev/rmt/1mnb /dev/rmt/c3t0d0DDSn
/dev/rmt/c3t0d0BEST /dev/rmt/c3t0d0DDSnb

/etc/fbackup -f/dev/rmt/0m -v -g/home/etc/diariocel
fbackup(1421): no history is available for graph file /home/etc/diariocel (below level 0)
fbackup(1004): session begins on Mon Apr 12 09:46:02 2010
fbackup(3038): output file /dev/rmt/0m is not a valid device file for backup
fbackup(3019): would you like to enter a new output file?
n
fbackup(3022): would you like to continue this session?
n
fbackup(3004): writer aborting
fbackup(1002): Backup did not complete : Reader or Writer process exit

Thanks !!
Torsten.
Acclaimed Contributor

Re: tape not responding

Strange, you have /dev/rmt/0m and /dev/rmt/1m.

Consider to do an rmsf and insf again.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
BUPA IS
Respected Contributor

Re: tape not responding

Hello ,
The ioscan currently thinks this tape instance 1 so the /dev/rmt/1m may work.
I think this happens because there is some intermittent fault on the drive and when the system was restarted it thought incorrectly that a new drive had been installed.

Because of the sometimes it is CLAIMED and sometimes it is NO_HW I would get your hardware engineer to check and possibly replace the drive .

Mike
Help is out there always!!!!!
S.N.S
Valued Contributor

Re: tape not responding

Hi Rose,
As the experts say, you would need to check the H/W....

However, temporarily this may work out (I have faced a similar, but not Exact issue - with some of the errors overlapping..) ---->
I had tried two ways - it was with the ignite tape. I was successful with both...I'm not sure it will work for you - but You sound quite in a need for getting the files from the tape...

A. using tar
1. cd to any dir that has space
2. then tar xvf /dev/rmt/0mn path of the file you need to recover WITHOUT / at the start
eg...for getting /etc/lvmtab from ignite back up into dir
tar xvf /dev/rmt/0mn etc/lvmtab...
[tar took me a lot of time - beware, u may need to run it in the background using &]

OR

B. sam>Backup&Recovery option.>Interactive Backup and Recovery
and specify any dir to which U need the files to be copied...

Try it - you never know..

HTH
SNS
"Genius is 1% inspiration, 99% Perspiration" - Edison
rosa maria_1
Advisor

Re: tape not responding

event.log file has:
Nov 29 22:28:45 2009 Tape at hardware path 0/0/2/1.0.0 : Media failure dm_stape SERIOUS 100038
Apr 10 23:13:46 2010 Tape at hardware path 0/0/2/1.0.0 : Hardware failure dm_stape CRITICAL 100057

The recommendation is:"... Repair or replace the device" as you said.

Before to take this option, I have a question, what implications can be using rmsf command?
Dennis Handly
Acclaimed Contributor

Re: tape not responding

>what implications can be using rmsf command?

This just removes the possibly bogus device files and insf(1m) will put it back.
Torsten.
Acclaimed Contributor

Re: tape not responding

This will hopefully recreate the 0m device:

# rmsf -k -H 0/0/2/1.0.0

# insf -C tape

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
rosa maria_1
Advisor

Re: tape not responding

Great !!!

I could make the backup, but could it be a solution only in a short time ? or must be better if I change the drive ...

what do you recommend me?
S.N.S
Valued Contributor

Re: tape not responding

Hi Rosa,


There some HW issue, as all say - needed to be checked!
The general rule is that if there is any HW issue/defect, fix/replace it...coz, you just can't bypass an HW issue with any Software solution....

Ofcourse never fail to report the matter to whosoever is responsible.Draw up your support contracts, check the timelines & budget... purchase/transaction/warranty...We need to make our side - SysAdmin/SysEngr side clear..

My Golden Rule is never depend on a single source/point of failure...

Hope things get sorted out soon

Best Regards
SNS

NB: ERROR on my part: 2. Using SAM -- I was only able to get the list of file - not the files themselves..sorry abt that...SAM uses frecover..
Thanks for the generous assignment of points!
"Genius is 1% inspiration, 99% Perspiration" - Edison
BUPA IS
Respected Contributor

Re: tape not responding

hello,
If the drive will stay working for long enough then you might try a backup before you change it but the tape may have errors on it.
I would change the drive and then take a backup as soon as it is changed .
Mike
Help is out there always!!!!!
rosa maria_1
Advisor

Re: tape not responding

ok, I think the best is replace the drive ...

Thanks all of you for your support, everyone has been helpful ...

rosa maria_1
Advisor

Re: tape not responding

Every solution people give me goes the same way, replacing the drive is the best option in this case.
Thanks.
S.N.S
Valued Contributor

Re: tape not responding

Check, Test & replace if needed :-)..
Merci/Dunke for being generous!
SNS
"Genius is 1% inspiration, 99% Perspiration" - Edison