System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

tar File size limit exceeded

 
SOLVED
Go to solution
himacs
Super Advisor

tar File size limit exceeded

Hi Admins,

I was backing up a dir using tar.But tar will terminate after backing up 101M data saying "File size limit exceeded"

[root@uaedxbpdcrmdsp03 reuters]# uname -a
uname -a
Linux uaedxbpdcrmdsp03 2.6.18-164.el5 #1 SMP Tue Aug 18 15:51:48 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
[root@uaedxbpdcrmdsp03 reuters]#


Please suggest on this.

Regards
Pavan
6 REPLIES
Patrick Wallek
Honored Contributor

Re: tar File size limit exceeded

How large is the file it was backing up when it terminated?

Was there any other information with the error? A file name perhaps? What 'tar' syntax were you using?
Steven Schweda
Honored Contributor
Solution

Re: tar File size limit exceeded

> [...] using tar.

Not a very detailed description of anything.
As usual, showing an actual command can be
more helpful than a vague description.

> [...] tar will terminate after backing up
> 101M data saying "File size limit exceeded"

"tar" is unlikely to have a file size limit
anywhere near 100MB, so I'd guess that you
are hitting a limit imposed elsewhere.

ulimit -a

With no useful information about what you're
doing, it's hard to know what might help, but
if you're storing the "tar" archive on a
disk, then compression (gzip, bzip2, ...)
might help.
himacs
Super Advisor

Re: tar File size limit exceeded

Hi ,

Thanks for your response.

Issue has been solved.Filesize limit was 100MB.I changed to 2 GB.

Regards
Pavan
Steven Schweda
Honored Contributor

Re: tar File size limit exceeded

> [...] Filesize limit was 100MB. [...]

That was a "ulimit" limit?

> As usual, showing an actual command can be
> more helpful than a vague description.

Still true.
himacs
Super Advisor

Re: tar File size limit exceeded

Yes Steven,That was ulimit.

The command i had fired was
<>

Regards
himacs
Steven Schweda
Honored Contributor

Re: tar File size limit exceeded

> The command i had fired was
> [...]

I suppose that it would be a waste of time to
note that "ulimit" is also a command which
you used, with some particular option, I'd
guess.