System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

telnet / Local Flow Control Off

SOLVED
Go to solution
Kevin_194
Advisor

telnet / Local Flow Control Off

Hi Experts,

I try to telnet a HP-UNIX-Client but I get this Error:

Trying...
Escape character is '^]'.
Local flow control off
Connection closed by foreign host.

I get the telnet on the other Clients, which hast the same NW-Area.

Thanks for advice
Kevin
10 REPLIES
Karthik S S
Honored Contributor

Re: telnet / Local Flow Control Off

1. restart inetd on that client.

if that doesn't work,

2. From console of that client try running "insf -e" and telnet again.

-Karthik S S
For a list of all the ways technology has failed to improve the quality of life, please press three. - Alice Kahn
Mark Grant
Honored Contributor

Re: telnet / Local Flow Control Off

Sounds to me like you don't have telnet defined in /etc/inetd.conf. Have a look at it and see if you have ane entry that is not commented out that looks like this

telnet stream tcp nowait root /usr/lbin/telnetd telnetd

Also, check you are not being refused by /var/adm/inetd.sec
Never preceed any demonstration with anything more predictive than "watch this"
Kevin_194
Advisor

Re: telnet / Local Flow Control Off

Hi Karthink and Mark,

thanks for reply. It seems everything is OK, but still telnet dosen't work.

Kevin
Karthik S S
Honored Contributor

Re: telnet / Local Flow Control Off

Are you able to do a ftp to that box? Do you see any error messages related to telnet in syslog.log??

-Karthik S S
For a list of all the ways technology has failed to improve the quality of life, please press three. - Alice Kahn
Kevin_194
Advisor

Re: telnet / Local Flow Control Off

Hi Karthink,

FTP works.
Wenn I start a Telnet i get in syslog.log:

Cannot allocate pty


Kevin
RAC_1
Honored Contributor

Re: telnet / Local Flow Control Off

What is yout npty kernel parameter setting? Check it as follows.

kmtune -lq npty. (You need to be root for this.) Compare this no. with following command.

ll /dev/pty/*|wc -l.

Anil
There is no substitute to HARDWORK
Kevin_194
Advisor

Re: telnet / Local Flow Control Off

Hi RAC,

I have the command kmtune not in this client:
HP-UX 10.20

ll /dev/pty/*|wc -l.
60

Kevin

Fabio Ettore
Honored Contributor
Solution

Re: telnet / Local Flow Control Off

Hi Kevin,

try the following command:

# insf -d pty -n 150

It will build new pty files and telnet already should work.
Then you should change npty and nstrpty to 150 and after reboot for kernel rebuilding

# rm /dev/pty/*
# rm /dev/ptym/*
# cd /dev
# insf -d pty -n 150

I hope this helps you.

Best regards,
Ettore
WISH? IMPROVEMENT!
Kevin_194
Advisor

Re: telnet / Local Flow Control Off


Thank you all. It works.
Ramesh_csc
Occasional Visitor

Re: telnet / Local Flow Control Off

it worked for me , i run insf -e  from server console ,

now   i am able to telnet server , 

thankyou  very much...Ramesh Bhagat