System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

threshold raised to 256 bytes

SOLVED
Go to solution

threshold raised to 256 bytes

I am getting this following message on console.
tuo: transmit FIFO underflow: threshold raised to 256 bytes.

My OS is Compaq True64 system version 5.1.

Any suggestions.

Thanks in advance.

Madhav
7 REPLIES
Ralf Puchner
Honored Contributor
Solution

Re: threshold raised to 256 bytes

the tulip cards uses dynamic buffers for I/O. If pci bus is saturated the card automatically choose the correct transfer mode leading to the given message.

Change the parameter

% /sbin/sysconfig -q tu
tu:
StoreAndForward = 0

to 1 to enable store and forward mode without using DMA buffers. Of course, your packet latency will be greater, but it sounds like your system is crippled anyway (and you
probably wouldn't notice the increased latency).
Help() { FirstReadManual(urgently); Go_to_it;; }

Re: threshold raised to 256 bytes

Ralf,

I have the same problem but when I launch

/sbin/sysconfig -q tu

The system replies with: framework error: subsystem 'tu' not found.

I tried also tu1

Thanks.
Michael Schulte zur Sur
Honored Contributor

Re: threshold raised to 256 bytes

Hi Ezra,

you should have tu, if you have 5.1.
Can you post ifconfig -a?

Michael

Re: threshold raised to 256 bytes

I have 4.0f but the ethernet device is tu(x) also.

tu0: flags=c63

tu1: flags=c63
inet 172.25.5.10 netmask ffff0000 broadcast 172.25.255.255 ipmtu 1500

tu2: flags=c63

tu3: flags=c63

sl0: flags=10

lo0: flags=100c89
inet 127.0.0.1 netmask ff000000 ipmtu 4096

ppp0: flags=10
Ralf Puchner
Honored Contributor

Re: threshold raised to 256 bytes

for 4.0f use:

# kdbx -k /vmunix /dev/mem
(kdbx) patch tu_sf_mode=1

this procedure must be repeated each time a new kernel will be created.
Help() { FirstReadManual(urgently); Go_to_it;; }

Re: threshold raised to 256 bytes

Thanks Ralf.
As I typed the command you showed me, the system replied with:

thread 0xfffffc007fe14a80 stopped at [thread_block:2376 ,0xfffffc00002c2490] Source not available
warning: Files compiled -g3: parameter values probably wrong

However I typed what you suggested and it replied with a "1".
I think I did it right and it seems to work now.
I'm sorry I can't give points.
Thanks.
Michael Schulte zur Sur
Honored Contributor

Re: threshold raised to 256 bytes

Hi Madhay,

Is your question answered? If so, would you be so kind to award some points for those, who gave you a hint?

greetings,

Michael