cancel
Showing results for 
Search instead for 
Did you mean: 

time worng hp-ux

 
leonardop
Occasional Contributor

time worng hp-ux

I have a superdome SD32000 with two partitions, 3 days ago the server got completely blocked, the partitions reset and since then the time is not ok., it gets continuously and progressively ahead of the real time set by me. The NTP service is down and not configured, but the problem with the system clock continues…any ideas?
7 REPLIES
sujit kumar singh
Honored Contributor

Re: time worng hp-ux

hi
are you able to set the MP system time ?
regards
sujit
vz7r1x
Regular Advisor

Re: time worng hp-ux


Hi,

use "set_parms" command to set time.

set_parms command sets up:
system hostname
networking
date/time
root password

Thanks
V. Nyga
Honored Contributor

Re: time worng hp-ux

â ¦any ideas? - Configure NTP.

Else - any chance that you have a problem/changing in power supply - from 50 to 60Hz?

Do you have HP support?

Volkmar
*** Say 'Thanks' with Kudos ***
leonardop
Occasional Contributor

Re: time worng hp-ux

I configure NTP but the problem continue..

/etc/rc.config.d> date
Thu Jun 18 10:53:53 SAT 2009

/etc/rc.config.d> /sbin/init.d/xntpd stop
xntpd stopped
/etc/rc.config.d> /sbin/init.d/xntpd start
18 Jun 10:54:06 ntpdate[20911]: step time server 10.69.57.1 offset -38.892602 sec
date
Thu Jun 18 10:54:08 SAT 2009

V. Nyga
Honored Contributor

Re: time worng hp-ux

Well, ntp can't sync a too big gap, normally you have to take the time from the ntp server.

I don't know if here are the hints:
http://docs.hp.com/en/B2355-90685/ch07.html

HTH
Volkmar
*** Say 'Thanks' with Kudos ***
Ron Irving
Trusted Contributor

Re: time worng hp-ux

You can force the NTP to adjust. Turn off NTP first. Then

#ntpdate -B "time source ip"

The system time will drift, and match up to the source, then turn on NTP again.
Should have been an astronaut.
BUPA IS
Respected Contributor

Re: time worng hp-ux

Hello,
There is a problem with supderdome firmware where the clock is not updated properly

see this thread

http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1305383

PDC_FW 043.006.000 contains the following fixes:
...
Time drift for HP-UX operating systems up to 48 minutes per month. This has been fixed.

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=322811&swItem=ux-55398-1&mode=4&idx=2

In order to get it started again I would be inclined to shutdown and step the clock with ntpdate . When using -B it can take several days to slew to the right time .
Remember that the ntpdate server used at startup is set independently in /etc/rc.config.d/netdaemons
I hope this helps

Mike


Help is out there always!!!!!