System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

trouble setting up samba and active directory

SOLVED
Go to solution
sandyt
Frequent Advisor

trouble setting up samba and active directory

We are running rhel4 and want to share a few linux libraries with xp clients using samba 3.0.33.

I am having problems getting the server to join the AD domain. For some reason the computer name is getting a $ suffix e.g. if the server name is xxxx, and the domain is yyyy, we get kerberos_kinit_password xxxx$@yyyy failed:client not found in kerberos database, and a subsequent nsswitch/winbindd_ads.c:ads_cached_connection(128)
ads_connect for domain yyyy failed:client not...(These found in the /var/log/samba/winbindd.log)

Any help will be welcome.

2 REPLIES
P Muralidhar Kini
Honored Contributor
Solution

Re: trouble setting up samba and active directory

Hi Sandyt,

Refer the following link -

* Configuring a Samba Server on RHEL 4
http://www.scribd.com/doc/6059836/Configuring-a-Samba-Server

* How to configure samba in RHEL 5
http://hubpages.com/hub/How-to-configure-samba-in-RHEL-5

* Connecting RHEL to Active Directory Server through Samba
http://linuxhunt.blogspot.com/2010/02/connecting-rhel-to-active-directory_09.html

Also,
http://wiki.samba.org/index.php/Samba_%26_Active_Directory

Hope this helps.

Regards,
Murali
Let There Be Rock - AC/DC
sandyt
Frequent Advisor

Re: trouble setting up samba and active directory

Thanks a lot for the references.
I had a problem with our /etc/samba/smb.conf
and has been corrected.