System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

unable to add secondary swap ...

SOLVED
Go to solution
sabinkarvijay
Frequent Advisor

unable to add secondary swap ...

Hi All,

Please help me out on this..

When i tried to add secondary swap , I am getting the below error..not able to proceed further

# vxassist -g sappbidg -U swap make swapvol2 1g
VxVM vxassist ERROR V-5-1-435 Cannot allocate space for 1048576 block volume
# vxassist -g sappbidg maxsize
Maximum volume size: 7328768 (7157Mb)

Please let me know, how can i proceed on this..

Thanks in Advance,

Regards,
Vijay Sabinkari.
4 REPLIES
James R. Ferguson
Acclaimed Contributor

Re: unable to add secondary swap ...

Hi:

From the information you provide, the error is self-explanatory. You don't have enough free space.

Regards!

...JRF...
Mel Burslan
Honored Contributor

Re: unable to add secondary swap ...

I have never used veritas volumes as a swap before, hence this answer is shooting from the hip. Swap volumes need to be on a contiguous space. Even though you have 7.15 GB of space, it might npt be contiguous. You need to refere to vea error descriptions and look for the error code your command spitted out. I am sure it has some relevance to the answer "why" or call Symantec to figure it out.

One question ? Did your system get built with VxVM instead of LVM ? If you have LVM available, why not use that ?
________________________________
UNIX because I majored in cryptology...
Turgay Cavdar
Honored Contributor
Solution

Re: unable to add secondary swap ...

Hi,
You cannot use CDS disk as swap volumes on veritas. Type "vxdisk list", if you see your disk as cds then you can not use as "-U swap".
sabinkarvijay
Frequent Advisor

Re: unable to add secondary swap ...

Thanks all for your responses..

Just a small change worked..

Instead of '-U swap' used '-U gen'

#vxassist -g sappbidg -U gen make swapvol2 1g

Regards,
Vijay..