cancel
Showing results for 
Search instead for 
Did you mean: 

update-ux failed

 
SOLVED
Go to solution
Aungshuman Paul
Regular Advisor

update-ux failed

HI,

Can anyone help regarding the following issue :

My current OS version : # swlist -l bundle | grep OE
HPUX11i-OE B.11.23.0712 HP-UX Foundation Operating Environment Component
HPUX11i-OE-MC B.11.23.0712 HP-UX Mission Critical Operating Environment Component
#

I want to upgrade it to HPUX11i-BOE.

My update-ux failed with following error :

* Analyzing Software To Be Installed



* Checking if Reboot Needed
NOTE: A reboot will be required to complete the installation of the selected software.
* Running pre_update Check Scripts
* Running any scripts found in directory "/var/adm/sw/pre_update".
* Running "/var/adm/sw/pre_update/update_ok.001".
ERROR: Could not validate the viability of updating from B.11.23:HPUX11i-OE
HPUX11i-OE-MC to HPUX11i-BOE.
ERROR: The script "/var/adm/sw/pre_update/update_ok.001" returned a value of "1" (ERROR)
* Analysis Summary
- Reboot needed: Yes
- Kernel build needed: Yes
- Install: 58 bundles 1067 filesets
- Update: 49 bundles 888 filesets
* Analyzing Software To Be Installed failed with 2 errors.

======= 03/25/10 14:01:09 TST END Operating Environment Update failed with 2 errors. (user=root) (jobid=000001)

ERROR: SWM terminated with errors without rebooting the system. See
/var/opt/swm/swm.log for details.
NOTE: One or more errors encountered. Take appropriate corrective action
and re-run update-ux to complete the update.

======= Thu Mar 25 14:01:10 TST 2010 END update-ux


Aungshu

4 REPLIES
Dennis Handly
Acclaimed Contributor

Re: update-ux failed

>HPUX11i-OE-MC B.11.23.0712 HP-UX Mission Critical Operating Environment Component
>I want to upgrade it to HPUX11i-BOE.

Looks like you want to go backwards, from 11.23 to 11.11? (Or did it forget to repeat B.11.23?)
And from MCOE to BOE, which is also backwards.
Aungshuman Paul
Regular Advisor

Re: update-ux failed

Actually I have some confusion from the output swlist -l bundle | grep OE.

Which operating environment currently the system has foundation OE or MC-OE ?


And I want to upgrate it to 11iv3 BOE.

Any suggestion?
Dennis Handly
Acclaimed Contributor
Solution

Re: update-ux failed

>Which operating environment currently the system has foundation OE or MC-OE?

I assume you have MC-OE, the one with the most features.

>And I want to upgrade it to 11iv3 BOE.

Perhaps it thinks that it is not allowed to remove features?

Aungshuman Paul
Regular Advisor

Re: update-ux failed

So is there any way to remove MOE and use only FOE. then try to upgrade it to 11i v3 BOE.


Wait for your valuable feedback.