System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

updating HP-UX B.11.23i to install Websphere 6.1

SOLVED
Go to solution
s0mbriks
Occasional Contributor

updating HP-UX B.11.23i to install Websphere 6.1

during the Websphere installation process tis installer warns me about some patches:

Detected HP-UX 11.23, but the following operating system patches are missing:
Level: B.11.23.0603.040a Description: Applications Quality Pack Bundle for HP-UX 11i v2, March 2006
Level: B.11.23.0603.040a Description: Base Quality Pack Bundle for HP-UX 11i v2, March 2006

so, i go and run a perl script which generates a file called inventory.xml and i use it to know what i already have installed and to browse other updates.

but when i finally find what i have to download it came with dependencies and those dependencies have dependencies too;

for now i already downloaded those files:

PHCO_38637 PHKL_34546 PHKL_37619 PHKL_37657 PHKL_38364 PHNE_36575
PHCO_38717 PHKL_36319 PHKL_37653 PHKL_37777 PHKL_39902 PHNE_39387
PHKL_31500 PHKL_36320 PHKL_37654 PHKL_38151 PHKL_40094
PHKL_32637 PHKL_36668 PHKL_37655 PHKL_38313 PHKL_40177
PHKL_33820 PHKL_36669 PHKL_37656 PHKL_38315 PHKL_40487

but i still unable to install it, because even if is unpack, do swreg -l depot and then swinstall -s \* if fails saying that depot "x" have dependency "y" and the process of search and download starts again.

is there any other easier way to find the update that i need?

thanks in advance.
8 REPLIES
James R. Ferguson
Acclaimed Contributor

Re: updating HP-UX B.11.23i to install Websphere 6.1

Hi:

Install and use the Software Assistant tool (SWA). Fetch it from:

http://www.hp.com/go/swa

See here for some suggestions for using it:

http://forums.itrc.hp.com/service/forums/questionanswer.do?threadId=1371067

The tool will analyze your server; download the patches meeting your criteria; and create a software depot for use with 'swinstall'.

Regards!

...JRF...
sombriks
Advisor

Re: updating HP-UX B.11.23i to install Websphere 6.1

Thanks for the answer James, the ling gave me a forbidden message, but i'll find a way to get it,
Torsten.
Acclaimed Contributor

Re: updating HP-UX B.11.23i to install Websphere 6.1

If your server are not allowed to access the internet, consider to download the bundles, transfer and install.

Left column on this page -> patch database

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
James R. Ferguson
Acclaimed Contributor

Re: updating HP-UX B.11.23i to install Websphere 6.1

Hi (again):

> If your server are not allowed to access the internet, consider ...

Consider that SWA supports direct Internet access or access through a proxy server.

In addition, you can setup one server which has direct or indirect access and then use that server to perform the work for others. See Patrick's response and script in this thread:

http://forums.itrc.hp.com/service/forums/questionanswer.do?threadId=1334542

Regards!

...JRF...
sombriks
Advisor

Re: updating HP-UX B.11.23i to install Websphere 6.1

allow me ask one more thing (thanks you all which answered, i'm going to give points to you all when the bundle dl ends... for some silly reason i have 2 accounts)


on the "selected patch list" page (patch database > bundle main > release index > release > bundle page > selected patch list) i have some PHCO files and at the end the bundle itself.

are those files inside bundle or do i need to download those ones too?

thanks again.
Steven E. Protter
Exalted Contributor
Solution

Re: updating HP-UX B.11.23i to install Websphere 6.1

Shalom,

If this is a websphere process, it might not be smart enough to know you have a later QPK bundle.

You would be ill advised to dig up or download this:
Level: B.11.23.0603.040a Description: Applications Quality Pack Bundle for HP-UX 11i v2, March 2006

The statement really means this QPK or newer.

so go to http://itrc.hp.com
patch database
HP-UX

There is a link for Major patch sets.

Download a QPK less than a year old and install that.

Take all dependencies.

Then you can add patches to the set individually and always take their dependencies.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Torsten.
Acclaimed Contributor

Re: updating HP-UX B.11.23i to install Websphere 6.1

The page lists the contents of the bundle and patches newer than the bundled versions:

http://www13.itrc.hp.com/service/patch/depotPage.do?BC=main|releaseIndexPage|releasePage{0912-11.23}|&depotId=QPK1123:B.11.23.0912.082

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
James R. Ferguson
Acclaimed Contributor

Re: updating HP-UX B.11.23i to install Websphere 6.1

Hi (again):

> on the "selected patch list" page (patch database > bundle main > release index > release > bundle page > selected patch list) i have some PHCO files and at the end the bundle itself. are those files inside bundle or do i need to download those ones too?

No, these are simply, as noted, the "Complete Bundle Contents for QPKAPPS(B.11.23.0912.082) [and] For your reference, the below table lists all patches included in the bundle."

Checking the depot ( QPK1123(B.11.23.0912.082)
released: 2009/12/01 ) brings it and the replacement patches pre-marked below it.

Regards!

...JRF...