System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

utomountd[1078]: match_addr: getaddrinfo failed

 
Aamir14
Regular Advisor

utomountd[1078]: match_addr: getaddrinfo failed

Hi,

 

I found the error message in syslog.log file.

 

i trouble shoot some basic commands.

 

prodata2#tail -100000 /var/adm/syslog/syslog.log |grep failed
Apr 23 18:10:07 prodata2 automountd[1078]: match_addr: getaddrinfo failed: host nor service provided, or not known
Apr 23 18:10:53 prodata2 automountd[1078]: match_addr: getaddrinfo failed: host nor service provided, or not known
Apr 24 15:30:18 prodata2 automountd[1078]: match_addr: getaddrinfo failed: host nor service provided, or not known
Apr 24 15:30:29 prodata2 automountd[1078]: match_addr: getaddrinfo failed: host nor service provided, or not known
Apr 25 11:06:10 prodata2 sshd[17624]: error: PAM: Authentication failed for root from prodata1
ps -ef | grep automount
    root  1078     1  0  Apr 22  ?         0:21 /usr/sbin/automountd
    root 29439 19339  0 11:25:55 pts/0     0:00 grep automount

more /etc/auto_master
/net -hosts -nosuid,soft,nobrowse

 

after reboot  the server automountd  message there

Kindly help me.

what,s a problem and why this message shown on syslog file again and again

 

Thanks

Aamir 

5 REPLIES
RAJD1
Valued Contributor

Re: utomountd[1078]: match_addr: getaddrinfo failed

Hi Aamir,

 

As per the below message 'getaddrinfo faled' messages is  automountd related. Check you automount configurations. ls -l /etc/*auto*  

 

Also check this out:

http://h30499.www3.hp.com/t5/System-Administration/match-addr-getaddrinfo-failed-host-nor-service-provided-or-not/td-p/4748973

 

Hth,

Raj D.

Aamir14
Regular Advisor

Re: utomountd[1078]: match_addr: getaddrinfo failed

Hi,

 

 

prodata2#more /etc/auto_master
/net -hosts -nosuid,soft,nobrowse
prodata2#more /etc/auto_parms.log
Apr 22 13:22:00: Mounting filesystems ...
Apr 22 13:22:03: The /tmp/EFI_SYSINFO.txt file does not exist.
Apr 22 13:22:03: No reply received (or DHCP disabled) for: lan0
Apr 22 13:22:03: DHCP is disabled for: lan0
Apr 22 13:22:03: No reply received (or DHCP disabled) for: lan2
Apr 22 13:22:03: DHCP is disabled for: lan2
prodata2#more /etc/auto_parms.log.old
Apr 22 13:17:18: Information: /sbin/auto_parms execution was stopped.
Apr 22 13:17:18: /sbin/auto_parms may only execute from /sbin/rc during
Apr 22 13:17:18: the initial transition from run level 'S' ( see init(1M) ).
prodata2#
prodata2#
prodata2#ll /net/
total 0
prodata2#
Thanks for given the issue link but,
I am not understand the how to solved the problem and stop the error message.
Thanks
Aamir 
Matti_Kurkela
Honored Contributor

Re: utomountd[1078]: match_addr: getaddrinfo failed

more /etc/auto_master
/net -hosts -nosuid,soft,nobrowse

 This default configuration of automountd attempts to make /net sort of similar to Network Neighborhood on Windows systems.

 

For example, if you run "ls /net/prodata1", the automounter would attempt to connect the host "prodata1" and see if it had any exported NFS filesystems available for this host. If found, they would be presented as sub-directories of /net/prodata1.

 

For example, if the host "prodata1" had /export as a NFS exported filesystem, you could access it from prodata2 with commands like "ls /net/prodata1/export".

 

The disadvantage of this set-up is that if any user makes a typo when accessing /net, e.g. trying to access a host that does not exist, the automountd will emit an error message in the system log.

 

You don't seem to have any other lines in /etc/auto_master, so the question is: are you using /net with your applications? If not, you can disable the automounter: run "sh /sbin/init.d/autofs stop", then edit /etc/rc.config.d/nfsconf and change AUTOFS=1 to AUTOFS=0 to prevent it from restarting at system boot.

 

MK
Aamir14
Regular Advisor

Re: utomountd[1078]: match_addr: getaddrinfo failed

Hi Matti,

 

Thanks for helpfull advice.

 

But the perticular server is a ignite server. and other server are clients of ignite server.and clients server are uses the NFS .

 

 

please help me. i stop the autofs or not.


Thanks

 

 

 

Matti_Kurkela
Honored Contributor

Re: utomountd[1078]: match_addr: getaddrinfo failed

Autofs is an optional part of NFS, and Ignite-UX uses only basic NFS, not autofs.

 

You can disable autofs if your Ignite server configuration does not include any /net/* pathnames. The default configuration of Ignite-UX does not use /net/* in any way, so unless you've customized your Ignite-UX installation, there should be no problems with disabling autofs.

 

Leave the other NFS components (NFS_CORE, LOCKMGR, NFS_CLIENT and NFS_SERVER variables in /etc/rc.config.d/nfsconf) in their current state.

MK