Re: vg00

 
Siju Vadakkan
Trusted Contributor

vg00

vgcfgrestore -n vg00 /dev/rdsk/c2t1d0
vgcfgrestore: Mismatch between the backup file and the running kernel:
Kernel indicates 3 disks for "/dev/vg00"; /etc/lvmconf/vg00.conf indicates 2 disks.
Cannot proceed with the restoration. Deactivate the Volume Group and try again.




4 REPLIES 4
Siju Vadakkan
Trusted Contributor

Re: vg00

# vgcfgrestore -n /dev/vg00 -l
Volume Group Configuration information in "/etc/lvmconf/vg00.conf"
VG Name /dev/vg00
---- Physical volumes : 2 ----
/dev/rdsk/c2t1d0 (Bootable)
/dev/rdsk/c2t0d0 (Bootable)
#
Rajeev  Shukla
Honored Contributor

Re: vg00

It usually happens when you replace the defective disk and somehow the lvmtab files does not update the information.

Now first is to make sure you surely have only 2 disks in vg00 and the kernel is reporting it wrong.

Use the option -R with vgcfgrestore but be sure that your backup file is update
Have a look at the man pages of vgcfgrestore
where it talks about -R option.
Chris Wilkinson
New Member

Re: vg00

Hi Siju, There is also an option to the vgreduce command "-f" which will remove the old disk from LVM config so you dont get a mismatch issue. Suggest you run the vgcfgrestore then the vgreduce if you get complaints mismatches between lvmtab and the kernel.
Senthil Kumar .A_1
Honored Contributor

Re: vg00

Hi Siju,

Buzz me on Yahoo chat, once your are free.

Regards,
Senthil Kumar .A
Let your effort be such, the very words to define it, by a layman - would sound like a "POETRY" ;)