System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

vgextend: Warning: Max_PE_per_PV for the volume group (1679) too small for this PV (4799)

 
Regular Visitor

vgextend: Warning: Max_PE_per_PV for the volume group (1679) too small for this PV (4799)

HI,  Have assgined 300 Gb disk to increase my extising Logical volume, so have created physcial voulme of 300gb disk and existing logical volume has been extened . But post extended vg am getting this output VG IS TOO SMALL

while i checked in vg am getting only 107 GB remaning space ? u

Enclosed ouputs for your refernce

# vgextend ppsvg02 /dev/disk/disk291
vgextend: Warning: Max_PE_per_PV for the volume group (1679) too small for this PV (4799).
Using only 1679 PEs from this physical volume.
Volume group "ppsvg02" has been successfully extended.
Volume Group configuration for /dev/ppsvg02 has been saved in /etc/lvmconf/ppsvg02.conf
# vgdisplay -v ppsvg02
--- Volume groups ---
VG Name /dev/ppsvg02
VG Write Access read/write
VG Status available
Max LV 255
Cur LV 1
Open LV 1
Max PV 16
Cur PV 3
Act PV 3
Max PE per PV 1679
VGDA 6
PE Size (Mbytes) 64
Total PE 4317
Alloc PE 2637
Free PE 1680
Total PVG 0
Total Spare PVs 0
Total Spare PVs in use 0
VG Version 1.0
VG Max Size 1679g
VG Max Extents 26864

--- Logical volumes ---
LV Name /dev/ppsvg02/lvol1
LV Status available/syncd
LV Size (Mbytes) 168768
Current LE 2637
Allocated PE 2637
Used PV 2


--- Physical volumes ---
PV Name /dev/disk/disk249
PV Status available
Total PE 1679
Free PE 0
Autoswitch On
Proactive Polling On

PV Name /dev/disk/disk262
PV Status available
Total PE 959
Free PE 1
Autoswitch On
Proactive Polling On

PV Name /dev/disk/disk291
PV Status available
Total PE 1679
Free PE 1679
Autoswitch On
Proactive Polling On


# diskinfo /dev/disk/disk291
diskinfo: Character device required
# diskinfo /dev/rdisk/disk291
SCSI describe of /dev/rdisk/disk291:
vendor: HITACHI
product id: OPEN-V
type: direct access
size: 314572800 Kbytes
bytes per sector: 512

2 REPLIES 2
Honored Contributor

Re: vgextend: Warning: Max_PE_per_PV for the volume group (1679) too small for this PV (4799)

Since this a VG version 1.0 volume group, your new disk is too big for your VG. 

The current MAX PE PER PV (maximum # of physical extents per physical volume) is 1679.  No device can have more physcal extents than that.

 

Your PE size is 64 MB.  So, the biggest disk you can have in the VG is 64 (PS Size) x 1679 (MAX PE PER PV) which comes out to 107456 MB.

 

Your new PV, which is 4799 extents or 307136 MB is way too big for this VG.

 

In order to extend the VG you'll need to create new PVs that are 107456 MB (1679 PEs) or smaller.

 

Your other option is to try converting this VG to a version 2.2 VG, which eliminates a lot of issues from version 1.0 VGs.

 

Migrating to VG version 2.2 can be done with the 'vgversion' command.  I recommend reviewing the man page for vgversion before trying to convert.

 

To see if your VG can be converted to 2.2:

 

# vgversion -r -V 2.2 /dev/ppsvg02 

To do the actual conversion just omit the '-r' option.

HPE Pro

Re: vgextend: Warning: Max_PE_per_PV for the volume group (1679) too small for this PV (4799)

Greetings,

You may use "vgmodify" to increase Max_PE_per_PV to make use of max capacity of the disk(s) is in the VG.

Please refer the detailed documenation at https://support.hpe.com/hpesc/public/docDisplay?docLocale=en_US&docId=c01920387

Or you may refer the man page of vgmodify (1M)

Here are some of the commands I suggest: 

Key options to note:

-r = review
-a = to change online
-n = enable renumbering

Use the vgmodify -t option to determine the available settings that best meet your needs.

Note: You can run the vgmodify –t operation against an activated or deactivated volume group.

# vgmodify –t –v ppsppsvg02 # Table without physical extent renumbering (For more information, see the Physical extent renumbering (-noption) and pvmove enhancement section in the above document)

In your case, disk249 has no free PEs. So, it may need renumbering. If so, check:

# vgmodify –t –v –n ppsppsvg02 # Table with physical extent renumbering. Henceforth, I will use -n, meaning enabling renumbering. 

Check the optimized settings:

# vgmodify –r -a -o ppsppsvg02 # Since renumbering is required, you will need to use -p and -e. But try the following first:

# vgmodify -v –r –a –E -n ppsvg02

If this does not work, try:

# vgmodify –r -n –p 150 –e 2000 –v ppsvg02

NOTE : In the above syntax I used "-r" to review. To execute them, you need to remove "-r"

I hope it helps. Please keep us posted. 

Warm regards,


I am a HPE Employee

Accept or Kudo