HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

vgmodify on 11.31 - vg active error

 
jitjose
Advisor

vgmodify on 11.31 - vg active error

Hi,

 

I am unable to run a vgmodify command online.

 

#vgextend cpod_db03 /dev/disk/disk4519
vgextend: Warning: Max_PE_per_PV for the volume group (4095) too small for this PV (4096).
Using only 4095 PEs from this physical volume.
Volume group "cpod_db03" has been successfully extended.
Volume Group configuration for /dev/cpod_db03 has been saved in /etc/lvmconf/cpod_db03.conf

 

#vgmodify -e 4096 /dev/cpod_db03
vgmodify: The volume group "/dev/cpod_db03" is active on this system.
Cannot perform requested change.

 

vg version is 1.0.0

 

#vgdisplay cpod_db03
--- Volume groups ---
VG Name /dev/cpod_db03
VG Write Access read/write
VG Status available
Max LV 255
Cur LV 1
Open LV 1
Max PV 64
Cur PV 4
Act PV 4
Max PE per PV 4095
VGDA 8
PE Size (Mbytes) 32
Total PE 16380
Alloc PE 12285
Free PE 4095
Total PVG 0
Total Spare PVs 0
Total Spare PVs in use 0
VG Version 1.0.0

 

server os - HP-UX B.11.31 U ia64 2491326431 unlimited-user license

 

Please let me know withough deactivating the vg, why I am unable to do a vgmodify on the fly even though the server OS is 11.31 and LVM version is 1.0

 

Thanks in advance

3 REPLIES
Torsten.
Acclaimed Contributor

Re: vgmodify on 11.31 - vg active error

"Online vgmodify is supported starting with the HP-UX 11i v3 September 2008 Update release. "

Is your version older?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
jitjose
Advisor

Re: vgmodify on 11.31 - vg active error

 

Thanks, yes its March 2008. If I update the bundles to latest version, will it be supported.

Torsten.
Acclaimed Contributor

Re: vgmodify on 11.31 - vg active error

Create an ignite backup first.
Take the latest update release (2013) DVD set and run "update-ux".

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!