cancel
Showing results for 
Search instead for 
Did you mean: 

vlan tagging issue

 
MikeL_4
Super Advisor

vlan tagging issue

I am trying to setup VLAN tagging on a server for the first time...
I was told by network that the VLAN ID's were:
192.168.131.129 VLAN ID 868
155.90.164.4 VLAN ID 922

When I try to restart the network I am receiving the following errors:

Bringing up interface eth0.868: SIOCGIFFLAGS: No such device
ERROR: Trying to add VLAN #868 to IF -:eth0:- error: Invalid Argument [ FAILED ]

Bringing up interface eth0.922: SIOCGIFFLAGS: No such device
ERROR: Trying to add VLAN #922 to IF -:eth0:- error: Invalid Argument [ FAILED ]

My ifcfg-eth0 files are setup as follows:

=> cat ifcfg-eth0
DEVICE=eth0
ONBOOT=yes

=> cat itcfg-eth0.868
DEVICE=eth0.868
BOOTPROTO=static
BROADCAST=192.168.131.191
HWADDR=00:22:19:2C:2F:17
IPADDR=192.168.131.129
NETMASK=255.255.255.192
NETWORK=192.168.131.128
ONBOOT=yes
TYPE=Ethernet
VLAN=yes

=> cat itcfg-eth0.922
DEVICE=eth0.922
BOOTPROTO=static
BROADCAST=155.90.164.61
HWADDR=00:22:19:2C:2F:17
IPADDR=155.90.164.4
NETMASK=255.255.255.192
NETWORK=155.90.164.0
ONBOOT=yes
TYPE=Ethernet
VLAN=yes

Any ideas as to the issue ??
1 REPLY
Steven E. Protter
Exalted Contributor

Re: vlan tagging issue

Shalom,

In this context you may need a GATEWAY statement in each VLAN.

Nothing stands out in the configuration files.

There may be an external issue preventing communication with the VLAN.

you might want to run tcpdump or wireshark on another host to see if you can detect the packets moving across the lan.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com