HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

vmunix: file: table is full---- issue

 
Viney Kumar
Regular Advisor

vmunix: file: table is full---- issue

Hi

We have HP-ux system with 24 GB memory. After starting the database, "table is full" messaging getting in syslog.log file. current value of kernal parameter are:--

nfile 61308 - (16*(NPROC+16+MAXUSERS)/10+32+2*(NPTY+NSTRPTY+NSTRTEL))
maxfiles 4096 - 4096
maxfiles_lim 4096 Y 4096
maxusers 4096 - 4096
nclist 65636 - (100+16*MAXUSERS)
ninode 37800 - ((NPROC+16+MAXUSERS)+32+(2*NPTY))
nproc 33536 - (768+8*MAXUSERS)
maxdsiz 23622320128 - 23622320128
maxdsiz_64bit 23622320128 - 23622320128
maxssiz 0x17f00000 - 0X17F00000
maxssiz_64bit 0x40000000 - 0X40000000
dbc_max_pct 10 - 10
dbc_min_pct 5 - 5




swapinfo -atm
Mb Mb Mb PCT START/ Mb
TYPE AVAIL USED FREE USED LIMIT RESERVE PRI NAME
dev 1024 0 1023 0% 0 - 1 /dev/vg00/lvol2
dev 8000 0 8000 0% 0 - 1 /dev/vg00/lvol9
dev 8000 0 8000 0% 0 - 1 /dev/vg00/lvol12
reserve - 3684 -3684
memory 18705 2596 16109 14%
total 35729 6280 29448 18% - 0 -



Please suggest how much value increase for nfile parameter or any else to resolve out this issue


thanks

6 REPLIES
Pete Randall
Outstanding Contributor

Re: vmunix: file: table is full---- issue

Increase nfile - double it or triple it or more. It's only a tiny increase in the size of the kernel to accomodate the enlarged table.


Pete

Pete

Re: vmunix: file: table is full---- issue

What HP-UX version are you using?
You could just change nfile to 90000.

Your maxdsiz seems bogus, with a value of 23,622,320,128, the same as maxdsiz_64bit.
Bill Hassell
Honored Contributor

Re: vmunix: file: table is full---- issue

> nfile 61308 - (16*(NPROC+16+MAXUSERS)/10+32+2*(NPTY+NSTRPTY+NSTRTEL))

nfile is your problem. It is the maximum number of files (including network ports) that can be opened at the same time. Run sam and replace the kernel parameter (with all the formula junk) nfile with 100000 (100k). If you are running 11.23 or 11.31, the change is immediiate. Otherwise, for 11.11 and earlier you'll have to regenerate the kernel and reboot (sam will do this for you).

Monitor the size of nfile and nproc with the command: sar -v 1 1



Bill Hassell, sysadmin
Steven E. Protter
Exalted Contributor

Re: vmunix: file: table is full---- issue

Shalom,

Formula based kernel calculations is the first thing I remove from a system after cold install.

They are simply not real world relevant.

nfiles and the maxfiles parameters need an increase to realistic levels.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Viney Kumar
Regular Advisor

Re: vmunix: file: table is full---- issue

Thanks for all

Yesterday I was increase the nfile value.
New value is:---

nfile 92160 - 92160

but during the time of starting our data base again getting error "HP-UX Error: 23: File table overflow"

HP-UX-----version 11.11.v1


Please suggest...........

there any other parameter need to be tune?????

Re: vmunix: file: table is full---- issue

>Yesterday I was increase the nfile value. nfile 92160 - 92160
>during the time of starting our data base again getting error "HP-UX Error: 23: File table overflow"

You could try doubling it again. But if that fails, there is probably something wrong with your application??