HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

vmware issues

 
SOLVED
Go to solution
Adithyan
Frequent Advisor

vmware issues

hi friends,

My server is Vmware 2.5 series with a kernel of 2.4 vmnix

in the mii-tool output is:
[root@esxalp07 boot]# mii-tool eth0
eth0: negotiated, link ok

What is the speed? whether HD or FD? how to find? How to change the speed and duplex settings?

Can anybody guide with me the exact syntax?

I need to turn off negotiation and 100/FD.

there is no ethtool available.

Thanks in advance!
Keen to learn HP UX
7 REPLIES
Steven E. Protter
Exalted Contributor

Re: vmware issues

Shalom,

If mii-tool shows this answer, then you need to install ethtool onto the system to check speed and negotiation status.

It's not magic, you just need to install the tool.

You have not said which distribution you are using. If you do that, it will be possible to provide installation instructions.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Ivan Ferreira
Honored Contributor

Re: vmware issues

I don't think that vmware virtual interfaces will work with ethtool.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Steven E. Protter
Exalted Contributor

Re: vmware issues

Yes Ivan is right,

Big oops to me.

dmesg should give you the data though.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
larstr
Advisor

Re: vmware issues

The Service Console of ESX 2.5 is derived from Redhat 7.2.

Be aware that mii-tool on ESX2.x is not Gigabit aware.

For gigabit networks you're normally best off using auto/auto on both the nic and the switch.

Lars
skt_skt
Honored Contributor

Re: vmware issues

This is how i check the network is OK.If the vmtools are running i am OK.

[root@adela114p init.d]# ./vmware-tools status
vmware-guestd (pid 390) is running...
[root@adela114p init.d]# pwd
/etc/init.d


How to change speed/duplex

i hope /etc/sysconfig/network-scripts/ifcfg-eth0 is aplicable here too

ETHTOOL_OPTS=â speed 100 duplex full autoneg offâ
Adithyan
Frequent Advisor

Re: vmware issues

Hi Friends,

I found the settings from dmesg.

I was not talking abt the virtual instances. It was abt the base server.

Thanks all.
Keen to learn HP UX
Sac_3
Frequent Advisor
Solution

Re: vmware issues

Hi Adityan,

1.) mii-tool is not gigabit capable.
2.) As per the output of "mii-tool eth0", it is evident that eth0 is set to GIGABIT (1000)
3.) If you have to force speed/duplex settings for NIC cards in VMWARE base box, you can do it from /etc/modules.conf file.
Please check the below link from VMWARE, explains how to "Setting Network Adapter Speed in ESX Server"

http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=813&sliceId=1&docTypeID=DT_KB_1_1&dialogID=16305666&stateId=0%200%2016303480

Explanation:
============
presume that ur modules.conf file looks like this:

cat /etc/modules.conf
alias parport_lowlevel parport_pc
alias eth0 bcm5700
alias eth1 bcm5700
alias eth2 e1000
alias eth3 e1000
alias eth4 e1000
alias eth5 e1000
alias eth6 e1000
alias eth7 e1000


options bcm5700 line_speed=1000,1000 auto_speed=1,1 full_duplex=1,1

1.) line_Speed=1000,1000 --> first for eth0 after "," eth1. so eth0 is set to 1000 and eth1 is set to 1000

2.)auto_speed=1,1 --> 0 means autoneg OFF, 1 means autoneg on (this is also for eth0 and eth1)

3.) full_duplex=1,1 --> 0--means half duplex and 1 means full duplex.


Once your done with settings reboot the server.

Hope this helps. :o)

Regards,
SaC

P.S: Best way of thanking in this forum is to assign points.