System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

we are not able to print special character i.e "¡" as column separator

SOLVED
Go to solution
chindi
Respected Contributor

we are not able to print special character i.e "¡" as column separator

 Team,

Hpux 11.23  we have got a strange requirement from one of our report team.

In AIX they are able to print special character "¡" how can we achieve the same in HPUX ?

8 REPLIES
chindi
Respected Contributor

Re: we are not able to print special character i.e "¡" as column separator

ASCII code 173 in Spanish

chindi
Respected Contributor

Re: we are not able to print special character i.e "¡" as column separator

cd /usr/lib/nls

1) C/

2) POSIX/
3) README.nls.10.01
4) arabic-w/
5) arabic/
6) bulgarian/
7) chinese-s/
8) chinese-t/
9) config
10) csr/
11) czech/
12) greek/
13) hebrew/
14) hungarian/
15) iconv/
16) japanese/
17) katakana/
18) korean/
19) loc/
20) msg/
21) polish/
22) rumanian/
23) russian/
24) serbocroatian/
25) slovene/
26) thai/
27) turkish/

As you can see Spanish is missing , how can i install the same ?

Dennis Handly
Acclaimed Contributor

Re: we are not able to print special character i.e "¡" as column separator

>ASCII code 173 in Spanish

 

Are you sure?  While you can use ALT 173 to get the char, the correct code is ALT 0161 which matches to 0xa1.

And 173 is a dash.  See /usr/lib/loc/charmaps/

https://en.wikipedia.org/wiki/Inverted_question_and_exclamation_marks

 

>As you can see Spanish is missing

 

This was never there.  You can check your locales with 'locale -a".  And Spanish starts with "es_".

Where are you trying to "print' it?  To a screen or a printer?

Which locale are you using?

chindi
Respected Contributor

Re: we are not able to print special character i.e "¡" as column separator

Hi we are trying to print in sqlplus prompt of Oracle 9i.

When tried through ALT 0161 its giving ! mark.

Need to check locale settings of Oracle user.

oracle /home/oracle >locale
LANG=
LC_CTYPE="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_MESSAGES="C"
LC_ALL=

 

Dennis Handly
Acclaimed Contributor

Re: we are not able to print special character i.e "¡" as column separator

>Need to check locale settings of Oracle user.

>LC_CTYPE="C"

 

These won't work.

 

chindi
Respected Contributor

Re: we are not able to print special character i.e "¡" as column separator

Please guide then what is to be checked.

Dennis Handly
Acclaimed Contributor
Solution

Re: we are not able to print special character i.e "¡" as column separator

>Please guide then what is to be checked.

 

You need to pick a locale that has the character that you want.

<exclamation-down> is in these charsets: roman8.cm, iso88591.cm, iso885915.cm, iso88599.cm, turkish8.cm and utf8.cm

In the iso* charmaps the char is: \xa1

In roman8 and turkish it is: \xb8

In utf8 it is \xc2\xa1

(LC_CTYPE=C supports roman8)

 

And the most important thing, what characters sets does your printer support?

chindi
Respected Contributor

Re: we are not able to print special character i.e "¡" as column separator

Hi Dennis,

Thanks for your response.

By print i mean "Want to use it as a separator" in one of reports generated by running SQL query.

We do not want to print it on paper.

Thanks will try those settings.