System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

wsio_claim init failed isc=0x113b221c00 name=ciss

SOLVED
Go to solution
arkie
Super Advisor

wsio_claim init failed isc=0x113b221c00 name=ciss

Hi All,

Syslog.log/dmesg is reporting the following error in one of our rp4440s:-

Jun 10 16:59:33 srmdev vmunix: wsio_claim init failed isc=0x113b222400 name=ciss

Further, it is being observed that ioscan is taking significantly long to produce the output.

Can the two be related? How do I look into the ciss initialization failure?

Can anyone provide me with some insight. Thanks!
9 REPLIES
arkie
Super Advisor

Re: wsio_claim init failed isc=0x113b221c00 name=ciss

There are two such messages at the end of `dmesg` output:-

wsio_claim init failed isc=0x113b221c00 name=ciss
wsio_claim init failed isc=0x113b222400 name=ciss

What I can observe is that, there are no SmartArray controllers in the system. Still, the ciss module is loaded by the kernel - can I modify it to the unused state. The wsio module on which ciss is dependant, is failing to initialize ciss.

Can this possibly have an effect on ioscan's processing ?

I really need some from you experts out there...
arkie
Super Advisor

Re: wsio_claim init failed isc=0x113b221c00 name=ciss

Its a pity...I cannot get some answers from someone, when there are so knowledgeable people like you out there...
VK2COT
Honored Contributor
Solution

Re: wsio_claim init failed isc=0x113b221c00 name=ciss

Hello,

Some details are missing from your
question.

I assume your OS is HP-UX 11.11.
If so, there are three Mass Storage Driver
Bundles that utilise ciss driver I can think
of (this is straight from my brain so I
could be missing some more):

RAID-01 A7143A RAID160 SA SCSI Controller
RAID-01 A9890A Smart Array 6402 Controller
RAID-01 A9891A Smart Array 6404 Controller

Do you have any of them?

The ioscan(1M) taking long time makes me
believe that you have a problem.
Are there any devices in state "NO_HW" or
"UNCLAIMED"?

And be aware that these forums are
managed by volunteers. Nobody is paid
for it.

On top of it, it was a weekend, and many
people do the right thing - enjoy it
with friends and families. So, not getting
any response initially does not mean you
were ignored :)

In some regions, today (Monday) is a public holiday. For example, in Australia. We call
it Queen's Birthday. So, people in this region were not working today...

Cheers,

VK2COT
VK2COT - Dusan Baljevic
arkie
Super Advisor

Re: wsio_claim init failed isc=0x113b221c00 name=ciss

Hi Dusan,

Thanks a lot for your response!

OS is B.11.31 (recently installed)

We have RAID-01 version B.11.31.1003 which supports A7143A/A9890A/A9891A

'ioscan |grep NO_HW' & 'ioscan |grep UNCLAIMED' did not produce any output.

VK2COT
Honored Contributor

Re: wsio_claim init failed isc=0x113b221c00 name=ciss

Hello,

Now we have a bit more information.

What do these commands say:

# sautil /dev/cissX

# sautil /dev/cissX stat

# sautil /dev/cissX get_trace_buf

# sautil /dev/cissX get_fw_err_log

# saconfig /dev/cissX

where cissX is whatever exists on your server.

Cheers,

VK2COT
VK2COT - Dusan Baljevic
Raj D.
Honored Contributor

Re: wsio_claim init failed isc=0x113b221c00 name=ciss

Arkie,

Check this out:
Hoep you will find the answer.

http://forums13.itrc.hp.com/service/forums/questionanswer.do?&threadId=1153232


Hth,
Raj.
" If u think u can , If u think u cannot , - You are always Right . "
arkie
Super Advisor

Re: wsio_claim init failed isc=0x113b221c00 name=ciss

Dusan,

There is no device file /dev/cissX.

This is all in the o/p of 'find / -name ciss* -print' :-

/stand/current/bootfs/stand/current/mod/ciss
/stand/current/mod/ciss
/stand/current/mod/ciss.prep
/stand/last_install/mod/ciss
/stand/last_install/mod/ciss.prep
/stand/last_install/bootfs/stand/current/mod/ciss
/stand/backup/mod/ciss
/stand/backup/mod/ciss.prep
/stand/backup/bootfs/stand/current/mod/ciss
/opt/raidsa/bin/ciss.pl
/opt/raidsa/bin/ciss_insf
/usr/sbin/olrad.d/ciss
/usr/conf/mod/ciss
/usr/conf/mod/ciss.prep
/sbin/init.d/ciss


VK2COT
Honored Contributor

Re: wsio_claim init failed isc=0x113b221c00 name=ciss

Hello,

It seems then the module is not needed or used.
I would think it is worth trying to unload it.

Cheers,

VK2COT
VK2COT - Dusan Baljevic
arkie
Super Advisor

Re: wsio_claim init failed isc=0x113b221c00 name=ciss

Hi Dusan, Raj

Thanks for your time & support.

It was a mere case of card at 0/2/1 not seating properly, becoz' of which, ext_bus at 0/2/1/0/4/0 was showing UNCLAIMED.

Now, after removing & reseating the card, the problem seems to have disappeared. `ioscan` is back in producing o/p (in approx 4-5 secs), which i assume is normal (w.r.t. other similar systems in this facility. `dmesg|grep wsio` ---> no o/p && `grep ciss /var/adm/syslog/syslog.log` says:-

Jun 17 16:47:21 srmdev vmunix: Module ciss is put into ramfs:load time: driver_install, state: loaded
Jun 17 16:47:21 srmdev vmunix: 0/2/1/0/4/0 ciss

/dev/ciss4 is there and this is good news.

Dusan, i'll run the saconfig and sautil commands you sent earlier.

Thanks!