HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

xmanager is not login

 
SOLVED
Go to solution
Mousa55
Super Advisor

xmanager is not login

Hi,

My OS is HP-UX 11.v23 and I tried to login to my server (rp8420) through xmanager, but after login the
User name and password the xmanager is not login and hanging, is not coming to logging prompt.

Please help me.



Thanks & kind Regards
13 REPLIES
Avinash20
Honored Contributor

Re: xmanager is not login

To get the correct hints, look into start*.log which will be available in the home directory of the server

It might be simple permission issue of /tmp
Check if /tmp is having 1777 permission
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Jeff Schussele
Honored Contributor
Solution

Re: xmanager is not login

Check your /etc/inetd.conf file.
There are several X services listed in there that must not be commented out for X logins to be available.

HTH,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
Mousa55
Super Advisor

Re: xmanager is not login

Hi all,

the problem, when i login in xmanager the command prompt is not coming and the xmanager is hang-up on a one window it is " a starting the common Desktop Environment"
how to solve this problem


Thanks & kind Regards

Re: xmanager is not login

Best way to start to diagnose these sorts of problems is to run "Doctor Desktop"!

/usr/contrib/bin/X11/dr_dt

and fix any issues reported there...

HTH

Duncan

HTH

Duncan
Mousa55
Super Advisor

Re: xmanager is not login

Hi All,

i am run the "Doctor Desktop"! but i don't see any error but only 5 warning.
and you can find the attached file for the output of this command.

Thanks & kind Regards

Re: xmanager is not login

well no major issues there (although you need to do something about those permissions - particularly /etc/hosts and /var/adm/inetd.sec)

What user are you trying to connect as? go to that users home directory and there should be a ".dt" directory with some log files in... se if any of those have been written to when you tried to login...

HTH

Duncan

HTH

Duncan
Mousa55
Super Advisor

Re: xmanager is not login

Hi All,

this the logs for startlog

ruxdevap# /.dt> more startlog
--- Mon Apr 6 10:16:49 WAT 2009
--- /usr/dt/bin/Xsession starting...
--- Xsession started by dtlogin
--- sourcing //.dtprofile...
--- sourcing /usr/dt/config/Xsession.d/0010.dtpaths...
--- sourcing /usr/dt/config/Xsession.d/0020.dtims...
--- sourcing /usr/dt/config/Xsession.d/0030.dttmpdir...
--- sourcing /usr/dt/config/Xsession.d/0040.xmbind...
--- sourcing /usr/dt/config/Xsession.d/0060.srcsysenv...
--- starting /usr/dt/bin/dthello &
--- starting /usr/dt/bin/dtsearchpath -ksh
--- starting /usr/dt/bin/dtappgather &
--- execing /usr/dt/bin/dtsession -session display-home...
not sourcing //.profile (see //.dtprofile)
X connection to 10.8.33.89:1.0 broken (explicit kill or server shutdown).

and this the logs of sessionlogs

ruxdevap# /.dt/sessionlogs> ll
total 192
-rw-rw-r-- 1 root sys 132 Apr 5 09:29 ruxdevap_DISPLAY=10.15.1.208:2
-rw-rw-r-- 1 root sys 132 Apr 5 11:08 ruxdevap_DISPLAY=10.8.33.22:0
-rw-rw-r-- 1 root sys 132 Mar 29 12:19 ruxdevap_DISPLAY=10.8.33.22:1
-rw-rw-r-- 1 root sys 132 Mar 18 12:42 ruxdevap_DISPLAY=10.8.33.53:0
-rw-rw-r-- 1 root sys 132 Mar 30 14:14 ruxdevap_DISPLAY=10.8.33.53:1
-rw-rw-r-- 1 root sys 132 Apr 6 09:53 ruxdevap_DISPLAY=10.8.33.89:0
-rw-rw-r-- 1 root sys 132 Apr 5 15:00 ruxdevap_DISPLAY=10.8.33.89:1
-rw-rw-r-- 1 root sys 132 Apr 5 12:03 ruxdevap_DISPLAY=10.8.33.89:2
-rw-rw-r-- 1 root sys 132 Feb 25 09:10 ruxdevapp_DISPLAY=10.8.33.89:0
-rw-rw-r-- 1 root sys 132 Mar 16 08:25 ruxdevapp_DISPLAY=10.8.33.89:1
-rw-rw-r-- 1 root sys 132 Feb 24 12:06 ruxdevdb_DISPLAY=10.8.33.89:1
-rw-rw-r-- 1 root sys 132 Feb 24 12:19 ruxdevdb_DISPLAY=10.8.33.89:2
ruxdevap# /.dt/sessionlogs> more ruxdevap_DISPLAY=10.8.33.89:0
This session log file is currently disabled.
To enable logging, edit //.dtprofile and
remove dtstart_sessionlogfile=/dev/null line.
ruxdevap# /.dt/sessionlogs> more ruxdevap_DISPLAY=10.15.1.208:2
This session log file is currently disabled.
To enable logging, edit //.dtprofile and
remove dtstart_sessionlogfile=/dev/null line.

i am removing this line but the problem is still.

thanks
Mousa55
Super Advisor

Re: xmanager is not login

Hi All,

please find the print screen attached for xmanager hang-up.

Thanks & kind Regards

Re: xmanager is not login

Have you tried something like:

export dtstart_sessionlogfile="/tmp/mysession.log"

in /.dtprofile ?

And seeing if a logfile is created??


Presuambly it is the root user you are logging in as here?

HTH

Duncan

HTH

Duncan
Mousa55
Super Advisor

Re: xmanager is not login

Hi All,

the problem is still, and i am login in root user.

thanks

Re: xmanager is not login

so answer the question... did a log file get created when you set the parameter I sugegsted?

Duncan

HTH

Duncan
Avinash20
Honored Contributor

Re: xmanager is not login

Hi,

I like to confirm some basic things

1. Is nslookup working fine
Does /etc/nsswitch.conf exist.
If no, copy from /etc/nsswitch.files
# /etc/nsswitch.files /etc/nsswitch.conf
If yes, please see that the following entries are there

hosts: files dns
ipnodes: files dns



From the CDE login select Options -> Session -> Failsafe Session and login as root.
2) Append the following font path to the end of the catalogue= line in the font server's config file, /etc/X11/fs/config:
     /usr/dt/config/xfonts/C/
        // Set the RUN_X_FONT_SERVER environment variable to 1 in the /etc/rc.config.d/xfs file:
     RUN_X_FONT_SERVER=1
        //Start the font server:
     $ /sbin/init.d/xfs start
        // Verify that the font server has been started:
     $ ps -ef | grep xfs
3) Check permissions and ownership of the following files:
-r--r--r-- 1 bin bin 616 Jul 1 16:03 /etc/hosts
-r--r--r-- 1 root sys 1010 Jun 25 18:22 /var/adm/inetd.sec
4) Exit the failsafe session. From the CDE login select Options -> Command Line Login. When the screen turns black, press and You should get a Console Login prompt. Login as root.
5) mv $HOME/.dt $HOME/.dt.orig
mv $HOME/.dtprofile $HOME/.dtprofile.orig
Exit (to return to CDE) -
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
T G Manikandan
Honored Contributor

Re: xmanager is not login

Before you fix these, to login temporarily with your xmanager, you can choose the failsafe session with the options tab.