Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Hp SIM running on VM windows 2012 R2 VCRM not discovered on local host.

NZICEMAN
Visitor

Hp SIM running on VM windows 2012 R2 VCRM not discovered on local host.

I have deployed HP Sim on a new VM running windows 2012 R2.


As it is a VM i am unable to install Webem.


VCRM is installed and running.


I have installed PSP into the VCRM fine and have made a base line.


But when I try to Deploy I get "

Error retrieving repository. Ensure the Version Control Repository Manager (VCRM) is installed and running. Be sure a trust relationship is established with the repository device. Finally, the VCRM may not respond if it is in the process of updating its catalog. In this case simply try again later."

I have tried to "identify System" on the Hpsim server and get the following result.(see attached)

 


How do i get it to find the local VCRM so i can get this working. 

 

4 REPLIES
n0kia
Valued Contributor

Re: Hp SIM running on VM windows 2012 R2 VCRM not discovered on local host.

Hello,

From the error i see this error

Critical: There are no valid WBEM / WMI credentials for the system(s). 
        * Running WBEM rules based identification...

 so that means it couldn't authenticate to itself.

Can you verify/re-enter the credentials it's using by going to options > Security > credentials > System Credentials. After you retype it in it should do an auto reidentify which you can verify by going to tasks and logs > task results.

Check whether you see the wbem/wmi error.

Double check your proxy mapper settings > Options > Protocol Settings > Wmi mapper settings. Restart the Pegasus Wmi mapper service.

Also, if you see that it's able to work but complain about Trust. Delete both the certificate from the SMH security/ certificate page. Use HP SIM to run an Configure > Configure or repair agent task to itself to push a Trust by Cert. Re Identify the SIM server again and see if trust is there.

NZICEMAN
Visitor

Re: Hp SIM running on VM windows 2012 R2 VCRM not discovered on local host.

Thank you n0kia for your assistance.

I have tried your ideas and unfortunatly no change.

What I can say is because it is running on a VM there is no webem installed on the SIM .

When I try to install Webem it says that it has no iLo so won't install.

I think my issue is in the VCRM / SIM not seeing eacher other.

I have VCA installed but that also cant see VCRM. when I try to discover VCRM with VCA it says it can't see it.

So the system managment home page sees VCRM and VCM but nothing else can see VCRM.

n0kia
Valued Contributor

Re: Hp SIM running on VM windows 2012 R2 VCRM not discovered on local host.

Hello,

You cannot install WBEM on a Windows VM, we use windows WMi to access the information. Sometimes we use the terminology of WBEM/WMI together.

I would double check on the firewall on the CMS server. Also check what version of VCA you are using since newer version of SMH had their security cipher changed for security reasons... So it's recommend to use VCA 7.3.5.

Can you copy / paste the identification output of the SIm/VCRM server after making the change to the password? Under the system credentials, if you modify the creds, go to advance protocol link and make sure your only using the sign-in section and nothing in the wbem/wmi.

Phillip Thayer
Esteemed Contributor

Re: Hp SIM running on VM windows 2012 R2 VCRM not discovered on local host.

Whenever I install HP-SIKM on a VM I have a lot of srange things happen untikl I "fake" sim into believing it is running on a physical server.  So, go to a physical server in HP)-SIM and select the Tools tab.  Click on the link for System Properties and copy down trhe settings for the system and copy the information that defines what type of physical hardware the server is.

Rhen, go tro your SIM server in HP-SIJ, select the Tools tab andclick on the link for Systrem Preoperties.  Modify the system properties to be exactly like what the pyhysical machine is defined as.  CXlick save and to a re-identify from the quicklinks.  See if if resolves these issues.

Phil

Once it's in production it's all bugs after that.
Once it's in production it's all bugs after that.