Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Several systems not responding to snmp discovery

Andrew Kaplan
Super Advisor

Several systems not responding to snmp discovery

Hello --

I have been configuring snmp as well as installing the Insight Manager Agent software on our systems. However, there are three systems that have been problematic in that during the Discovery process, they do not respond to SNMP, and are therefore are in either an unknown or unmanaged state.

Two of the systems are Proliant DL360 G7 models, while the third is a Proliant DL380 G7 system. One of the DL360 systems runs Windows 2008 R2 Standard, while the other DL360 runs Windows 2012 R2 Standard. The DL380 system runs Windows 2012 Standard.

The built-in Windows SNMP service was activated and configured to go to the Insight Manager server on all three systems, and the service was restarted after the changes were made. The  cp026785 and cp026878 package files, which correspond to the Insight Manager Agent and WBEM software respectively, were subsequently installed on the systems.

When the discovery takes place all the Insight Manager reports in all three cases the systems did not respond to the SNMP protocol. I confirmed the community name was configured properly on the target computers as well as the Insight Manager server.

What would cause this problem, and how can I correct it?

Thanks.

A Journey In The Quest Of Knowledge
4 REPLIES
Andrew_Haak
Honored Contributor

Re: Several systems not responding to snmp discovery

Hello,

 

This could be a firewall issue is port 161 open on the firewall? Is the incomming part of SNMP configured ? Traps is an other part than reading SNMP. Traps: from server to SIM. SNMP polling from SIM to server.

 

Kind regards,

Andrew
Andrew Kaplan
Super Advisor

Re: Several systems not responding to snmp discovery

Hello --

Thank-you for your reply. I checked one of the systems in question to test your theory, and its firewall has been turned off, so I am doubtful the firewall has anything to do with it.

A colleague of mine mentioned the possibility the ilO firmware on the three systems could be obsolete, and updating it on the three systems might solve the problem.

What are your thoughts?

A Journey In The Quest Of Knowledge
Andrew_Haak
Honored Contributor

Re: Several systems not responding to snmp discovery

Hello,

 

Updating ILO firmware should only help if your read the ILO SNMP, you talked about the Windows SNMP. What type of server are you trying to monitor? If the server is a Gen8 or higher you should use the ILO and AMS for monitoring. If your server is older than that you can use WBEM or SNMP agents? Can you post screenshots of your SNMP settings blurring the actual settings? So things like who can read the SNMP, most systems only have localhost as an allow host. Add your SIM server to the allow list and identify your server to see if this is the problem.

Kind regards,

Andrew
cesarpegado
Valued Contributor

Re: Several systems not responding to snmp discovery

out of interest, have you tried loading up system management homepage on the server. If it loads all the details in the tope right corner you should see what protocol its using. Make sure this is using SNMP and not WBEM if you want to collect SNMP traps.