Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Strange behaviour in HP SIM VCRM while assigning servers to Baselines

Vicky_Rajdev
Established Member

Strange behaviour in HP SIM VCRM while assigning servers to Baselines

Hello Guys,

 

I have HP SIM 7.3 in my environment as well as HP VCRM. I have a single SPP (2015.04.0) in the repository. Whenever I assign a server to this baseline in the "Manage Software/Firmware Baselines" section in HP SIM, the software status changes to unknown instead of changing to traditional status icons (Orange, Yellow, Green). Earlier, I had SPP (2014.09.0) in the repository and assigning a server to this baseline would return appropriate status depending on the installed software or firmware versions. I have tried installing a firmware using Install Software and Firmare option in HP SIM using the repository (SPP 2015), and it works perfectly fine. And I think "Update Systems to Baseline" will work too. The only problem I am facing is that servers assigned to the baseline (SPP 2015) are unable to update their software status in HP SIM.

 

Since this is my first post in the forum, I may have failed in providing a lot of information. So please let me know if I have missed out on anything.

 

Kind Regards,

Khalid

 

 

5 REPLIES
Andrew_Haak
Honored Contributor

Re: Strange behaviour in HP SIM VCRM while assigning servers to Baselines

Hello,

The info your missing is a result of missing datacollection information. You could run a repair for one of the problem servers and repair any missing wbem credentials. Do you use snmp or wbem as a dataprovider? Is the server a windows linux or esx server? The baselines usualy only work realy good on Windows servers.
Kind regards,

Andrew
Vicky_Rajdev
Established Member

Re: Strange behaviour in HP SIM VCRM while assigning servers to Baselines

Hello Andrews,

 

I have already done Data Collection several times which completes without any issues. But I dont think thats the cause. As I said earlier, when SPP 2014.09 is uploaded, the software status changes accordingly whenever a server is assigned to the baseline. Only thing is there should be no other SPP in the repository, otherwise that too doesnt work. For sampling, I have used two servers and I can definitely say, keeping SPP 2014 alone in the repository and assigning those two sample servers (along with several other servers) to the baseline SPP 2014.09 works pretty well. But when the same is done using SPP 2015.04, I dont know why the software status arent updated! I really dont understand this behaviour. 

 

All our servers have Windows OS and we use both SNMP / WBEM as the data provider.

 

Regards,

Khalid

Andrew_Haak
Honored Contributor

Re: Strange behaviour in HP SIM VCRM while assigning servers to Baselines

Hello,

I've got 4 baselines in my vcrm and all get loaded and showup in the VCRM and in the baselines in SIM.
Do your baselines showup in the VCRM and SIM?

Wich version of the vcrm do you use? In the post you write you use SIM 7.3 did you do a seperste update of your SMH vca and VCRM? If possible i would recommend updating to 7.4 including the hotfixes, this could help with your problems but will fix some open ssl leaks in the proces....
Kind regards,

Andrew
Vicky_Rajdev
Established Member

Re: Strange behaviour in HP SIM VCRM while assigning servers to Baselines

Hello Andrews,

 

I have uploaded SPP versions 2014.09, 2015.04 and 2015.06 (one at a time) and all of them showed up. But only spp that changed the software status when a system is assigned to the baseline was 2014's. And I tested this not once, but several times. Only 2014 spp would change the software status in HP SIM, no other. (PFA)

 

Which baseline versions have you uploaded? Have you tried assigning systems to your baselines? Does the software status change accordingly for all the baselines? 

 

We have VCRM 7.3.

 

Regards,

Khalid Rajgoli

Andrew_Haak
Honored Contributor

Re: Strange behaviour in HP SIM VCRM while assigning servers to Baselines

Hello,
Yes i' ve added systems to baselines, i use the spp before the last as i'm a bit carefull to install the latest and greatest that HP has to offer. I also create custom baselines. Some don't seem to like to give the baseline info but that's always a struggle, sometimes i've even seen errors in the date format for a bios and thus i get false errors saying my system is not up to date.
Kind regards,

Andrew