Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

System Management Homepage is blank

BeteNoir
Occasional Visitor

System Management Homepage is blank

Fresh install of Proliant ML150 G6 running Windows SBS 2008. SMH just says Overall Status Summary-no items. Not so helpful. Somewhat worrying it also says System Model-unknown, Management Processor-none.

Any ideas what is going wrong here? Please be gentle with your answers as I have to confess to being a beginner. That being said, even I know this doesn't look right.

Thanks!

9 REPLIES
Gladiator
Valued Contributor

Re: System Management Homepage is blank

Hi,

For agents to be displayed properly, you need to install the whole psp.
Have you installed the wholr psp.
If yes, have you configured Snmp.

Try configuring smh and then restarting. This will populate the smh homepage with data.

Regards
Sinto
Gayathri Mohan
Occasional Visitor

Re: System Management Homepage is blank

Hi,

You can also install HP WBEM Providers. This is a optional component, which you can select during the PSP installation. HP WBEM Providers will also list server management data in system managemet home page.

Thanks,
Gayathri
CorbettEnders
Occasional Advisor

Re: System Management Homepage is blank

If the SMH page is not showing details for your server, you likely have to set the SNMP community name.

Open your services, locate the SNMP Service. Double click to open it. Select the Security Tab. Under "Accepted Community Names" it is likely blank. Click "add". With ReadOnly access enter community name "public". Click Add and then OK to close the windows. Then reboot and SMH should be OK.

 

As suggested in the comments below, you only need to restart the SNMP service and possibly the HP System Management Homepage services, not the whole server.

JMarshall
Occasional Visitor

Re: System Management Homepage is blank

Brilliant, thanks!

Ben J
Occasional Visitor

Re: System Management Homepage is blank


CorbettEnders wrote:
If the SMH page is not showing details for your server, you likely have to set the SNMP community name.

Open your services, locate the SNMP Service. Double click to open it. Select the Security Tab. Under "Accepted Community Names" it is likely blank. Click "add". With ReadOnly access enter community name "public". Click Add and then OK to close the windows. Then reboot and SMH should be OK.

Thanks this worked! I found restarting the SNMP services (and the associated services in the Restart other services popup window) was enough to start populating without a reboot of the server.

JimFA
Occasional Visitor

Re: System Management Homepage is blank

You can actually just restart the SNMP service once you reconfigure it. Note: this will also restart the HP Insight related services, which does not appear to harm anything (i.e. it won't force you to restart the server).

 

I did not have SNMP service enabled, so that had to be installed as a server feature (Windows 2008) using the MS System Management interface.

 

I followed the advice on setting up the public read only community name by double clicking the SNMP Service entry in the 'Services.msc' control panel. I then restarted the SNMP service rather than Windows itself, and after restarting the dependent HP insight services, the HP System Management Homepage correctly displayed the system model and the status of the various components.

runalongrh
Occasional Visitor

Re: System Management Homepage is blank

You don't need to reboot - Only restart the SNMP service. 

SureshNayak
Occasional Visitor

Re: System Management Homepage is blank

Thanks a lot CorbettEnders, this saved my day - You are the star.

joshcc83
Occasional Visitor

Re: System Management Homepage is blank

For Linux Installers using Centos 7 use the following link... https://www.centos.org/forums/viewtopic.php?t=55506

 

 Step 3 is where the magic happens.... If you do not configure the SNMP then your page may be blank

NOTE: step 3 didn't work for me. - if this happens to you try the following command... /sbin/hpsnmpconfig

  • if it doesn't work try running it from the following path /opt/hp/hpsmh/sbin

Assuming this is a new install and you have not yet configured SNMP it is easiest to answer No to the first question 'do you want to use an existing configuration file'. Follow the configuration questions through to the end and a new file will be created.

Then proceed to setup SNMP... if you are super new to this then do the following.

1. copy and paste... the below config  at the top of the  snmpd.config file and save - btw it's  in /etc/snmp

rwcommunity private 127.0.0.1
rocommunity public 127.0.0.1
rwcommunity private <IP_SIM_Server>
rocommunity public <IP_SIM_Server>
trapcommunity public
trapsink <IP_SIM_Server> public

2. run /sbin/hpsnmpconfig

3. Type n for no....

 

Spoiler
NOTE:  you will see the following info.

You will now be asked a series of SNMP configuration questions. How you answer

these question will affect the way SNMP behaves. Configuring SNMP could have
security implications on your system. If you are not sure how to answer a
question, you can abort by pressing <Ctrl-c> and no changes will be made to
your SNMP configuration.

Localhost SNMP Read/Write community strings are already known.
Do you wish to change it (y/n) (Blank is n): n


Localhost SNMP Read Only community strings are already known.
Do you wish to change it (y/n) (Blank is n): n


SNMP Read/Write community strings are already set to
rwcommunity private <IP_SIM_Server>
Do you wish to change them (y/n) (Blank is n): n


SNMP Read Only community strings are already set to
rocommunity public <IP_SIM_Server>
Do you wish to change them (y/n) (Blank is n): n


The SNMP trap community strings are set up like this:
trapcommunity public
Do you wish to change this (y/n) (Blank is n): n


Trap sinks are set up like this:
trapsink <IP_SIM_Server> public
Do you wish to change this (y/n) (Blank is n): n


The system contact is set to
syscontact Root <root@localhost> (configure /etc/snmp/snmp.local.conf)
Do you wish to change it (y/n) (Blank is n): n


The system location is set to
syslocation Unknown (edit /etc/snmp/snmpd.conf)
Do you wish to change it (y/n) (Blank is n): n

==============================================================================
NOTE: New snmpd.conf entries were added to the top of /etc/snmp/snmpd.conf
==============================================================================
snmpd is started

 you can also restart the snmpd service if you like just to make sure when you refresh you are good. 

 

 

 

 

 

Spoiler

Your SNMP.config file should look something like this - once finished

# Following entries were added by HPE Insight Management Agents at
# Tue Oct 18 04:27:37 UTC 2016
dlmod cmaX /usr/lib64/libcmaX64.so
rwcommunity private 127.0.0.1
rocommunity public 127.0.0.1
rwcommunity private <IP_SIM_Server>
rocommunity public <IP_SIM_Server>
trapcommunity public
trapsink <IP_SIM_Server> public
syscontact Root <root@localhost> (configure /etc/snmp/snmp.local.conf)
syslocation Unknown (edit /etc/snmp/snmpd.conf)

# ---------------------- END --------------------

 

 

 

Another reference: ftp://ftp.hp.com/pub/jp-linux/mainstream/support/doc/general/mgmt/pdf/c00223285.pdf