Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

The Data Collection task could not find any data to collect

Guillaule
Frequent Advisor

The Data Collection task could not find any data to collect

Hi

 

I've 2 new ProLiant DL380p Gen8, well recognize, i receive alert, see attachement.. 

but each weeks i stuill receive this following error :

 

Event Name: Data Collection found no data

URL: https://xxxx.xxx.xx:2381/

Event originator: xxxx

Event Severity: Minor

Event received: 22-Feb-2014, 00:10:42

Event description: The Data Collection task could not find any data to collect. The target system may not have been running any supported instrumentation protocol, such as SNMP, WBEM or DMI.

 

 

16 REPLIES
Andrew_Haak
Honored Contributor

Re: The Data Collection task could not find any data to collect

Hello there,

 

could you do a identify of the server and post the log to see if all protocols still work? What version and patch level of SIM are you running?

 

Kind regards,

 

Andrew

Kind regards,

Andrew
Guillaule
Frequent Advisor

Re: The Data Collection task could not find any data to collect

Hi

 

in attachement find the SIM version 

 

here the result of Identify

 

********* Significant issues and overall target discovery/identification
status:
Normal: The system has valid hardware data (model, serial number, and
unique identifier) and has been identified properly for SIM to
manage.
Normal: System(s) have been successfully identified.

********* Additional results (listed for information only):

* Starting identification process...
* Checking for known running web servers...
* Checking for SNMP protocol support on system...
Normal: The system responded to an SNMP request; it supports SNMP Protocol
and has a valid read community string.
* Checking for SNMPv3 protocol support on system...
Normal: The system did not respond to SNMPv3. Verify security settings and
v3 credentials in Options->Security->Credentials->System
Credentials
* Running HP ProLiant management agent identification...
Normal: Identification can get the system information from the ProLiant
SNMP Foundation agents for servers.
* Running SNMP base cluster identification using common cluster
MIB...
Normal: This system does not have the common cluster MIBs support.
* Checking for WBEM protocol support on system...
Minor: This system does not have any SMI-S CIMOMs installed. No storage
systems will be found on this system.
Minor: The Central Management System (CMS) cannot communicate with the
CIMOM locally installed on the managed system using the WBEM
protocol, Identification will try to identify Windows systems using
the WMI Mapper as proxy; for Linux and HP-UX systems, check
credentials by going to Options->Security->Credentials->System
Credentials. For Linux systems also check if the HP WBEM provider
is installed.
* Running WBEM rules based identification...
Normal: Got the system information from the WBEM / WMI providers and it has
a valid WBEM credential.
* Running Virtual Machine (VM) Host (non HP Integrity VM Host)
Identification...
Normal: The system is not a VM Host (non HP Integrity VM Host), or WBEM
credentials may not be specified so skipping VM Identification.
* Running Storage identification...
* This system has some storage related information and additional
storage systems may be added.
* This system has some storage related information and additional
storage systems may be added.
* This system has some storage related information and additional
storage systems may be added.
* This system has some storage related information and additional
storage systems may be added.
* This system has some storage related information and additional
storage systems may be added.
* Storage identification completed.
* Running HP NetServer identification...
Normal: System supports the NetServer SNMP agent, adding system type.
* Running HP-UX SNMP identification...
Normal: System does not have the HP-UX SNMP agents installed.
* Running OA Identifier which will discover systems in an enclosure
if the automatic enclosure discovery option for OA is enabled...
Normal: A non-embedded operating system is detected so skipping the OA
identification.
* Running XMLReply Identifier which will discover systems in a
rack/enclosure if the automatic discovery option for the container
node is enabled...
Normal: A non-embedded operating system is detected so skipping the
Management processor identification.
* Running iLO Identifier which will discover the server if the
automatic server discovery option for iLO is enabled...
Normal: A non-embedded operating system is detected so skipping the ILO
identification.
* Running p-Class Identifier...
Normal: The system is not a p-Class so skipping p-Class identification.
* Running IPMI protocol identification...
Normal: Skipping IPMI discovery in favor of WBEM/SNMP discovery.
* Running SSH Protocol identification...
Minor: The system(s) do not have Secure Shell (SSH) installed or it is not
running on the managed system(s).
* Running SSH Identification...
Normal: SSH Protocol is not enabled so skipping SSH Identification.
* Running WS-Man identification...
Normal: A non-embedded operating system is detected so skipping the WS-MAN
identification.
* Running Monarch OA Identification...
Normal: The system is not a monarch OA so skipping monarch OA
identification.
* Checking for System Management Homepage and other HP web agents...
Normal: System Management Homepage (SMH) is installed or is responding on
the system(s).
* Running HP Serviceguard Identification...
Normal: The system is not part of HP Serviceguard cluster.
* Running SNMP System Type manager ...
Normal: No matching SNMP System Type Manager rule for sysObjID was found.
* Running SNMP subtypes identification...
* No additional subtype(s) found from SNMP.
* Resolving DNS names...
Normal: The fully qualified domain name was successfully resolved for the
system.
* Checking if the Node is a Virtual Center...
Normal: Node is not a Virtual Center Node
* Running Virtual Machine Management (VMM) Plug-in Identification...
* Building system relationships...
Normal: The trust between the CMS and the managed system is established.
* Running system Manage Communication diagnosis...
* System identification finished on system.

 

 

Andrew_Haak
Honored Contributor

Re: The Data Collection task could not find any data to collect

Hello again,

 

Strange all looks fine, snmp & WBEM are working, if you delete the server and readd the server do you still get all information if you look at the data Collection for that server, does it look complete ?

 

Kind regards,

 

Andrew

Kind regards,

Andrew
Guillaule
Frequent Advisor

Re: The Data Collection task could not find any data to collect

yes very strange

 

if i run a Data Collection (overwrite existing) :

 

This system does not have any supported instrumentation.
Root Cause: Identification failed to detect any supported instrumentation (e.g. SNMP, DMI, WBEM) on this system.
Corrective Action: Check network and configuration of target system. Check the following pages to ensure appropriate credentials and data are provided: Global Protocol Settings, System Protocol Settings, WMI Mapper Proxy. Rerun Identification and then Data Collection.

 

 

Andrew_Haak
Honored Contributor

Re: The Data Collection task could not find any data to collect

Hello,

If you look at the Data Collection Report, do you still have your information ?

Kind regards,

Andrew
Kind regards,

Andrew
Guillaule
Frequent Advisor

Re: The Data Collection task could not find any data to collect

report in attachement

Andrew_Haak
Honored Contributor

Re: The Data Collection task could not find any data to collect

Hello again,

 

That's not a lot of info, could it be that the rights for wbem/wmi are not set for all wbem information. If I look at a server I have in Sim I see information like driver, firmware and installed controllers like ilo and array controller.

 

What are the rights you've set for discovery admin or a user that is allowed to read the whole wmi tree?

 

Kind regards,

 

Andrew

Kind regards,

Andrew
Guillaule
Frequent Advisor

Re: The Data Collection task could not find any data to collect

If i take a look to System Crendetial for WBEM / WMI, the user is member of Local Adminsitrators Group


Thanks
regards

Andrew_Haak
Honored Contributor

Re: The Data Collection task could not find any data to collect

Hello again,
With the risk of me asking again in an other post. What is your SIM version and patch level ?

Kind regards,

Andrew
Kind regards,

Andrew
Guillaule
Frequent Advisor

Re: The Data Collection task could not find any data to collect

no PB, the version is in attachement on my 2nd Post :)

Andrew_Haak
Honored Contributor

Re: The Data Collection task could not find any data to collect

Sorry no clue to what the problem is. All credentials seem ok. I can't help you any further, anyone else ideas?

Kind regards.

Andrew
Kind regards,

Andrew
Guillaule
Frequent Advisor

Re: The Data Collection task could not find any data to collect

Thanks for your time

 

i've worked a lot with HP SIM but it's the 1st time i've this pb ... and i managed a GEN8 too :)

Mrpink200
Occasional Advisor

Re: The Data Collection task could not find any data to collect

Hello

Im facing the same probleme with all my ESXi; 

Is there any solution found since 2014 ?

Andrew_Haak
Honored Contributor

Re: The Data Collection task could not find any data to collect

Hello quite an old post but found the problem.

Disable all agent on the server exept the Agentless Management Agent.

Enable SNMP on the ILO, configure read community, trap community and destination and set the setting to agentless Management in the same page.

Be sure to delete the server and ILO, then only discover the ILO, if all goes right the ILO will be discovered, when data collection runs for the ILO the server should be added without any extra credentials. Be sure the SIM does not try to discover the server itself as this will cause the timeouts seen earlier.

Once the polling job has run you will also see the status for the server. The Agentless Management software can be downloaded from the hpe.com website.

 

 

 

 

 

 

Kind regards,

Andrew
rcbrewer
Occasional Visitor

Re: The Data Collection task could not find any data to collect

Which agents are you disabling. 

Andrew_Haak
Honored Contributor

Re: The Data Collection task could not find any data to collect

When you want to datacollect a Gen8 server or newer you need to disable the following on the OS SNMP, SNMP agents, WBEM agents and SMH. The Gen8 and newer only need to be monitored and datacollected by the ILO using SNMP, HTTP and if used SSH. If the ILO is configured to send traps and a community to be read by SIM it will read if you enabled the AMS option in the ILO. Then the ILO connects to the Agentless Management Service running on the OS. The info collected by the ILO using the AMS is then added to the server. When you use multi protocols things get timeouts and then you get the error mentioned in the original question.

Kind regards,

Andrew