Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

VCRM trust relationship issue in SIM 7.4

SOLVED
Go to solution
prox
Occasional Contributor

VCRM trust relationship issue in SIM 7.4

Hi all,

 

maybe anyone could help?

We've updated recently to HP SIM 7.4 and uploaded the newest HP SPP 2014.09 to our repository.

 

Now the issue.

When in Insight Control, we search for the server and we chose it, then click on 'Deploy / Deploy Drivers, Firmware and agents / Install Software and Firware', new window openes.

Under 'Select a Version Control Repository' we see our SIM  server hostname, status is a green tick but under 'Trusted?' we have a red 'no [configure]' (that's the issue).

 

When we try to deploy a new iLO firmware for example, we chose new f/w 1.51 and click 'Next'.

Then on next screen we tick the f/w version and click 'Run now' but it fails with the following message:

 

'Security error downloading Support Pack. Be sure a trust relationship exists to the repository system and the user has privileges to the system.'

 

Now, going back to red 'no [configure]'. When on the SIM server itself, we click on '[configure]', it openes a new window with error loading page but after click on it 2nd time it openes a new window with 'Trust Modes'.

We don't use any certificate and we chose 'Trust All' (we've always used it this way).

So far it was working fine till update.

Unfortunately my collegue has updated SIM and uploaded SPP one after another and couldn't tell if trust issue was there just after the update or it has shown after the new SPP.

Removing the SPP doesn't help.

 

I'd hope there's a way to fix that issue without downgrading/reinstalling SIM.

 

We'll appreciate any advices.

 

Regards to all,

mgora

5 REPLIES
Andrew_Haak
Honored Contributor

Re: VCRM trust relationship issue in SIM 7.4

Hello there,

 

Rubn a repair for you SIm servers and select the Set Trust option. If all goes well the repair should push a trust certificate to your SIM server.

Kind regards,

Andrew
prox
Occasional Contributor

Re: VCRM trust relationship issue in SIM 7.4

Hi Andrew,

 

How would I run the repair on SIM server?

I couldn't find anything.

 

Regards,
Marek

 

 

Andrew_Haak
Honored Contributor
Solution

Re: VCRM trust relationship issue in SIM 7.4

Hello again,

Configure

First select the SIM server in your view, from the menu Configure >  Configure or Repair Agents.

Click Next on the first screen with no options enabled. On the second screen deselect all option exept Set Trust Relationship > Trust by Certificate, the second option is not needed. Fill in credentials for the SIm server to connect and see if the repair finishes.

 

 

Kind regards,

Andrew
prox
Occasional Contributor

Re: VCRM trust relationship issue in SIM 7.4

Andrew,

 

Thank you for the steps to run the fix.

Unfortunately that didn't help.

 

I decided to go with certificate Trust and that didn't seem to help either until I rebooted the server.

 

So I'm not sure which of the two helped here realy but I'm glad it's working now (I'll mark your answer as a solution, as it was part of it after all, not sure which of the two did the trick).

 

Thank you for your help on this.

 

Regards,

Marek

Andrew_Haak
Honored Contributor

Re: VCRM trust relationship issue in SIM 7.4

A restart of the SIM  and VCRM service would have been enough, but then again so does a reboot.

 

Kind regards,

Andrew