Systems Management (OpenView-OP Mgmt) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

opctrapi aborts on agent 11.03.012

Go to Solution
Trusted Contributor

opctrapi aborts on agent 11.03.012

opctrapi aborts very shortly after ovc is started.  This is on the management server  (OMW 8) so I cannot receive any direct traps.


Ideally I would just upgrade the agent.  But...


We are stuck on agent 11.03.012 because OVPM 8 cannot be patched to be compatible with anything higher than that.  (There is an OVPM patch which is compatible with 11.1x. agents but this is only for OVPM 9).


This fault occurred at agent 11.02.022 but went away.  There was an HP case for that - 4637732509 - but HP seems to have removed the facility to search old cases, and unfortunately I don't have a record of the solution, except that I noted that it was fixed at the same agent release 11.02.022 so it does not look like a 'just upgrade it' solution.


An OMW9 installation is on the way, but I am retiring soon (anyone want this job?), so I'd rather just fix my OMW8 installation.

Trusted Contributor

Re: opctrapi aborts on agent 11.03.012

oh, and all I get on System.txt is :-


0: ERR: Mon Jan 13 17:31:14 2014: ovcd (4060/10060): (ctrl-94) Component 'opctrapi' exited after very short runtime, ther
efore it will not be automatically restarted. Use 'ovc -start opctrapi'.


I have tried the standard solution ovc -kill   |   empty tmp\OpC   |   opcagt -cleanstart

HPE Expert

Re: opctrapi aborts on agent 11.03.012



I went to check the case you mentioned and it says that Hotfix from QCIM1A130533 was applied and solved the issue.

Perhaps you can open a support case to request this hotfix.


Best regards.

HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
If you liked it I would appreciate KUDOs.
Trusted Contributor

Re: opctrapi aborts on agent 11.03.012

I changed the SNMP_SESSION_MODE to NETSNMP and that prevented the crashes.

(There is a lot of confusing documentation out there about these settings - NNM_LIBS, TRY_BOTH etc., and it seems that it depends on which agent version you are using.  Hopefully NETSNMP will work from now on...)