Tape Backup (Small and Medium Business)
Showing results for 
Search instead for 
Do you mean 

Can not mount LTFS!

Visitor

Can not mount LTFS!

Hi,

 

I have an Ultrium 3280 SAS tape drive.

The system is RHEL5.5 x64.

Tape drive firmware is X38D/Standalone.

 

Here is what happens :

mkltfs successfully formats the LTO5.

 

[root@localhost ~]# mkltfs -f -d /dev/st0
LTFS15000I mkltfs starting, log level 2
LTFS15003I Formatting device '/dev/st0'
LTFS15004I LTFS volume blocksize: 524288
LTFS15005I Index partition placement policy: None

LTFS12503I Drive type is HP LTO5, serial number is HU1027B5C3
LTFS15010I Creating data partition b on SCSI partition 0
LTFS15011I Creating index partition a on SCSI partition 1
LTFS12516I Tape was formatted by Application Name LTFS                            
LTFS11097I Partitioning the medium
LTFS11100I Writing partition labels
LTFS15013I Volume UUID is: cca1737c-5cc7-4b95-b599-bc94f3afbf3f

LTFS15017I Writing Index to partition b
LTFS15017I Writing Index to partition a
LTFS15019I Volume capacity is 1536 GB
LTFS15024I Medium formatted successfully

 

When it comes to mount the tape ltfs does not work :

there you go:

[root@localhost ~]# ltfs /mnt/lto01/
LTFS14000I LTFS starting, log level 2
LTFS12503I Drive type is HP LTO5, serial number is HU1027B5C3
LTFS11005I Mounting the volume
LTFS11026I Performing a full medium consistency check
LTFS12069E EIO in read
LTFS12098E Forcing drive dump
LTFS12090W Cannot retrieve drive dump: failed to read buffer (-1)
LTFS12049E Cannot read: backend call failed (-5)
LTFS17039E XML parser: reading a block from the medium failed (-5)
Entity: line 1: parser error : Extra content at the end of the document

^
LTFS17037E XML parser: failed to read from XML stream
LTFS17016E Cannot parse Index (direct from medium)
LTFS11194W Cannot read Index: failed to read and parse XML data (-1)
LTFS12069E EIO in read
LTFS12098E Forcing drive dump
LTFS12090W Cannot retrieve drive dump: failed to read buffer (-1)
LTFS12049E Cannot read: backend call failed (-5)
LTFS17039E XML parser: reading a block from the medium failed (-5)
Entity: line 1: parser error : Extra content at the end of the document

^
LTFS17037E XML parser: failed to read from XML stream
LTFS17016E Cannot parse Index (direct from medium)
LTFS11194W Cannot read Index: failed to read and parse XML data (-1)
LTFS11257I No index found in the index partition
LTFS11258I No index found in the data partition
LTFS11220E Medium check failed: extra blocks were detected on the medium. Please run ltfsck.
LTFS11027E Cannot mount volume: medium consistency check failed
LTFS14013E Cannot mount the volume. Please format the medium with mkltfs or check it with ltfsck.
[root@localhost ~]#

 

Any ideas?

 

 

 

6 REPLIES
Occasional Advisor

Re: Can not mount LTFS!

An updated version of LTFS was posted to the HP website a little while back (v1.0.1) which includes a fix for issues such as this.  Are you still using the original 1.0.0 release?

 

If you have already updated and still see this problem, could you post details of the server and SAS HBA you are using?

 

Thanks.

Visitor

Re: Can not mount LTFS!

Hi Chris,

 

thanks for the response.

 

I'm using ltfs ver.1.0.1.

 

HBA is HP Smart Array P212 Controller. HP part number is 462828-B21

 

This computer is an average pc not a server. Asus P5B deluxe wifi motherboard, intel c2quad cpu.

 

I tried couple of distributions.Could manage to run LTFS packages only under RHEL5.5x64.

 

I upgraded SAS 3280 external LTO drive firmware to X38D before starting everything.(it was X22D)

 

I did a firmware upgrade to the HBA as well if I am not remembering wrong.But really don't remember why and how I did it.(Maybe something wrong with the incompatible firmware installation,don remember really)

 

thanks

 

Honored Contributor

Re: Can not mount LTFS!

That part number resolves to a P212/ZM (there are two models of the P212).  Unfortunately the P212/ZM is not compatible with LTFS.  Most controllers work fine but with the P212 the P212/256 is required.  That is: Smart Array P212/256MB 462834-B21.

 

See the compatibility matrix at:

http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c02432157/c02432157.pdf

 

You can buy the 256MB cache memory upgrade separately from the controller to upgrade that one.

Visitor

Re: Can not mount LTFS!

Hi Curtis,

Greatfull to you.

I have asked from the local dealer for the controller you have recommended me.

I'll post here what happens with the compatible one as soon as I get it.

Thanks again.

Visitor

Re: Can not mount LTFS!

Finally I did it with a P411 contoller.

Thanks a lot.

 

Occasional Visitor

Re: Can not mount LTFS!

Hi there,

 

I'm having a similar issue. This is what I'm getting:

 

LTFS14000I LTFS starting, LTFS version 1.2.2, log level 2
LTFS14058I LTFS Format Specification version 2.0.0
LTFS14063I Sync type is "time", Sync time is 300 sec
LTFS20013I Drive type is HP LTO5, serial number is HU1027B753
LTFS17160I Maximum device block size is 524288
LTFS11005I Mounting the volume
LTFS12015I Attempting to load the medium
LTFS11026I Performing a full medium consistency check
Entity: line 1: parser error : Document is empty
13780100925805C14E56080046020226
^
LTFS17037E XML parser: failed to read from XML stream
LTFS17016E Cannot parse Index (direct from medium)
LTFS11194W Cannot read Index: failed to read and parse XML data (-1014)
LTFS11220E Medium check failed: extra blocks were detected on the medium. Please run ltfsck.
LTFS11027E Cannot mount volume: medium consistency check failed
LTFS14013E Cannot mount the volume
LTFS20076I Triggering drive diagnostic dump
LTFS20096I Diagnostic dump complete

 

What can I do please?

//Add this to "OnDomLoad" event