Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

Adding a drive to an Ultrium library

Adding a drive to an Ultrium library

I am adding a drive to a 20 slot Ultrium tape library and have managed the physical installation ok. The device appears on the front panel and on the remote administraton web page. However through the web interface under status, I get: Library Partly Available
* Drive(s) not available on Fibre Channel
* Drive Firmware Revision Levels are Inconsistent

It seems you need to configure the drive to be seen by the fibre controller before you can upgrade the firmware? I can only locate the instructions to do this for the standalone Scsi - Fibre controller, 2100ER. In this case, you use a serial cable etc. However the controller we have is the built-in card which doesn't have any serial port. The only other place to upgrade the firmware I can determine is on the administraton web page, but this does not list the new drive under the firmware update tab. The drive is not visible on the host under the ltt utility (HPUX). Anyone have any idea how I get around this?

Robert.
9 REPLIES
Eugeny Brychkov
Honored Contributor

Re: Adding a drive to an Ultrium library

You may try:
1. remove both drives and make library 'single drive' but using one drive, update its firmware to known level, then insert another drive (again in 'single drive config' and update it to the same revision). After doing this you will have same firmware levels on both drives and can install them both;
2. update firmware using SCSI connection. To do this you should have appropriate SCSI card in the server and update drive with appropriate firmware image from library's firmware package
Eugeny

Re: Adding a drive to an Ultrium library

Updating through SCSI is not possible as the host is using fibre channel.
I updated one drive singly ok, but when I tried to update the other on it's own firstly with the ltt utility, it reported no matching file for the drive. On the web interface it reported that no drives that support remote download were found.

Will it not work at all with mismatched firmware? Also, if the firmware problem were resolved, would the Fibire-SCSI configuration problem dissapear?

Re: Adding a drive to an Ultrium library

I've managed to sort out the firmware issue - The new drive was one of a pair. Instead of adding one, I replaced both with the new drives and the firmware problems dissapeared.

The only problem remaining is that the extra drive is still not on fibre channel. How do I go about enabling it?

Robert.
Ted Ellis_2
Honored Contributor

Re: Adding a drive to an Ultrium library

to summarize what you were seeing, the SureStore libraries have a built in dependency that all tape drives be at the same firmware revision in order to be available. If their is a mismatch, the library will use all drives at the latest firmware that match and report a partial availability. Seems you have that sorted.

Do you see the new drive with an ioscan from the server? If you see the hardware path, do you also see device files?

Ted
Eugeny Brychkov
Honored Contributor

Re: Adding a drive to an Ultrium library

Robert, if you did correct drive cabling to FC card, connected terminators at the both ends of the bus, FC card's SCSI channels leds are green (indicating SCSI is good - only available for high perf FC IF card) then it should work
If one drive is reported as unavailable try to cross cables from the drives and see which drive will be reported then. If drive in another location - then there's problem with FC card or its setup, if in the same location - problem with cables/terms/drive. Continue troubleshoting in the same manner trying exchanging parts from both channels
Eugeny

Re: Adding a drive to an Ultrium library

I checked the cabling and although everything appeared ok, I tried swapping around cables to see if that made any differeance and 'lo it worked! When I switched the cable between ports on the fibre channel controller, both drives became visible. When I switched them back it went again. Strange, but at least now it works which is the important thing!

Thanks,
Robert.
Eugeny Brychkov
Honored Contributor

Re: Adding a drive to an Ultrium library

Robert, that great. I think SCSI cables should be connected as it drawn in the manual because there are internal drives' connection to the backplane and if you exchnange 'outer' drives' SCSI connection then library may be confused which drive is where.
I see that drive 1 (left if looking from the rear) connects to upper FC card SCSI connector, and another connector of SCSI drive 1 connected to library controller which is terminated in its other SCSI connector. Drive 2 is connected to lower FC card SCSI connector and there's a terminator in another drives' SCSI conenctor
Eugeny

Re: Adding a drive to an Ultrium library

Oops, just one last question. How do I create the device files for the newly added drive. Do I need to reboot?

Here's the ioscan:
tape 0 8/0/2/0.1.4.255.11.12.1 stape CLAIMED DEVICE HP Ultrium 1-SCSI
/dev/rmt/0m
/dev/rmt/0mb
/dev/rmt/0mn
/dev/rmt/0mnb
/dev/rmt/c5t12d1BEST
/dev/rmt/c5t12d1BESTb
/dev/rmt/c5t12d1BESTn
/dev/rmt/c5t12d1BESTnb

tape 1 8/0/2/0.1.4.255.11.12.2 stape CLAIMED DEVICE HP Ultrium 1-SCSI
Eugeny Brychkov
Honored Contributor

Re: Adding a drive to an Ultrium library

insf -e
you do not need to reboot
Eugeny