Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

Backup Exec 11d does not find MSL6030

SOLVED
Go to solution
Miika T
Valued Contributor

Backup Exec 11d does not find MSL6030

MSL6030 + e1200 + 2xUltrium460 drivers is not recognized by Backup Exec 11d build 7170 on x64 enterpise windows. Operating system recognizes the MSL as unknown medium changer and both drives are installed. Backup exec only sees the drives and gives an error about:

ADAMM configuration warning.
The device driver may not be installed for device :
Identifier : COMPAQ MSL6000 Series 0520.
Type : MediumChangerPeripheral.

Any idea why won't the backup exec find the library?

-Miika
25 REPLIES
MSECO_1
Trusted Contributor

Re: Backup Exec 11d does not find MSL6030

Try installing this driver
http://seer.entsupport.symantec.com/docs/265139.htm
Keep learning!!!
Prabhulj
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Hi Miika,

Please install the driver for the Mediaum Changer from the below link.

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=12169&prodSeriesId=316040&prodNameId=316054&swEnvOID=1060&swLang=8&mode=2&taskId=135&swItem=co-44137-2

Once the driver is installed, ensure that the changer is recognised on the device manager.
Once done, Delete all the detected devices( I assume that the 2 tape drives are listed on bakup exec)
Re-configure backup exec and The changer and the drives would be detected.

Hope this helps.

Regards,
Prabhu

Miika T
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

MSECO,

the driver you are referring to is to an old version. We are using BE11d build 7170.

Prabhulj,

I used this driver for the E1200 storage router, but then I decided to remove the storage router from e1200 mappings and used indexed presentation / zoning just to display the device to everyine in the zone (I only have one backup server and library in the zone). So the e1200 storage router disappeared from device manager.

Symantec/Veritas support suggested that I should install a device driver for the MSL6030 library, as it is diplayed as unknown medium changer. I disagree with this, as I suppose there is any specific driver for MSL6000 series, only for the tape drives.

I can't remember, if Symantec tapeinst displayes the library on the driver installation, as I can only see the drives:

Finding tape devices
Finding plug and play tape device names
Hardware ID = SCSI\SequentialHP______Ultrium_2-SCSI__F68W
Hardware ID = SCSI\SequentialHP______Ultrium_2-SCSI__F68W
Finding IDE plug and play device instances
Finding SCSI plug and play device instances
Finding Symantec device drivers
Hardware scan complete.

-Miika
Uli Böhm
Frequent Advisor

Re: Backup Exec 11d does not find MSL6030

Hi Miika,

at http://h18007.www1.hp.com/support/files/server/us/download/18619.html you find the driver for your MSL. Please clear the Indexed map the E1200 and fill map ( Target / Bus for Windows xxxx). Please verify that the Removable Storage Manager is disabled!
Does LTT find all devices?

Regards
Uli
Miika T
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Uli,

the softpack included the Ultrium drive drivers, but not the library driver (I suppose none exist). Unfortunately, this did not change the situation how Backup Exec sees the devices. Operating system still recognizes the MSL as Unknown Medium Changer and both Ultrium drives display ok under Tape devices.

HP Support suggested not to use the mapping, as there are no other servers in the zone that can see the MSL.

-Miika
Prabhulj
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Hi Miika,

Try re-configuring the Mapping to Indexed, and it should list the Changer,the two tape drives and the Cntrlr.

On Port settings of the NSR for FC port, Check if "use hard_ALPA" is disabled.

Driver - Tape/Automation Devices

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=12169&prodSeriesId=316040&swItem=co-47872-2&prodNameId=463669&swEnvOID=1005&swLang=8&taskId=135&mode=4&idx=0

Is L&TT able to recognise the Library and drives?

Regards,
Prabhu
Miika T
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Prabhulj,

LTT can see all devices fine. So I and HP support thought it is not the mapping that causes the BE not to see the device. Use Hard AL_PA is disabled though.

The baseline was the the MSL was connected to another server that is running Arcserve. I upgraded the library and tape firmwares and zoned the msl for a new server. I removed the mapping and new server device manager & ltt sees the devices, but be can't configure / see the library. If I zone the msl back to Arcserve zone, arcserve sees the msl fine and can use it (and no mapping is present).

-Miika
Uli Böhm
Frequent Advisor

Re: Backup Exec 11d does not find MSL6030

Hi,

the "right" mapping is important; do you see 4 devices in your map > AF, MSL and both drives? Have you checked http://support.veritas.com/docs/252041 ?
What about LTT status?

Regards
Uli
Miika T
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Uli,

I've checked out the Veritas article. But I've understood that there is no device driver for MSL6000 series other than Unknown medium changer and of course the tape drive drivers. BE tapeinst only installs the for the drives, not the changer.

I had the storage router as indexed, but it was removed from the view, as when it was there, the situation was the same. Now the device index is this:

FC LUN Protocol Bus Device Specific Address Type Status Device Description
0 PSCSI 0 Target= 0 Lun= 0 CHGR UP COMPAQ MSL6000 Series 0518
1 PSCSI 0 Target= 1 Lun= 0 TAPE UP HP Ultrium 2-SCSI F68W
2 PSCSI 1 Target= 2 Lun= 0 TAPE UP HP Ultrium 2-SCSI F68W


And as mentioned earlier, LTT sees the MSL, and two drives fine.

-Miika
Prabhulj
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Miika,

The controller (NSR) is not being listed on the device Map)
It should ideally look like

FC LUN Protocol Bus Device Specific Address Type Status Device Description
0 PSCSI 0 Target= 0 Lun= 0 CHGR UP COMPAQ MSL6000 Series 0518
1 PSCSI 0 Target= 1 Lun= 0 TAPE UP HP Ultrium 2-SCSI F68W
2 PSCSI 1 Target= 2 Lun= 0 TAPE UP HP Ultrium 2-SCSI F68W
3 AF Lun= 0 CTLR UP NSR E1200-160


Miika T
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Prabhulj,

the e1200 was removed from the map, as the backup exec did not see the msl (only the drives) and this was suggested by HP support.

-Miika
Prabhulj
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Miika,

Have attached a Small reference guide.
kindly have a look @ it.

Regarding deleting the NSR on the mapping,

" Unless you are using the OpenVMS operating system, make sure the Active Fabric (AF) is listed as the last LUN in the table. If Active Fabric gets assigned to LUN 0, it will cause problems in HP-UX, and should be moved by using Delete Map Item(s) and Discovered Device Entry."

could you try re-configuring the Mapping and snure NSR is listed.

Regards,
Prabhu
rich pattison
Trusted Contributor

Re: Backup Exec 11d does not find MSL6030

I think that the point is being missed here a bit ....... If your O/S and BE can "see" both the library changer, and the drives - then the NSR and mappings must be OK.

It seems to me the problem is with Windows or BE not handling the changer. How did the drivers get installed ? -- did you get BE to install them, or did you do it manually ?

When I install HP drivers for Windows - I use the automatic installation/upgrade program:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=12169&prodSeriesId=316040&prodNameId=1849286&swEnvOID=1005&swLang=8&mode=2&taskId=135&swItem=co-47872-2

....and I usually find any unidentified changers and drives "magically" get identified. However, with Veritas products, they like to have Veritas drivers - so they could possibly have an equivalent utility.

Rich
Miika T
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Rich,

os automatically identifies the library as Unknown medium changer (uses Microsoft driver for this) and the tape drives are not installed at first (devices with ?). I used Veritas tapeinst to install drivers for these.

-Miika
Prabhulj
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Miika,

Have you tried to install the "tape Driver" installer.

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=12169&prodSeriesId=316040&prodNameId=1849286&swEnvOID=1005&swLang=8&mode=2&taskId=135&swItem=co-47872-2

Try installing this to check if the Exchanger gets recognised on the Windows DM.

Prabhu
Miika T
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Prabhulj,

this only installs HP drivers for the Ultrium drives, not the medium changer.

And I can't extract the package, so I could try to update the medium changer driver and point the directory for these files.

-Miika
Prabhulj
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Miika,

This would install the drivers for the "Automation Devices" which is the medium changer.

Release Notes:
This utility will automatically install the SCSI drivers for HP StorageWorks Ultrium, DLT, SDLT tape and tape automation devices for systems running Microsoft Windows 2000 or Microsoft Windows Server 2003. These drivers are provided for the Microsoft Windows Native Backup Utility and other Backup Software that requires tape drivers to be loaded.
rich pattison
Trusted Contributor

Re: Backup Exec 11d does not find MSL6030

Windows uses a SCSI passthru mechanism so doesn't usually need a driver, just correct identification. It may be worth running the HP driver utility - but you would have to reload the Veritas tape drivers for the drives afterwards. I found a copy of the Veritas DDI (device driver installer) here:

http://www.symantec.com/enterprise/support/downloads.jsp?pid=15047

but you probably already have this ???

Rich
Miika T
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

Symantec support seems to think the problem is with device identifier. I get an event log entry that says COMPAQ MSL6000 Series 0518 and the hardware compatibility list is for:

MSL6000 series LTO2
(6030/6060)
HP^^^^^^MSL6000 SCSI SCSI ID HP StorageWorks Ultrium
460 LTO2
HP^^^^^^Ultrium^2-SCSI SCSI LTO

So based on this information, does anyone know, if it is possible to change the identifier from Compaq to HP? Only Compaq 5000 series is found from the HCL and all later models are for HP.

-Miika
Uli Böhm
Frequent Advisor

Re: Backup Exec 11d does not find MSL6030

Hi,

to change the identifier from CPQ to HP you have to make an Firmware Upgrade.

- Uli
rich pattison
Trusted Contributor

Re: Backup Exec 11d does not find MSL6030

I don't think a firmware upgrade will make any difference - V5.18 is only a few months old anyway.

Was this unit purchased as a Compaq library, or HP ? - most MSL6000's were HP, so has the controller module been replaced, or some settings modified ?.

There is a low-level utility called MSLutil.
If I remember correctly, there is an option in that utility to set the identity to Overland, Compaq, or HP. It runs on a Windows box, and uses a serial connection into the library controller. Its available as a download here:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=1849286&prodTypeId=12169&prodSeriesId=316040&swLang=8&taskId=135&swEnvOID=1005#930

However - there isn't much documentation, its not that intuative to use, and you need a special RJ11>D-type cable to use it (this should have been shipped with the library).

It may be worthwhile logging a hardware call with HP, if you're not confident using this utility.

Rich
Uli Böhm
Frequent Advisor
Solution

Re: Backup Exec 11d does not find MSL6030

You could change the product- & vendor identification in the Menu. On the Display/ Touchscreen press Menu, than SCSI at "edit options". You find Product- & vendor identification there.
Miika T
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

I couldn't locate the option from the menu, and I used mslutil instead. Unfortunately, this only gives the option to choose between Compaq and Overland :-( No HP available.

-Miika
Miika T
Valued Contributor

Re: Backup Exec 11d does not find MSL6030

I upgraded the HP_6000_520 firmware, but before it was possible, I needed to modify manually the Vendor information with mslutil. After this I cold booted the library and the possibility to change the vendor information in the menu structure came available (mslutil still displayed only Compaq/Overland). By doing this Backup exec recognized the library just fine.

Thanks to everyone!

-Miika