Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

D2D2503i - dual port network configuration

Hettegger Matthias
Occasional Contributor

D2D2503i - dual port network configuration

Hey there

There is an option in the D2D2503i network settings, which puts de backup appliance in high availability mode and should also increase throughput.
according to the user guide, this option requires a network switch, which supports port bonding.

now how do I have to configure our switch? does the switch require the LACP protocol? we attached our d2d2500 to an cisco 2960 switch and couldn't get the dual network port configuration working...

thanks for your help!

matthias
8 REPLIES
DanC_1
Frequent Advisor

Re: D2D2503i - dual port network configuration

Hi Matthias,

The network mode that you need to select from the drop-down on the network config page is "High Availability" not "Dual Port".
HA mode bonds the ports on the D2D together as a single port hence only one IP address is required.
I don't know much about the Cisco 2960 but it should support trunked/bonded ports if it is relatively new and generally it is enabled by default. A quick web search seemed to indicate that it does (might be called Etherchannel by Cisco rather than LACP).
Can you tell me more about the problem that you are seeing and errors reported?

"Dual Port" is a different mode is intended to be used when there are two separate networks connected to the D2D box, these networks MUST be on separate subnets otherwise configuration will fail.

Hope this helps, if not please post more questions and I will get back to you.

Dan
Esteban Zarikian
Occasional Visitor

Re: D2D2503i - dual port network configuration

Hi, I'm also trying to get my D2D2503i to work in HA mode, but I've configured the interfaces and I can't get the device to talk LACP (802.3ad) with my cisco switches. It looks like there's something turned off in the D2D. My switch config (the relevant parts is):

!

port-channel load-balance src-dst-ip
!
interface Port-channel2
description BackupD2D P1
switchport access vlan 200
spanning-tree portfast
spanning-tree guard root
!
interface GigabitEthernet2/0/24
description BackupD2D P1
switchport access vlan 200
channel-protocol lacp
channel-group 2 mode active
spanning-tree portfast
spanning-tree guard root
!
interface GigabitEthernet3/0/1
description BackupD2D P1
switchport access vlan 200
channel-protocol lacp
channel-group 2 mode active
spanning-tree portfast
spanning-tree guard root
end

I have three cisco 3750s, they're stacked and I've loaded software onto them that permits "inter-chassis" LACP within the same stack.

My switch shows the following:
sh int port 2
Port-channel2 is down, line protocol is down (notconnect)
Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)
Description: BackupD2D P1
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 0/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Auto-duplex, Auto-speed, link type is auto, media type is unknown
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 3 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

so the port channel interface isn't up

switch#sh int gigabitEthernet 2/0/24
GigabitEthernet2/0/24 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 000f.2491.0198 (bia 000f.2491.0198)
Description: BackupD2D P1
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 254/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:20, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1165170
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 4170000 bits/sec, 384 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
126833117 packets input, 117545249772 bytes, 0 no buffer
Received 16 broadcasts (15 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 15 multicast, 0 pause input
0 input packets with dribble condition detected
19740999 packets output, 1638237595 bytes, 0 underruns
435809 output errors, 0 collisions, 5 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
switch#sh int gigabitEthernet 3/0/1
GigabitEthernet3/0/1 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 000f.349b.6401 (bia 000f.349b.6401)
Description: BackupD2D P1
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:25, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 871550
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 2901000 bits/sec, 390 packets/sec
24170205 packets input, 4615803009 bytes, 0 no buffer
Received 381 broadcasts (10 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 10 multicast, 0 pause input
0 input packets with dribble condition detected
208547868 packets output, 179541145827 bytes, 0 underruns
435775 output errors, 0 collisions, 5 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

and the LACP shows:

switch#sh lacp 2 internal
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode

Channel group 2
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi2/0/24 SA indep 32768 0x2 0x2 0x4E 0x7D
Gi3/0/1 SA indep 32768 0x2 0x2 0x6D 0x7D
switch#sh lacp 2 neighbor
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode

Channel group 2 neighbors

Partner's information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Gi2/0/24 SP 0 0000.0000.0000 4294967s 0x0 0x0 0x0 0x0
Gi3/0/1 SP 0 0000.0000.0000 4294967s 0x0 0x0 0x0 0x0

So LACP isn't being seen on the interfaces, on the last command the SP sometimes changes to SA (goes from passive to active) when I reset the interfaces.

The main reason I'm trying this is because my verify times with symantec backup exec 12.5 are too high, it takes more time to verify than to backup 65GB. If this is normal, it would also help for you guys to point it out since I don't have a lot of experience with D2Ds.

Thanks for your help!

Steve
Hettegger Matthias
Occasional Contributor

Re: D2D2503i - dual port network configuration

Hi Steve

I finally managed to get the HA mode working on my Cisco switch .

It seems, that the D2D25000 appliance is not LACP capable. Fortunately, you can create etherchannel on Cisco switches without the need of LACP or PAgP by selecting the ON keyword at the end of the channel-group command.
Below you can find my etherchannel configuration on my Cisco 2960 switch for the D2D2500 appliance.

Hope, this helps you further.

Regards,
Matt



!
interface GigabitEthernet0/1
description ETHCH WHOD2D1
switchport access vlan 2
switchport mode access
channel-group 5 mode on
spanning-tree portfast
!
interface GigabitEthernet0/2
description ETHCH WHOD2D1
switchport access vlan 2
switchport mode access
channel-group 5 mode on
spanning-tree portfast
!
Esteban Zarikian
Occasional Visitor

Re: D2D2503i - dual port network configuration

Hi Matthias!

I was hoping there was a way to enable LACP on the D2D, but well, I guess it's gonna be "manual failover" then. Do you have any recommendations on the load balancing scheme?

Thanks again for your help!

Regards,

Steve
bryan Obra
Occasional Visitor

Re: D2D2503i - dual port network configuration

I cannot get this configuration to work. I have my etherchannel set to On(no lacp). Status says working but I cannot access the web admin nor can backup exec see it. when I turn off the etherchannel it works again
Beth_3
Occasional Advisor

Re: D2D2503i - dual port network configuration

I have the exact same problem. When I enable port bonding on my cisco switch (etherchannel), I can no longer access the D2D 2504 by ping, backup exec or HTTP. I tried the on option and it still didn't work. LACP is not enabled.
Every problem can be solved.
bryan Obra
Occasional Visitor

Re: D2D2503i - dual port network configuration

I have an open case with HP but noone will answer the question:
case history:
me:
what teaming technology is used on the d2d device when in high
availability mode. How do I configure the etherchannel on the
cisco switch to recognize the team?

hp:
Hi there,
The High Availability mode provides increased bandwidth, but both network ports must be connected
to the same switch, which must support port bonding. And is set up throu the Web Management
Interface. Single port configuration is the default mode.

me:
What standard does it conform to? Is it lacp compatitable?

me 5 days later:
What is the status of this? Still waiting on answer to the port bonding standard the device uses and how to setup the etherchannel on a cisco switch

me 5 days after that:
Is anyone ever going to answer my question? This is horrible turn-around time for something in warranty

me same day:
Thank you for putting me on hold for 40 minutes then hanging up on me. HP support is top notch



DanC_1
Frequent Advisor

Re: D2D2503i - dual port network configuration

The current implementation of "High Availability" mode ports on D2D products provides port failover and some limited level of bandwidth aggregation.
It uses Linux bonding mode 5 (adaptive transmit load balancing), this does not required LACP or Etherchannel configuration (in fact on Cisco switches configuring LACP/Etherchannel will result in connections not being possible).
So take any ports on the switch out of LACP/Etherchannel mode and it should work.