Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

DL380G4, Ultrium448 + 374654-B21

Mann_2
Frequent Advisor

DL380G4, Ultrium448 + 374654-B21

Hi at all,

sorry for my english!

I have a problem an external Ultrium 448 on a 1 channel SCSI Controller(374654-B21, U320).

I have integrated the controller in my DL380G4 Server and i have connect the Ultrium on the controller.

My OS is RH ES 4.
The Server start without problems, but i can't find the Ultrium in the system.

Less /proc/scsi/scsi say's :

no attached device.
-----------------------------------------------

dmesg:

Freeing unused kernel memory: 172k freed
SCSI subsystem initialized
HP CISS Driver (v 2.6.6-6)
cciss: Device 0x46 has been found at bus 4 dev 3 func 0
ACPI: PCI interrupt 0000:04:03.0[A] -> GSI 51 (level, low) -> IRQ 217
cciss: using DAC cycles
blocks= 426759840 block_size= 512
heads= 255, sectors= 32, cylinders= 52299

cciss/c0d0: p1 p2
Fusion MPT base driver 3.02.56
Copyright (c) 1999-2005 LSI Logic Corporation
Fusion MPT SAS Host driver 3.02.56
Fusion MPT SPI Host driver 3.02.56
ACPI: PCI interrupt 0000:06:01.0[A] -> GSI 74 (level, low) -> IRQ 225
mptbase: Initiating ioc0 bringup
ioc0: 53C1030: Capabilities={Initiator,Target}
scsi0 : ioc0: LSI53C1030, FwRev=01032700h, Ports=1, MaxQ=255, IRQ=225
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
SELinux: Disabled at runtime.
SELinux: Unregistering netfilter hooks

All bugs added by David S. Miller
cciss0: No device changes detected.
cciss0: No appropriate SCSI device detected, SCSI subsystem not engaged.
cciss0: No device changes detected.
cciss0: No appropriate SCSI device detected, SCSI subsystem not engaged.
i2c /dev entries driver
lp: driver loaded but no devices found
eth0: no IPv6 routers present
cpqci: module license 'Proprietary' taints kernel.
Fusion MPT misc device (ioctl) driver 3.02.56
mptctl: Registered with Fusion MPT base driver
mptctl: /dev/mptctl @ (major,minor=10,220)
mptbase: ioc0: IOCStatus(0x0002): Busy
mptbase: ioc0: IOCStatus(0x0002): Busy
mtrr: type mismatch for fc000000,800000 old: uncachable new: write-combining
mtrr: type mismatch for fc000000,800000 old: uncachable new: write-combining
-----------------------------------------------
Fusion MPT misc device (ioctl) driver 3.02.56
mptctl: Registered with Fusion MPT base driver
mptctl: /dev/mptctl @ (major,minor=10,220)
mptbase: ioc0: IOCStatus(0x0002): Busy
mptbase: ioc0: IOCStatus(0x0002): Busy


The MPT Driver is for the SCSI-Card 374654-B21?


How can i find my ultrium under RH and as I recognize whether that is correct?

thanks for help

kind regards

Roland
Roland
6 REPLIES
Basil Vizgin
Honored Contributor

Re: DL380G4, Ultrium448 + 374654-B21

Basil Vizgin
Honored Contributor

Re: DL380G4, Ultrium448 + 374654-B21

Mann_2
Frequent Advisor

Re: DL380G4, Ultrium448 + 374654-B21

Hi Basil,

thanks for the answer.

I have tried to install the driver for HBA Controller from :
----------------------------------------------------------------
http://h18000.www1.hp.com/support/files/server/us/download/23765.html

HP U320 SCSI Adapter and SAS HBA with RAID (AMD32 & x86) Driver for Red Hat Enterprise Linux 4 (x86)
version 3.02.56-4 (10 Oct 05)
This RPM is used to provide binary driver modules that have been pre-built for your Linux Distribution to enable the HP ProLiant 64-bit/133-MHz Dual Channel Ultra320 SCSI HBA and HP U320 64-Bit Single Channel SCSI G2 HBA, HP U320 64-Bit Single Channel SCSI HBA, HP 8 Internal Port SAS/SATA HBA with RAID and HP 4 Internal Port SAS HBA with RAID. This RPM provides a customer friendly approach to install a pre-built binary driver.

----------------------------------------------

But after installation the system doesn't say :
---------------------------------------------
# rpm -ivh mptlinux-{version}-(release).{distro}.{processor architecture}.rpm

Setup is now complete. Please REBOOT your computer NOW!!
---------------------------------------------

altough rpm -qa say the rpm is installed

The driver built any of new kernelversions with name :

/boot/grub/menu.lst

#boot=/dev/cciss/c0d0
# default=0 # commented out by Proliant HBA install script
# default=3 # commented out by Proliant HBA install script
default=5
fallback=3
# fallback=0 # commented out by Proliant HBA install script
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux ES (2.6.9-5.ELsmp)
root (hd0,0)
kernel /boot/vmlinuz-2.6.9-5.ELsmp ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.9-5.ELsmp.img
title Red Hat Enterprise Linux ES-up (2.6.9-5.EL)
root (hd0,0)
kernel /boot/vmlinuz-2.6.9-5.EL ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.9-5.EL.img
# This entry (no. 2) added by Proliant HBA install script
title HP-2.6.9-5.EL
root (hd0,0)
kernel /boot/vmlinuz-2.6.9-5.EL ro root=LABEL=/ rhgb quiet
initrd /boot/HP-initrd-2.6.9-5.EL.img
# This entry (no. 3) added by Proliant HBA install script
title HP-2.6.9-5.ELsmp
root (hd0,0)
kernel /boot/vmlinuz-2.6.9-5.ELsmp ro root=LABEL=/ rhgb quiet
initrd /boot/HP-initrd-2.6.9-5.ELsmp.img
# This entry (no. 4) added by Proliant HBA install script
# in package mptlinux-3.02.56-4.rhel4
title HP-2.6.9-5.EL-0
root (hd0,0)
kernel /boot/vmlinuz-2.6.9-5.EL ro root=LABEL=/ rhgb quiet
initrd /boot/HP-initrd-2.6.9-5.EL.img-0
# This entry (no. 5) added by Proliant HBA install script
# in package mptlinux-3.02.56-4.rhel4
title HP-2.6.9-5.ELsmp-0
root (hd0,0)
kernel /boot/vmlinuz-2.6.9-5.ELsmp ro root=LABEL=/ rhgb quiet
initrd /boot/HP-initrd-2.6.9-5.ELsmp.img-0
--------------------------------------------


but by type uname -a the answer is

2.6.9-5.ELsmp #1 SMP Wed Jan 5 19:30:39 EST 2005 i686 i686 i386 GNU/Linux

he doesn't boot a HP kernel by change from HBA-script.

can it come to problems while the system boot from HDD's on the internal Smart Array 6i controller and the HBA-Script will change the kernel?

lsmod shows me :

mptctl 60676 0
mptspi 12808 0
mptsas 12424 0
mptscsih 42140 2 mptspi,mptsas
mptbase 56608 4 mptctl,mptspi,mptsas,mptscsih
cciss 55620 3
sd_mod 20545 0
scsi_mod 116557 7 ide_scsi,sg,mptspi,mptsas,mptscsih,cciss,sd_mod


Thank you for help again

best regards

Roland

Roland
Mann_2
Frequent Advisor

Re: DL380G4, Ultrium448 + 374654-B21

Hi,

please someone could explain me how can i search the Ultrium Tape in the Redhat-Linux-System.

normally I can find tape-devices under /proc/scsi/scsi as attached.

is it also by the HBA-controller?

for which I must look?

all HBA-driver are loaded, i can see them per lsmod.
---------------------------------------------
ide_scsi 19913 0
mptctl 60676 0
sg 38113 0
cpqci 34096 3
parport_pc 27905 0
lp 15405 0
parport 37641 2 parport_pc,lp
autofs4 22085 0
i2c_dev 14273 0
i2c_core 25921 1 i2c_dev
sunrpc 137637 1
8021q 22089 0
dm_mod 57157 0
button 10449 0
battery 12869 0
ac 8773 0
md5 8001 1
ipv6 238817 12
uhci_hcd 32729 0
ehci_hcd 31813 0
hw_random 9557 0
tg3 79173 0
bcm5700 140908 0
floppy 58065 0
ext3 118473 1
jbd 59481 1 ext3
mptspi 12808 0
mptsas 12424 0
mptscsih 42140 2 mptspi,mptsas
mptbase 56608 4 mptctl,mptspi,mptsas,mptscsih
cciss 55620 3
sd_mod 20545 0
scsi_mod 116557 7 ide_scsi,sg,mptspi,mptsas,mptscsih,cciss,sd_mod
------------------------------------------------


thanks for all answers

kind regards

roland
Roland
Mann_2
Frequent Advisor

Re: DL380G4, Ultrium448 + 374654-B21

Hi,

i have found the failure.

The original HP-VHDC-connector from the ultrium has a defective pin, verry hardly recognize!

now, it works fine.

the performance of the ultrium is ingeniously.

Thank's to Bazil for help again

best regards

Roland
Roland
Mann_2
Frequent Advisor

Re: DL380G4, Ultrium448 + 374654-B21

show last thread
Roland