Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Tape Libraries and Drives
Showing results for 
Search instead for 
Did you mean: 

DLT hard error I2C command

Go to solution
gwen guerin
Occasional Contributor

DLT hard error I2C command


I get a hard error on the screen of my DLT Suretore E 2/20 library :


Failed inventory check on a drive.
I2C command did not complete successfully

(more button pressed)

failed inventory check at storage slot 20

(more button pressed)

code 64, qualifier 60
sequence 108, 109, 110, 108, 109, 110

what is the problem?? the drive? or something else!!

thanks for the future answers, as I was planning to buy a new drive....

Satish M.S.
Valued Contributor

Re: DLT hard error I2C command


The issue with the 2/20 (Galactica) library may not only be the drive but most likely the shuttle assembly/picker.

Code 64: Transport unable to inventory drive. This means that either the picker is misaligned or not able to sense the drive itself

Qualifier 60: Internal bus command did not complete successfully.

Error 12C: Plunge Control system detected an error

Try the following from the front panel of the library

1. Home Screen - Main Menu - Adminstration/Service/ Run Test ==> Run Full Sweep Test and Recalirate Loader

Let us know the results.


gwen guerin
Occasional Contributor

Re: DLT hard error I2C command


thanks for the answer, but I can't get in service menu as I don't have the service code.....maybe there's a master code for service?

I bought the library for 70Euro maybe a year ago, in a non-working state, because one of the drives had failed, then I brought it home, I put the failed drive off the library, and it worked again!!

a few days ago, I had to move it to another location 2 meters away from its previous location, and since it started not to work...

I forgot to say something :

when the robotics has finished the inventory check in the left magazines, it checks the drive.....then it looks like it tries to pick up a cartrigde in the drive, then the drive goes offline, and the robot goes on to the right magazines....

after, when I try to put the drive back online, it won't....

what could be the problem!!!!

I really need it to work, even with only one drive, because I have nearly 1To to backup!!!

Acclaimed Contributor

Re: DLT hard error I2C command

First - mechanical components could get worn over the years, especially DLT drives.

I would install HPs LTT and upgrade the firmware. This will resolve some problems.
After this run some dozen sweep tests.

But if you have bad luck, your drive is gone.

Hope this helps!

There are only 10 types of people in the world -
those who understand binary, and those who don't.

No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Satish M.S.
Valued Contributor

Re: DLT hard error I2C command


Further to Torsten's suggestions, the service access password can only be obtained via the HP Tech Support.

Also, as Torsten pointed out, firmware upgrades on the library and drives will be a good start

Curtis Ballard
Honored Contributor

Re: DLT hard error I2C command

64/60 as mentioned is a failure to inventory the drive. This error code means that there is a drive module problem. Usually nothing to do with the transport assembly. The move sequence shown here is a magazine slot inventory check so the picker was not moving at the time of the error which means this was almost certainly caused by a drive module response.

Various errors can cause the problem. The library will try to close the drive door since the drives do not come ready with the door open. After the drive comes ready the library will open the door if the drive is empty. After this error the library will turn off the drive.

If the door close operation fails, the drive does not come ready, the door open operation fails, or the drive reports full and the picker is unable to find a tape in the drive. In this case the picker never looked for a tape in the drive so that is not the issue.

I think you have a failed drive module. Maybe something simple like the door assembly being stuck but very possibly a drive self test failure.

L&TT can read the drive logs and see if there is a drive self test failure.
gwen guerin
Occasional Contributor

Re: DLT hard error I2C command

first of all, thanks for all the answers!!

but there remains a problem, a big one.....

I did install an run LTT, but since the drive is put offline after the error, I get another error in LTT, which says that the library failed to recognize the drives...

I've found drives on eBay for $180, I think I'm gonna buy one for the moment, and another one later, the seller has 43 drives!!!

another detail : when my library was working with only one drive, I tried to put the working in the other slot, and it didn't work this normal, or the card in which the connectors meet is defective too?

thanks in advance!!!