Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

Does anyone use IBM 3584 partioned library with OB4.1 or above

SOLVED
Go to solution
Dan Zucker
Regular Advisor

Does anyone use IBM 3584 partioned library with OB4.1 or above

My employer is looking into an IBM3584
library with LTO2 drives, to use in
partitioned mode, to be used by both
Omniback and Netbackup.

Does anyone use this configuration and have
you (had/not had) problems?

The library is supported by Omniback, but there
is no mention of partitioned mode, nor does
HP seem to have a comparable device.

Any and all input is appreciated.

Dan
3 REPLIES
Angus Crome
Honored Contributor
Solution

Re: Does anyone use IBM 3584 partioned library with OB4.1 or above

Yes, we use this setup. We have direct attached (Fibre) LTO-1 devices and a 226 Slot configuration. We have it partitioned into a 196 Slot with 6 drives and a 30 Slot with 6 separate drives. We use OBII 4.10 on the larger partition and Veritas Netbackup on the other. In the long run, there are only two gotchas with this setup. You cannot do simultaneous tape egress from the library (mostly a problem with NetBackup) and you can't keep the Library functions window up in (NetBackup). In both cases, the Software locks the Picker to itself, and requests from the other partition time out. It doesn't take much in the way of scheduling to get around these problems.

On the other note. I don't know if LTO-2 is supported in Omniback 4.10. This has been a point of debate, but I'm sure it will work in Data Protector 5.X. If you post again in a month, I will have completed an upgrade straight to 5.10 and can let you know. We may have LTO-2 drives by then.

One last thing, I would have to say, this setup has worked darned near flawlessly for us since the day we put it into production. Our only other problem is that rebooting certain HP-UX 11.00 machines during normal backups will cause a query or reset to the active drives and end the backup. This is not a problem specific to any tape drive or library. It is just a problem with HP-UX, not having anyway to lock the physical hardware to a single machine during backup. There are copeous threads on this within the forums. Good scheduling is always the best deterent.

As a reference. I have used OEM and direct manufacturer Libraries from most of the big players. This is the first IBM one I have ever used, and it has outperformed all the rest, hands down. However, software support for any hardware is always the most mitigating factor for technical area decisions (behind, of course, and say it with me....... $$$$$).
There are 10 types of people in the world, those who understand binary and those who don't - Author Unknown
Edward J. Segura
Frequent Advisor

Re: Does anyone use IBM 3584 partioned library with OB4.1 or above

I would like to expand on this same issue, but not quite the same. I have an rp2470 11.i Fiber attched ibm 3584 Library with 6xLTO2's. I can't seem to get the Library changer to show up. The drives are there and claimed, but no Changer. Is this supported? I have been installing the ATDD driver, what am I missing? Thanks
Dan Zucker
Regular Advisor

Re: Does anyone use IBM 3584 partioned library with OB4.1 or above

First look at ioscan -nf and see if after the first IBM drive you have a autoch device.

ba 12 1/10 lba CLAIMED BUS_NEXUS Local PCI Bus)
fc 1 1/10/0/0 td CLAIMED INTERFACE HP Tachyon XLr
/dev/td1
fcp 5 1/10/0/0.97 fcp CLAIMED INTERFACE FCP Domain
ext_bus 77 1/10/0/0.97.7.255.12 fcpdev CLAIMED INTERFACE Fe
target 112 1/10/0/0.97.7.255.12.10 tgt CLAIMED DEVICE
tape 17 1/10/0/0.97.7.255.12.10.0 atdd CLAIMED DEVICE I2
/dev/rmt/29m /dev/rmt/c77t10d0BEST
/dev/rmt/29mb /dev/rmt/c77t10d0BESTb
/dev/rmt/29mn /dev/rmt/c77t10d0BESTn
/dev/rmt/29mnb /dev/rmt/c77t10d0BESTnb
autoch 4 1/10/0/0.97.7.255.12.10.1 schgr CLAIMED DEVICE I2
/dev/rac/c77t10d1
ext_bus 78 1/10/0/0.97.8.255.12 fcpdev CLAIMED INTERFACE Fe
target 113 1/10/0/0.97.8.255.12.9 tgt CLAIMED DEVICE
tape 18 1/10/0/0.97.8.255.12.9.0 atdd CLAIMED DEVICE I2
/dev/rmt/30m /dev/rmt/c78t9d0BEST
/dev/rmt/30mb /dev/rmt/c78t9d0BESTb
/dev/rmt/30mn /dev/rmt/c78t9d0BESTn
/dev/rmt/30mnb /dev/rmt/c78t9d0BESTnb


Make sure autoch driver (from HP) is loaded into the kernel.