Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 6/60 tape library I/O errors on 1 tape drive

SOLVED
Go to solution
Robert Bryan
Frequent Advisor

HP 6/60 tape library I/O errors on 1 tape drive

HP SureStore 6/60 tape library...
Recieving I/O write errors when trying to write to one drive...No problem on the other 5 tape drive.
Firmware is the same level on all drives.
Problem followed bad drive when swapped with another location.
Installed replacement drive and it is getting the same I/O errors...
Need help what else could be generating this error other than the drive itself (or I recieved a bad tape drive out of stock)
11 REPLIES
Torsten.
Acclaimed Contributor

Re: HP 6/60 tape library I/O errors on 1 tape drive

Sounds like a bad drive until the replacement. Try another tape, if you always use the same.
Test the drive (with a new tape) with HPs LTT

http://h18006.www1.hp.com/products/storageworks/ltt/index.html

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Robert Bryan
Frequent Advisor

Re: HP 6/60 tape library I/O errors on 1 tape drive

I have tried new tapes no help and I have used the same tape in a different tape drive without any problems...
JASH_2
Trusted Contributor

Re: HP 6/60 tape library I/O errors on 1 tape drive

Robert,

Have you checked the wiring at the back of the tape array? If the tapes are not the problem and you have recently changed the drive, then there is not much more it could be?

Regards,

JASH
If I can, I will!
Robert Bryan
Frequent Advisor

Re: HP 6/60 tape library I/O errors on 1 tape drive

I have checked the cables and scsi terminator(no help)
I have moved just the tape drive and the problem followed...
I may have to assume the tape drive was bad out of stock
Robert Bryan
Frequent Advisor

Re: HP 6/60 tape library I/O errors on 1 tape drive

Also found that the firmware is not at the latest version...the tape library is at 1600 and the latest firmware version is 1720... The tape drives themselves are at the newest firmware level. V086-0ML3
Do not know why I did not recieve a firmware mismatch...
Curtis Ballard
Honored Contributor

Re: HP 6/60 tape library I/O errors on 1 tape drive

Are these drives fibre channel? From your comments I assume that they are parallel SCSI not FC SCSI. There were changes between 1600 and 1720 that improve FC SCSI read/write behavior but none for parallel SCSI.

When you moved the drive did you move only the drive and keep all of the other configuration? Cables, HBA, jobs assigned to drive location?

We have seen a few cases when particular backup jobs have trouble collecting data and will time out and fail the job. Sometimes that timeout looks like a drive problem when it was really a data collection problem. If the application is assigning backup jobs based on drive serial number then it is possible that even though you moved the drive the same job got sent to the drive in the new location. Changing the drive should have tested that case but maybe not if the app just saw the serial number change and automatically moved the jobs to the new drive.
Robert Bryan
Frequent Advisor

Re: HP 6/60 tape library I/O errors on 1 tape drive

Drives are HVDS SCSI Drives...2 sets of 2 drives on 1 SCSI controller and 2 sets of 1 drive on 1 SCSI controller...
I swapped just the tape drive with a tape drive from another controller...
I am unable to tar a file to this tape drive (independent of backup software)
Curtis Ballard
Honored Contributor
Solution

Re: HP 6/60 tape library I/O errors on 1 tape drive

I hate to see it happen, but it really sounds like your replacement drive must be faulty. One possibility, did you get a replacement drive from HP in a drive canister or did you get a bare mech from another source and put it into the canister you had? The canisters have a short cable in them and if you re-used that cable it is possible that it is damaged.

The most common cable damage I see is a bent pin in the cable will smash the plastic on the connector on the drive can then any cable you plug into that drive will get a bent pin and problems follow the drive. Sometimes the problems multiply as pins bend and damage connectors.
aleks mindlin
Frequent Advisor

Re: HP 6/60 tape library I/O errors on 1 tape drive

Drive firmware is not considered in firmware compartibility evaluation.

You could try LTT: "DLT drive acceptance test"
Edgar_8
Regular Advisor

Re: HP 6/60 tape library I/O errors on 1 tape drive

Hi Robert,

Im experiencing a similar problem where we are continuously receiving scsi timeout; media; drive and picking errors. We've replaced every component with the exception of the chasis. I must just say that I think we will have to look at the drives cabling again as a possible cause. Any suggestions welcome and let us know how you resolve the problem.

Regards,

Edgar
Robert Bryan
Frequent Advisor

Re: HP 6/60 tape library I/O errors on 1 tape drive

Problem was resolved...problem was a bad teminator on the drive