Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

HP CD-Writer 9900ci/RecordNow version compatability?

Russ_31
Occasional Contributor

HP CD-Writer 9900ci/RecordNow version compatability?

I have version 3.5 of RecordNow software and there is 4.56 version that requires version 3.55 to update. I downloaded software and it does not detect my version. Does anyone know if the update works with my drive, and if so how to get the upgrade?

Thanks, Russ