Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

HP Ultrium 3000 Not Showing in Device Manager

Rob88
Occasional Advisor

HP Ultrium 3000 Not Showing in Device Manager

My HP Ultrium 3000 external tape drive is not being detected by the computer at all. I've tried everything I could find with regard to installing drivers, checking compatibility, etc, but to no avail.

Symptoms:
* The tape drive powers up correctly, and the status LED stabilises into ready state
* The SAS controller shows up in Device Manager, but the tape drive does not
* HPE Library and Tape Tools Version 4.22 does not detect the tape drive, only the controller
* LTFS Configurator also fails to detect the tape drive

Tape drive:
* Hardware: HP LTO-5 Ultrium 3000, Model Number EH958B
* Driver Download Title: HPE StoreEver Tape Drivers for Windows (American, International), 4.2.0.0, 24 Oct 2016
* Relevant Driver: HP LTO Tape Drive 1.0.9.1

SAS controller:
* Hardware: LSI SAS 9201-16e 6Gb/s Host Bus Adapter
* More information: http://www.avagotech.com/products/storage/host-bus-adapters/sas-9201-16e#overview
* Relevant driver: Preinstalled for Windows 10, and also have tried the website driver download

SAS cable:
* Hardware: External SAS 6Gb/s cable
* Have tried the cable in all four external SAS ports on the controller card

Operating system:
* Windows 10 Pro, 64-bit

The computer is a standard workstation style machine.

I appreciate any advice you can provide - many thanks in advance for your help in resolving this issue.

5 REPLIES
Rob88
Occasional Advisor

Re: HP Ultrium 3000 Not Showing in Device Manager

P.S. The cable is marked  with "430066-001", which seems to show as compatible on PartSurfer:

http://partsurfer.hpe.com/Search.aspx?SearchText=EH958B

"430066-001 SAS Cable - External mini SAS (SFF8088) to mini SAS (SFF8088) - Connects to HP StorageWorks 1U SAS rack-mount kit - 2m (6.56ft) long"

 

The SAS controller is LSI rather than an HP model, but as far as I can see this shouldn't be a show-stopper?

Rob88
Occasional Advisor

Re: HP Ultrium 3000 Not Showing in Device Manager

I did find this page:

http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=emr_na-c02096846#N100A2

It indicates that (despite all the other compatibility guidance), when not using the drive with an HP server but with a third party workstation, the following controller/HBA is recommended:

"For 3rd Party servers and workstations
64-bit 133-MHz Single Channel Ultra320 SCSI G2 Host Bus Adapter (HBA)     374654-B21
This SCSI controller supports a wide range of connectivity to non-HP 32-bit servers."

More info on that card can be found here:

http://h18000.www1.hp.com/products/quickspecs/archives_North_America/11943_na_v7/11943_na.HTML

However that controller is actually not listed on PartSurfer as far as I can see:

http://partsurfer.hpe.com/Search.aspx?SearchText=EH958B

In the November 2016 v3 version of the HP Data Compatibility Matrix doc, there's no mention of it either. And actually:

http://h20566.www2.hpe.com/hpsc/doc/public/display?sp4ts.oid=412183&docId=emr_na-c04616269&docLocale=en_US

The "Hewlett Packard Enterprise - StoreEver Standalone Tape Controllers and SAS Cables // Workstation Only Controllers" lists only LSI cards.

So I'm really at a loss. I can buy one of those cards too in the hope that it makes a compatibility difference, but I have no real reason to believe it will help. Ideas?

Rob88
Occasional Advisor

Re: HP Ultrium 3000 Not Showing in Device Manager

In the absence of any replies here so far, I've ordered the following:

* HP P212 Smart Array PCI-E SAS SATA RAID
* HP Smart Array P410 P212 P411 256MB Write Cache Module

In the hope that this might be a compatibility problem. I'll post the results obviously when I've been able to re-test. However in the meantime I'd still really appreciate any thoughts / guidance on what the problem could be.

Many thanks, Rob.

Curtis_Ballard
Valued Contributor

Re: HP Ultrium 3000 Not Showing in Device Manager

I just read through your posting.  It is an interesting case.

SAS HBA support for tape drives is primarily determined by whether the controller supports all of the SAS protocol retry mechanisms.  Some SAS controllers don't and cause errors to be reported when the issue was one that should have been able to be recovered without error.  It is really rare for a controller to not detect/report the tape drive. A few array controllers block out devices that report as tape but I have only seen that with array controllers.

I haven't seen any examples of the Broadcom/Avago/LSI controller you mentioned in your first posting but I would expect that it should work.  Controllers in the LSISAS family usually have full SAS protocol support and work fine with tape even if they haven't gone through formal testing at HPE.

The HPE P212 with cache module card that you list in your later message definitely should work with your tape drive and has been tested with a lot of different HPE tape drives but it is an older controller that isn't tested very often anymore.

The cable you list should also be fine.

If there are any SAS BIOS utilities in your LSI controller it would be interesting to see if the controller BIOS is able to detect the tape drive. Otherwise I don't have a lot of suggestions I can offer at this point.

Rob88
Occasional Advisor

Re: HP Ultrium 3000 Not Showing in Device Manager

Thanks very much for the response Curtis. Really appreciate your thoughts.

I've looked hard for any kind of BIOS or configuration utility, but they seem to only be available for the integrated LSI controllers, not for PCIe cards. I did actually try SAS2IRCU, but it doesn't detect the controller, since I guess it's only interested in the dedicated RAID controller machines. Similarly, all the BIOS options / utilities are for the same kind of setup.

I get the same error message described at https://github.com/glensc/nagios-plugin-check_raid/blob/master/lib/App/Monitoring/Plugin/CheckRaid/Plugins/sas2ircu.pm as meaning no controllers are present.

> sas2ircu.exe list
LSI Corporation SAS2 IR Configuration Utility.
Version 20.00.00.00 (2014.09.18)
Copyright (c) 2008-2014 LSI Corporation. All rights reserved.

SAS2IRCU: MPTLib2 Error 1

I'll wait for the HPE P212 to arrive and then see what that yields.

Thanks again, Rob.