Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

Installing HP Library and Tape Tools v 4.6

SOLVED
Go to solution
welshowen
Occasional Advisor

Installing HP Library and Tape Tools v 4.6

I have succesfully installed hp_ltt on HP-UX 11.11, but when I try to run the exe, I get a permission denied message.

/opt/ltt/./hp_ltt
./hp_ltt: Execute permission denied

I know there was an issue in earlier versions, 3.4 and 3.5?? but any idea why I'm getting this problem now?

I'm logged in as root, I don't think it's a permissions problem.

Thanks.
19 REPLIES
Torsten.
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

What system model do you have?

AFAIK the application is made for PA-RISC 2.0, it doesn't work with 1.1 CPU's.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
welshowen
Occasional Advisor

Re: Installing HP Library and Tape Tools v 4.6

PA-RISC 1.1e

Is there an alternative, and can we be sure that it does not work on PA-RISC 1.1??

Thanks.
Torsten.
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

"Is there an alternative" - IMHO the old version only.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

What kind of device do you want to manage? What do you want to do?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
LTT Team
Valued Contributor

Re: Installing HP Library and Tape Tools v 4.6

Hi,

By default, the permission for hp_ltt would be -rwxr--r-- 1 root sys 16777216 Sep 25 12:11 hp_ltt

Please check the permission of hp_ltt. If they are not the same, could you assign executable permissions and verify if the issue is fixed.

Thank you,
Satya
L&TT Team
LTT Team
Valued Contributor

Re: Installing HP Library and Tape Tools v 4.6

It is true that the application is meant for PA-RISC 2.0 however it is also backward compatible with 1.1
welshowen
Occasional Advisor

Re: Installing HP Library and Tape Tools v 4.6

I have changed the permissions as instructed:

-rwxr--r-- 1 root sys 16572416 Jun 12 11:00 hp_ltt

But I still get:

/opt/ltt#./hp_ltt
sh: ./hp_ltt: Execute permission denied.
John Donovan
Regular Advisor

Re: Installing HP Library and Tape Tools v 4.6

Note the difference in size of your file compared to the one shown by the team...

Believe you don't have the complete hp_ltt file.

Hope this helps...
--donovan
"I have not failed. I've just found 10,000 ways that won't work." - Thomas Edison
Dennis Handly
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

>can we be sure that it does not work on PA-RISC 1.1??

It's called "trust but verify". What does "file /opt/ltt/hp_ltt" show?

>L&TT CPE Team: It is true that the application is meant for PA-RISC 2.0 however it is also backward compatible with 1.1

This doesn't sound like proper HP-UX speak. It should be something like:
This runs on PA1.1 and is forward compatible to PA2.0.

Torsten.
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

I doubt about the compatibility - I can only tell you that I'm not able to run applications made for PARISC 2.0 (including newer LTT versions) on my test system with
CPU Version: 1.1e PA7300.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Dennis Handly
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

>Torsten: I doubt about the compatibility - I'm not able to run applications ... on my test system with 1.1e PA7300.

What does file(1) show for your version of LTT?
Torsten.
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

First here is the info about a working version :

# swlist |grep -i ltt
HP_LTT35 3.5.3.0 Library & Tape Tools - HP-UX


# ll
total 28480
drwxrwxr-x 3 root sys 96 Apr 12 2006 catalogs
drwxrwxr-x 2 root sys 96 Sep 26 13:38 firmware
-rwxrwxr-x 1 root sys 14553088 Jun 28 2005 hp_ltt
drwxrwxr-x 2 root sys 96 Sep 26 13:41 logs
drwxrwxr-x 3 root sys 8192 Sep 26 13:41 misc
drwxrwxr-x 9 root sys 8192 Sep 26 13:38 scripts

# what hp_ltt
hp_ltt:
$Revision: 92453-07 linker linker crt0.o B.11.37 030623 $
HP92453-02A.11.00 HP-UX SYMBOLIC DEBUGGER (END.O ILP32) $Revision: 75.04 $

# file hp_ltt
hp_ltt: PA-RISC1.1 shared executable dynamically linked

# getconf KERNEL_BITS
32

# chatr hp_ltt
hp_ltt:
shared executable
shared library dynamic path search:
SHLIB_PATH disabled second
embedded path disabled first Not Defined
shared library list:
dynamic /usr/lib/librt.2
dynamic /usr/lib/libpthread.1
dynamic /usr/lib/libxcurses.1
dynamic /usr/lib/libcl.2
dynamic /usr/lib/libstd.2
dynamic /usr/lib/libstream.2
dynamic /usr/lib/libCsup.2
dynamic /usr/lib/libm.2
dynamic /usr/lib/libc.2
static /usr/lib/libdld.2
shared library binding:
deferred
global hash table disabled
plabel caching disabled
global hash array size:1103
global hash array nbuckets:3
shared vtable support disabled
static branch prediction disabled
executable from stack: D (default)
kernel assisted branch prediction enabled
lazy swap allocation disabled
text segment locking disabled
data segment locking disabled
third quadrant private data space disabled
fourth quadrant private data space disabled
third quadrant global data space disabled
data page size: D (default)
instruction page size: D (default)
nulptr references disabled
shared library private mapping disabled
shared library text merging disabled



Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

Now a non working:

# swlist | grep -i ltt
HP_LTT46 4.6.0.0 Library & Tape Tools - HP-UX


# file hp_ltt
hp_ltt: PA-RISC2.0 shared executable dynamically linked

# what hp_ltt
hp_ltt:
$Revision: 92453-07 linker linker crt0.o B.11.41 040906 $
HP92453-02A.11.00 HP-UX SYMBOLIC DEBUGGER (END.O ILP32) $Revision: 75.04 $




# ./hp_ltt
ksh: ./hp_ltt: Executable file incompatible with hardware


(I think is is a NEW message!)





>L&TT CPE Team: It is true that the application is meant for PA-RISC 2.0 however it is also backward compatible with 1.1



Hmm ...




Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Dennis Handly
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

>Torsten: hp_ltt: PA-RISC2.0 shared executable dynamically linked

That's pretty conclusive.
So they should change the documentation to say "no longer supported ...".
LTT Team
Valued Contributor
Solution

Re: Installing HP Library and Tape Tools v 4.6

Hi,

LTT 4.x is compiled with +DAportable flag.

The difference in binary size is due to the versions installed on the systems.

Please check if you are able to run this version

ftp://ftp.hp.com/pub/information_storage/software/ltt/hp_ltt32sr1_hpux.tar

Regards,
Satya
Dennis Handly
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

>L&TT CPE Team: LTT 4.x is compiled with +DAportable flag.

That's not what Torsten's file(1) shows. There may be one 2.0 object in some archive lib that you are using? If you don't strip your hp_ltt, you can use footprints(1) to find it.
If you still have any questions you can mail me directly.

>Please check if you are able to run this version

Yes, that's 3.2.1.0, PA-RISC1.1.
Torsten.
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

for this file I get

hp_ltt: PA-RISC1.1 shared executable dynamically linked


=> works.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Dennis Handly
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

>Torsten: for this file I get ... => works.

Yes, and would probably also run on 10.20.
Torsten.
Acclaimed Contributor

Re: Installing HP Library and Tape Tools v 4.6

IMHO the problem will only be seen on pre PA-8000 CPUs - like my small test box.
Such systems are old now, most are older workstations or early servers like "small" D-classes or A180 ...

The number of running systems like this will getting less, but (as you can see in this thread) they are still there.

If I assume that an old computer is connected to an old storage device, there are other possibilities to manage such devices (e.g. STM), because this is pre-LTT era.

So the "issue" is not this serious, but anyway, a clear statement or even a running version would be nice ...


;-)


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!