Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

MSL2024 connectivity to W2003

SOLVED
Go to solution
KC-DSM
Occasional Visitor

MSL2024 connectivity to W2003

Attempting to connect MSL2024 (2 480 drives) to w2003 via Adaptec 39160 HBA. Continually see up to 16 drives in device manager with no media changer. Have enabled LUN scanning on SCSI ID with no success. Have also tried several different HBA's (same model). Any suggestions would be appreciated.
5 REPLIES
Marino Meloni_1
Honored Contributor

Re: MSL2024 connectivity to W2003

I had a similar problem in the past (but not with 2003) so this may be the same behavior:
the cause was a bent pin in the cable, so I suggest you to check cabling, and terminators for damaged or bent pin in the connector, eventualy connect only the controller or only the drive in order to identify a defective component.
Curtis Ballard
Honored Contributor
Solution

Re: MSL2024 connectivity to W2003

Marino's suggestion is a very good one. Almost every single case I have worked on where drives showed up too many times was due to a bent pin in one of the cables and there have been a lot of those cases.

The only other case where I have seen that happen was when the HBA and the drive were set to the same ID so every time the HBA tried to connect to a device on the bus the drive would respond. Normally the HBA is at ID 7 but it can be moved. If you don't find any bent pins try changing the drive SCSI ID.

You can look in the registry to check and see what the ID of your HBA is: HKLM\HARDWARE\DEVICEMAP\Scsi then find your SCSI port and look for the Initiator Id.
KC-DSM
Occasional Visitor

Re: MSL2024 connectivity to W2003

Thanks for the response. We still have check the cables. However, since my last posting, just to try something, we installed HP tape drivers on all the drives including the ghosts. Immediately the ghost drives went away leaving 2 drives and the media changer(which didn't show up before). Now what we're seeing is:
1. If the server is powered off and we reboot the libary the tapes and media changer are detected during the BIOS SCSI scan for that HBA/port on the next server boot but the system hangs when trying to start windows.

2. After item one occurs, any further reboots of the server hangs at the BIOS SCSI scan for that port on the HBA. Eventually the scan will fail but the server comes (doesn't hang during windows startup).


KC-DSM
Occasional Visitor

Re: MSL2024 connectivity to W2003

As it turns out, HP replaced the entire library and everything started working as planned.
KC-DSM
Occasional Visitor

Re: MSL2024 connectivity to W2003

Library was replaced and attached to the W2003 with no issues.