Tape Libraries and Drives
Showing results for 
Search instead for 
Do you mean 

MSL2024 upgrade to LTO 5 firmware problem

Occasional Advisor

MSL2024 upgrade to LTO 5 firmware problem

I am trying to upgrade an MSL2024 from LTO 2 to an LTO 5 drive. The Library gives an error "Unsupported Drive".


From what I understand this should work as long as I upgrade the firmware.  Problem is, when I try to upgrade the firmware using the Library and Tape Tools it shows "wrong personality" for the new firmware (5.70).  Currently the library is using 4.4 and the drive (LTO 5 SAS) upgraded to firware version Z58W just fine.


The servers in question are not connected to the internet by design so I'm wondering if anyone can help me figure out how I can get the correct firmware to update this thing.



Frequent Advisor

Re: MSL2024 upgrade to LTO 5 firmware problem



LTO-5 support was introduced with Library code 4.90, you could try upgrading from 4.40 to a version before 5.70 ?


Also, how did you get the firmware 5.70 downloaded ? Through L&TT download mechanism ?


Another suggestion would be to also download the latest firmware bundle from here:






Occasional Advisor

Re: MSL2024 upgrade to LTO 5 firmware problem

@Eric,  Thanks for the reply!


I don't know how to get 4.9.  I downloaded the latest firware bundle (I believe the same one you have linked to) and it only has 2 files listed for MSL 2024 Library, Rev 1.91 and 5.70.


I would have tried the L&TT download but this server cannot be connected to the internet.

Occasional Advisor

Re: MSL2024 upgrade to LTO 5 firmware problem


Frequent Advisor

Re: MSL2024 upgrade to LTO 5 firmware problem

Question: Are you using Command-View TL to update the firmware or are you using the USB method ?


Honored Contributor

Re: MSL2024 upgrade to LTO 5 firmware problem



I have checked the release notes, but i find it strange that you library ever worked with an LTO5 SAS drive with FW 4.40. This rises the question, have you bought the lib like this or did you upgrade from LTO4 to LTO5 without checking the FW levels.


If you bought it like this, i strongly suggest to take contactwith the vendor for support, as you have an invalid config. If you did an upgrade you have 2 options.


Call to HP to get a downloadlink for an intermediate FW and upgrade this way or you can try the following, but it is at you own risk :

Shutdown lib >> remove LTO5 drive >> power on lib and update the Lib controller (in the understanding that L&TT will accept a lib without drive, i suspect that L&TT refused to update due to an invalid config)

Once done

Shutdown lib >> install drive >> power on and check with L&TT the operation of the lib.


This is undocumented and not supported by HP, use this a last option.


One advice, always do a library upgrade in a 2 step upgrade process.

first the controllers, then the drives.


I would like to have better news, but i hope to have helped you on your way.