Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

MSL4048 Ultrium 3000 FC WWN mystery

Dan Crossman
Advisor

MSL4048 Ultrium 3000 FC WWN mystery

We are attempting to install three MSL4048 LTO5 Ultrium 3000 FC tape libraries within a SAN environment. Each library has two drives.
Command View MSL reports that two drives from two different libraries have the same WWN port address!

See Serial Number and WWide Port Name below:


Vendor ID HP
Product ID Ultrium 5-SCSI
Serial Number HU1043DA0T
Firmware Revision Y32W
Physical Drive Slot Number 2
Element Address 2
Library LUN Hosted By Drive No
Data Compression Yes
Interface Type Fibre Channel
WWide Node Name 5001438012589B35
Port A
WWide Port Name 5001438012589B36
Port Type Automatic
Speed Automatic

Vendor ID HP
Product ID Ultrium 5-SCSI
Serial Number HU1047DNDC
Firmware Revision Y32W
Physical Drive Slot Number 1
Element Address 1
Library LUN Hosted By Drive Yes
Data Compression Yes
Interface Type Fibre Channel
WWide Node Name 5001438012589B35
Port A
WWide Port Name 5001438012589B36
Port Type Automatic
Speed Automatic


Different drives - same WWN name!


This is causing big problems with HP-UX 11.31 device names.


Additionally, all of the WWN port names as shown on the front panel of the libraries are unique, but are not the same WWN names as those reported by Command View MSL.

What can be done to fix this? Any advice is much appreciated.

Kind Regards,
-Dan
5 REPLIES
Torsten.
Acclaimed Contributor

Re: MSL4048 Ultrium 3000 FC WWN mystery

This is strange.


Normally the MSL itself has a unique WWN and generates and passes another unique WWN to the drive bays.

Can you confirm the chassis itself have different WWNs and the firmware is up to date?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Dan Crossman
Advisor

Re: MSL4048 Ultrium 3000 FC WWN mystery

My guess is the f/w version is current, as these are brand new. I wish it was easier to find out what the latest rev is.


Serial Number MXA050Z0HP
Product ID MSL G3 Series
Currently Installed Library Firmware 7.30 / 3.00e
Bootcode Firmware Revision 0.80
Barcode Reader SE625
Library Mode Automatic, Sequential
WWide Node Name 5001438012589B34


Serial Number MXA050Z0B5
Product ID MSL G3 Series
Currently Installed Library Firmware 7.30 / 3.00e
Bootcode Firmware Revision 0.80
Barcode Reader SE625
Library Mode Automatic, Sequential
WWide Node Name 5001438012589B31
Torsten.
Acclaimed Contributor

Re: MSL4048 Ultrium 3000 FC WWN mystery

Latest is 7.30 for the library.

How about the drives?

Looks like you have the latest too.

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=12169&prodSeriesId=3936307&swItem=co-38806-39&prodNameId=4305049&swEnvOID=4064&swLang=8&taskId=135&mode=4&idx=0


Ask HP for help?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Dan Crossman
Advisor

Re: MSL4048 Ultrium 3000 FC WWN mystery

On one of the libraries I swapped the locations of the two drives. What I observed was that the WWN did NOT change for the drives. That leads me to believe that Command View MSL (or the internal controller) is enumerating the WWN.

It also leads me to believe that if I had the drive with the duplicate WWN replaced, it would make no difference - the library would still use the same WWN for the drive.

-Dan
Dan Crossman
Advisor

Re: MSL4048 Ultrium 3000 FC WWN mystery

It turns out this is a known issue; apparently some libraries made it out of production with this issue during the Christmas timeframe. There is f/w code provided by L4 that fixes it. Install firmware 7a30 (this will change the WWIDs) then reinstall the released firmware 730. This has to be done using LTT (Library and Tape Tools); we couldn't make it work from the front panel or from the MSL web interface.

-dan.crossman@hp.com