Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

MSL5026 SAN Tape Library on RedHat 2.1 AS

Piyush Agrawal_2
Occasional Advisor

MSL5026 SAN Tape Library on RedHat 2.1 AS

Dear all,

I have a MSL5026 SAN Tape Library with single drive and HP NSR E1200-160 connected to HP SAN Switch 2/8-EL. There is NO Zoning configured. I have a Linux 2.1 Advanced Server box connected to the same SAN switch with one HBA. The problem is that I can not see the tape drive (SDLT 320) on Linux host. No device files are created by Linux. I used L&TT from where I can see MSL library at 10.2.0 detected but no attached SDLT 320 device.

The configuration on NSR E1200 are correct and as follows,

Bus Target LUN Type Status
0 0 0 CHGR UP MSL5000 Lib 0423
0 1 0 Tape UP Compaq SDLT 320

Can anyone help in getting this SAN Library work on Linux 2.1 AS, kernel build 2.4.9-e.38Enterprise

Thanks in advance
Piyush
Do it Right the First Time.
7 REPLIES
Uwe Zessin
Honored Contributor

Re: MSL5026 SAN Tape Library on RedHat 2.1 AS

Piyush,
have you checked the mapping on the NSR? It is not enough that you see the devices inside the NSR - he does not by default use a SCSI to FC map to present the devices to the host.
.
Piyush Agrawal_2
Occasional Advisor

Re: MSL5026 SAN Tape Library on RedHat 2.1 AS

Hi Uwe,
I have checked the NSR E1200 configuration and I have mapped explicitly the WWN ids of HBAs of servers who should see the library. By The way, we installed a Redhat rpm called 'mtst' which we found on the RedHat CDs and with this we could see the Tape drive as /dev/st0 on Linux. We could take 'tar' backup. However this is just one bit forward. We still need to see the Changer. There are no device files yet created on the Linux host for the changer. I guess we are missing some rpm or we need to create manually the device file for changer (Robotics). Any suggestions there ??

Thanks in Advance.
Piyush
Do it Right the First Time.
Shaikh Imran
Honored Contributor

Re: MSL5026 SAN Tape Library on RedHat 2.1 AS

Hi,
I read somewhere that Redhat rpm called 'mtst' which is available on the RedHat CDs.
Installing this rpm you could be able to use the tape drive.
Please try and revert back to confirm.

Regards,
I'll sleep when i am dead.
Piyush Agrawal_2
Occasional Advisor

Re: MSL5026 SAN Tape Library on RedHat 2.1 AS

Hi Imran,

Please see my post. We have installed 'mtst' and we are able to take backup through 'tar'. We are not able to get Changer (Robotics) device file created on the Linux host and hence are not able to use Data Protector.

Goal - Use Data Protector(Windows based) to take backup on MSL 5026 SAN Library from. Media agent installed on Linux host.

Hope this clarifies the requirement.

Thanks
Piyush
Do it Right the First Time.
Shaikh Imran
Honored Contributor

Re: MSL5026 SAN Tape Library on RedHat 2.1 AS

Hi,
i m sorry,i was facing some prob with my browser so i could not see the next post properly.
yes here we go further..

Do you have the robotic arm controller's device file
/dev/picker
If not exist try creating it through
mknod command ( see man mknod ).


Regards


I'll sleep when i am dead.
Shaikh Imran
Honored Contributor

Re: MSL5026 SAN Tape Library on RedHat 2.1 AS

Hi,
Never tried but also try this link it says that the available driver installs the library by itself.

http://linux.bytesex.org/misc/changer.html

Regards
I'll sleep when i am dead.
Abdul Salam H S_1
Frequent Advisor

Re: MSL5026 SAN Tape Library on RedHat 2.1 AS

Hi,

I'm continuing from Piyush's mail.
There's some improvement now in our issue.Initially, #cat /proc/scsi/sci was
showing only the SDLT Tape drive (/dev/st0)as a Sequential-Access
Device.The "Medium Changer" device was not visible.
When we executed the following command :
#echo scsi add-single-device lun> > /proc/scsi/scsi
the "autochanger" or "robotic arm" or "medium changer" (You may call it any of
these names) has also become visible.

As we came to know,the above command will enable multi-LUN support for RedHat
Linux temporarily.
The dmesg output shows both devices /dev/st0 (For the Tape Drive) & /dev/sge ( For the medium changer device)
So, both the robotic arm and the drive is detected by the RedHat OS.

But still we are not able to control the robotics arm using "mtx" utility which
we had downloaded. Using "mtx" we should be able to move tape from one Slot to
a Drive and from one slot to another slot.
When we executed: #mtx -f /dev/ status, the command fails.

Additionally,we have installed the HP Backup S/W "HP Data Protector" with the Cell Manager on a Windows 2000 server and Disk & Media Agents on our Linux machine.Data Protector S/W when run from the Windows machine is able to detect both the Medium Changer device & the Tape Device on the Tape Library attached to the RedHat Linux server and we are able to successfully configure the Library.But the library is not responding to any of commands sent to the "medium changer" from the Data Protector S/W running on Windows server.

The error messages from the Software are listed below:

Cannot load exchanger medium (No additional sense information)
Description:
The exchanger failed to complete the SCSI move command . An Operating System
error or a SCIS error has been encountered. The error message indicates the
reason as reported by the Operating System or the exchanger robotics.

Does anyone have some tool similar to "mtx" or some latest version of "mtx" which
can help us in isolating the Linux side? Once we are able to control the
robotic arm from within Linux, we can check it from Data Protector side.
Awaiting for some valuable suggestions.

Thanks & Best Regards,
Abdul Salam