Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

MSL5030 Tape Library in a SAN environment

SOLVED
Go to solution
Danny Matton
Occasional Contributor

MSL5030 Tape Library in a SAN environment

Hi,

Let me begin to explain the SAN environment:

-MSA1000 with 2 ctrl's connected to 2 separate SAN switch 8/EL (2 Fabrics)
-MSL5030 with 2 LTO1 drives and an internal NSR e1200 connected to only 1 of the 2 SAN switches.
- 3 proliant servers with 2 FCA2101 HBA's installed per server, each HBA is connected to the 2 separated SAN switches
- within the 3 proliant servers there is a 2 node cluster and a stand alone server
-Zonig is NOT configured
-OS = W2K SP4
-Backup Software = Veritas BUE 9.0 build 4454

PROBLEM:

Every time a backup completes on one of the servers there is an event logged in the System Event ID of each server:

Event ID 9: SOURCE: CPQKGPSQ
Description: The device, \Device\Scsi\CPQKGPSA1, did not respond within the timeout period.

RESULT:

Other servers lose connection with the Library and the jobs fails in Veritas BUE saying:

Storage device "hp LTO1 drive 1" reported an error on a request to space to end of data.
Error reported:
The request could not be performed because of an I/O device error.


Can someone help me on this?

THX
5 REPLIES
Eugeny Brychkov
Honored Contributor
Solution

Re: MSL5030 Tape Library in a SAN environment

Danny,
please on each server go to regedt32 and check CPQKGPSA registry settings: hkey_local_machine\system\currentcontrolset\services\CPQKGPSA\parameters\device. There should be driverparameters value. Please check if there's ResetTPRLO in the list set to 1. In addition check that EmulexOption as set as default 0xAA00. If you'll change any values server needs to be rebooted to make them effective.
BTW, you also may need to upgrade driver. It's highly recommended if server has 4.81 driver to upgrade to 4.82 (a14, a16) drivers.
Remember you should do it on ALL servers within SAN
Eugeny
Danny Matton
Occasional Contributor

Re: MSL5030 Tape Library in a SAN environment

Hi Eugeny,

Thx for the quick reply. I checked the settings and only the 'EmulexOption' parameter is different in our installation, we have 0xBA00. You recommend to change it into 0xAA00.

Can you provide some more details concerning this parameter?

All drivers and firmwares are upgraded to the latest version for every peace of hardware in the SAN environment.

Thx

Danny
Leon Rosier
Respected Contributor

Re: MSL5030 Tape Library in a SAN environment

In an EBS environment the ResetTPRLO setting should be set to a value of 2
(See EBS design guide)
The emulex option shuold be set according to OS:
- 0xAA00 for Windows 2000 SP2 and NT
- 0xBA00 for Windows 2000 SP3 & up

Leon
Danny Matton
Occasional Contributor

Re: MSL5030 Tape Library in a SAN environment

Hello,

I got an interesting remark back from the HP support staff in Belgium.

It looks like their might be connection problems with an internal NSR E1200 which runs at firmware version 5.01.04.

They proposed me to downgrade the firmware to version 4.03.19.

And guess what...

At first sight it looks like the CPQKGPSA errors are gone.

I will do some more testing, but like I told it looks OK.

Regards,

Danny
Leon Rosier
Respected Contributor

Re: MSL5030 Tape Library in a SAN environment

That's true, another workaround is to disconnect your network cable which goes to the NSR and wait till a new release firmware is available. 4.03.19 might introduce other issues because it is an older version.

Leon