Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

MSL6030 halfinchVRTS Error / Veritas

Astro2
Frequent Advisor

MSL6030 halfinchVRTS Error / Veritas

Hello

I'm using a MSL 6030 2 drives LTO-2 in a SAN configuration (3 server + 1 W2K cluster using SSO), Veritas Backup Exec 9.1 (4691) SP1, Windows 2000 Server / Adv. Server SP4.

I'm getting the error:
- Source: halfinchVRTS
- ID: 7
- Description: The device, \Device\Tape0, has a bad block
(I think halfinchVRTS is the Veritas driver of the tape)

and in the log BE of the job:
- Completed status: Failed
- Final error: 0x17 - Data error (cyclic redundancy check)

In the driver statistics, the Hard Read Errors or Write Read Errors are increased.

I changed all the media in the library, but the problem still exist. I also executed a manual clean of the drives, but the problem still exist.

The problem is random: 2 or 3 days all the jobs of all the servers are ok, and then the error occurs (sometimes on drive0, sometimes on drive1).

MSL6030 library firmware: 4.21
LTO-2 driver firmware: F43W
SW Veritas + patch updated at 1 OCT 2004

Any ideas ?

Many thanks
Armando Stroppari

20 REPLIES
Bostjan Kosi
Trusted Contributor

Re: MSL6030 halfinchVRTS Error / Veritas

HI,

are U using Network Storage router and if so please provide FW version...Are servers HP..are U using Management agents... versions, also versions of FW & Drivers for HBA...

br

B.
Nothing is impossible for those that don't have to do it themselves!
Astro2
Frequent Advisor

Re: MSL6030 halfinchVRTS Error / Veritas

Hi

All the systems are in production from Jan 2004 without relevant problems.

I'm using a NSR HP NSR1200-160:
- Vendor HP
- Product Network Storage Router
- Firmware Level 5.3.0b
- Bios Version BIOS 4.23
- Booter Version BOOTER 4.11
- CPU PLD Version 0x4
- Part/Serial # 262673-002_3F39LV61545S
- HW ID C01FWW

Servers:
- 5 HP PL380G3 (3 "single" - 2 in cluster MS W2K3)
- all the server W2K SP4
- all the server 2 HBA FC2101 (driver: 5-4.82a16) (fw/BIOS RB1.63A1 RS3.91A1)
- all the server SecurePath 4.0c

Management Agent:
- 7.10
- "subagent" Fiber Array Information disabled on all servers (for debugging this problem)

Storage & SAN:
- MSA1000 (2 controllers)
- 2 x switch 2/8 integrated in MSA 1000

In attach a survey of one of the servers.

Many thanks and best regards
Armando


Lars Floden
Frequent Advisor

Re: MSL6030 halfinchVRTS Error / Veritas

Have you tried using the HP driver for the tapes?

I ran the 4.21 firmware on those with only a few issues, but not this one. Of course I'm running Netbackup 5, but it definately sounds like a driver/firmware issue.

Try upgrading the HBA driver, I had a ton of problems with the earlier versions, currently at 3.92a2 and it works great. Plus there are upgrades for the NSR1200 and the library and drives. Just be careful on the router, when you upgrade it wipes the config and you have to redo the settings, took me half a day to figure it out, check your settings first.

Does your library have 2 drives? If so does it happen on both of them?

First thing to try though would be the tape driver, thats the easiest thing to go back on if something happens or it doesn't fix it.
Astro2
Frequent Advisor

Re: MSL6030 halfinchVRTS Error / Veritas

Thanks Lars

Veritas documentation advices to install Veritas driver.
Yesterday I updated the Veritas driver with the last version, but today the problem still remains.

The problem happens on both the drives.

HBA driver: I will try.

Best regards
Armando
Bostjan Kosi
Trusted Contributor

Re: MSL6030 halfinchVRTS Error / Veritas

Hi,

I'm not shure for veritas, but with DP I always disable Removable Storage service. Since DP is using also his own drivers I tend to disable also devices in Device Manager, so windows do not influence my setup...
Nothing is impossible for those that don't have to do it themselves!
Lars Floden
Frequent Advisor

Re: MSL6030 halfinchVRTS Error / Veritas

Veritas does recommend disabling the Removable storage service. But I believe Backup Exec works the same as Netbackup, it reads its device list from the device manager.

Still think it is a driver or firmware version and they need to be upgraded.
Bostjan Kosi
Trusted Contributor

Re: MSL6030 halfinchVRTS Error / Veritas

It would be certainly advisable to follow the latest EBS compatibility matrix, containing all supported current driver and firmware listings from:
http://h18006.www1.hp.com/products/storageworks/tapecompatibility.html

BR
B.

Nothing is impossible for those that don't have to do it themselves!
Astro2
Frequent Advisor

Re: MSL6030 halfinchVRTS Error / Veritas

Hi
Thanks for the suggestions.

The Removable storage service is disabled.

Driver / firmware: today I'll try to update:
- HP PSP (from 7.00 to 7.10)
- HBA FC2101 driver (5-5.10a10)
- HBA FC2101 FW (FCA2101_hpq_rc392a2)
- MSL 6030
- robot firmware 4.30
- driver firmware F59W
- firmware NSR 5.6.0.6

Many thanks
Armando
Astro2
Frequent Advisor

Re: MSL6030 halfinchVRTS Error / Veritas

Hi

Last friday I updated all driver / firmware (except NSR 1200-160), but friday night, during one job on one server in the System log:
Event ID 7, Source halfinchVRTS, The device, \Device\Tape0, has a bad block.

All the others server/jobs was OK.

I cannot update the firmware of NSR, because using LTT 3.51SR1 the software don't "sees" the NSR. How can I update this device ? There's a driver ?

Actual configuration:
- Proliant Support Pack 7.10
- HBA: driver 5-5.10a10, fw 392a2
- MSL6030: robot 0430, drivers F59W
- NSR 1200-160: fw 5.3.0b

I'll try to change one MSL drive ?

Many thanks
Armando
Astro2
Frequent Advisor

Re: MSL6030 halfinchVRTS Error / Veritas

Another information: before the BE jobs I stopped the HP Agents Storage and Foundation (and than I started at the end).

Armando
Bostjan Kosi
Trusted Contributor

Re: MSL6030 halfinchVRTS Error / Veritas

You connect to the NSR web page and log in...Leawe new FW file somewhare on your desktop.
Under utilities on the left side you'll see FTP..type in the username (root or admin) and password (password - default), NSR's ip address, click connect, browse to the file and select put...Than wait for a minute or two...

Check for reset tprlo parameter on emulex cards, and set it to 2 )using emulex util...

BR
B.
Nothing is impossible for those that don't have to do it themselves!
Astro2
Frequent Advisor

Re: MSL6030 halfinchVRTS Error / Veritas

Hi
NSR update: months ago updated using ftp, but the firmware file was in a differnet format (file 5.3.0b_fw_winston_x.dlx) that this new (file LTT_HP_E1200-160_5606.frm - LTT "format" ?).
This is not a problem ?

Many thanks
Armando
Claudio Ruzza_1
Valued Contributor

Re: MSL6030 halfinchVRTS Error / Veritas

Armando,
.frm is a firmware format suitable for LTT
.dlx is a firmware format suitable for FTP or serial connection to the nsr.
Do not use inappropriate version!
Claudio
Astro2
Frequent Advisor

Re: MSL6030 halfinchVRTS Error / Veritas

Hi

There's a version .DLX for the firmware of NSR 1200-160 ? Where can I download it ?

Many thanks
Armando
Bostjan Kosi
Trusted Contributor

Re: MSL6030 halfinchVRTS Error / Veritas

Hi

You can dl from HP site...

http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?locale=en_US&pnameOID=315730&taskId=135&prodTypeId=12169&prodSeriesId=315728〈=en&cc=us&swEnvOID=54

Nothing is impossible for those that don't have to do it themselves!
Astro2
Frequent Advisor

Re: MSL6030 halfinchVRTS Error / Veritas

Hi
Many thanks

On 15 feb I changed the tape0 of the library.

The jobs on that tape (tape0) are now all OK (5 days) and the Hard Read Errors and Write Read Errors in the driver statistics (in Veritas BE) still remains 0.

On the other tape (tape1), there was an error on 16 feb (and a BE job failed with CRC error as usual), but the error was
"timeout \Device\Scsi\lpxnds2". I think that the error is changed due the driver / firmware upgrade.
I tried to clean the tape1 (even there was no message that the tape need cleaning).
Now the jobs on that tape are OK (4 days)...

Only a cleaning problem ? But I cleaned both the tape twice although the documentation states to avoid excessive cleaning.
See also my old thread
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=708437

Thanks a lot !
Armando
Astro2
Frequent Advisor

Re: MSL6030 halfinchVRTS Error / Veritas

Hi

All is working fine.

Cleaning. From another thread (http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=708437):
"If the autoclean is enabled in Veritas, it will load the cleaning tape whenever an LTO drive is dirty."
But the BE software don't clean the drive when needed...

So I scheduled a cleaning job on both drive on first day of each month.

Any other suggestion ?

Many thanks
Armando
Bostjan Kosi
Trusted Contributor

Re: MSL6030 halfinchVRTS Error / Veritas

Hi,

I think once per month is much too much. Try other approach. Configure Library (use display) to assign a cleaning slot. LTO drives have their own internal cleaning mechanism and use external cleaning tape only when the drive finds out it can not clean itself automaticaly. In this case library will load cleaning tape into the drive by it self and clean it. Also do not to forget to correctly mark cleanin tapes with CLN barcone. If you clean drives so often, you'll destroy the drives + you will use your cleaning tapes to quickly.

BR
B.
Nothing is impossible for those that don't have to do it themselves!
Claudio Ruzza_1
Valued Contributor

Re: MSL6030 halfinchVRTS Error / Veritas

I agree: do not over-clean your drives, unless you like to make HP service engineers to swap it very often!
If you decide to use MSL internal cleaning capability, make sure to disable the BE cleaning feature, and vice versa.

HTH
Claudio
Astro2
Frequent Advisor

Re: MSL6030 halfinchVRTS Error / Veritas

Many thanks.

My "cleaning configuration" was:
- MSL6030: no automatic cleaning
- Veritas BE: 1 cleaning tape in slot X (I don't remember the exact slot) marked as "clean slot"
- the cleaning cartridge has CLN barcode
- no one cleaning job configured: if I create a cleaning job in BE, I must specify a scheduled time (run now or in the future)

In this situation, BE never submitted a clean (the number of cleaning in the cleaning cartridge properties was still the same). Se also my thread 708437.

The library never requested a cleaning: no request on the panel and the status (using the web interface of the library) was always "no need cleaning"...

I don't know if my problem was the drive or was the need of cleaning, but after I changed a drive and cleaned the other, all seems to working fine...for this reason I scheduled the cleaning job.

There's something wrong in my configuration ?

Thanks
Armando