Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

No Hardware Compression with HP Surestore dat40 (C5683A)

Steve Benson_2
Occasional Visitor

No Hardware Compression with HP Surestore dat40 (C5683A)

I'm using an HP Surestore dat40 (C5683A) with W2k Advanced server and can only seem to get the native capacitiy from HP dds4 tapes (C5718A rated for 40GB).

I'm using an Adaptec 29160 scsi controller connectd to the tape drive using LVD/SE.

Drive is flashed to latest firmware C111.

I'm using the latest drivers:
6.1.530.201 for Adaptec 29160

For DAT40 I have tried:
MS tape driver 5.0.2183.1
HP Suresrtore Dat 1.0
Veritas 04mmdat.sys

I've run the HP StorageWorks Library and Tape Tools and the drive passes all tests.

The compression ratio test reports 2.23:1 ratio and that hardware compression is enabled.

All 8 dip switches are on with the exception of 3 which is off. This is the drive default dip switch settings.

But the drive test shows a ratio of 0.96:1 after running a backup job with any of the following:

I've run Veritas Backup Exec versions 8.6 and 9, Yosemity Tapeworks 6.2 and even the Backup utility that comes with W2K.

All get approx.
19GB and then tell me the tape is full.

Can someone help me figure out why all these backup programs don't seem to be getting the dat40 hardware compression when run?

I've about driven myself nuts testing all the combinations of drivers/software. All give the same result about 19GB per tape.

Surely I've over looked something that's going to make me feel real silly. :)

Any advice would be appreciated.

Thanks,

....... Steve
11 REPLIES
Terri Harris
Honored Contributor

Re: No Hardware Compression with HP Surestore dat40 (C5683A)

I would recommend the following basic steps:

1. Disable RSM (Removable Storage) 2000 service. When using any other backup software, such as Veritas Backup Exec, RSM should be disabled.

Note: Make sure it really stops. Sometimes when you request the service be stopped (then set to MANUAL so it will not restart on a reboot), it never actually stops until the OS is restarted.

2. Then uninstall Backup Exec, then reinstall. Backup Exec will install the correct driver. Do not enable any software compression.

Does this make any difference?
Eugeny Brychkov
Honored Contributor

Re: No Hardware Compression with HP Surestore dat40 (C5683A)

Terri is correct, looks like software problem. During job execution backup utility disables drive's hardware compression. This overrides dip switch setting
Eugeny

Re: No Hardware Compression with HP Surestore dat40 (C5683A)

Steve, make shure, that the data are able to be compressed. If they are already compressed (for example jpeg or *.zip files) they can??t be compressed further by hardwarecompress. As a result you wil see only the native capacity of around 20 GB.

Marcus
Steve Benson_2
Occasional Visitor

Re: No Hardware Compression with HP Surestore dat40 (C5683A)

Thank you for your response to my question. It's greatly appreciated.

I tried the following:

1. Disabled RSM (Removable Storage) 2000 service.

2. Re-booted.

3. Checked to insure RSM was disabled and stopped (it was).

4. Re-installed Veritas Backup Exec 8.6 and updated 04mmdat.sys dated 9/11/02.

5. Configured Backup Exec for hardware compression only.

6. Ran a backup.

Still only gets the native capacity and prompts for another tape.

Help... is there something else I could try?

I found a doc on HP dat3 drives (I know mine is a dat4 but I was getting desperate :))named dat3.pdf that indicated the dip switches when set to 3 off all others on was for enabling hardware compression with software control (default) and that setting 2 and 3 off with all others on would enable hardware compression without software control.

Is that worth trying or should I not bother to go there?

Thanks for time and help,

......... Steve

Eugeny Brychkov
Honored Contributor

Re: No Hardware Compression with HP Surestore dat40 (C5683A)

Why not? Dip switches should be really the same. Instead of researching what is causing this software behavior let's disable its capability :o)
Eugeny
Terri Harris
Honored Contributor

Re: No Hardware Compression with HP Surestore dat40 (C5683A)

This issue does not want to easily resolve itself! My recommendation is to send an email directly to HP Storage. Include the L&TT tickets (generated from within L&TT) and include all the good info you have done here.

Include the serial number of the tape drive so we can check warranty status.

HP Email support:

http://productfinder.support.hp.com/tps/Hub?h_tool=email

Select these options to get to DAT40 email support: STORAGE - TAPE STORAGE - HP DAT TAPE DRIVES - HP SURESTORE DAT40 DRIVES
Steve Benson_2
Occasional Visitor

Re: No Hardware Compression with HP Surestore dat40 (C5683A)

Update.

Tried dip switch 2 set to off and got the same result.

The only difference was that Backup Exec reported no compression used on backup job and still got native capacity from tape.

I'd try to use support at HP but I'm afraid the drive is out of warranty. :(

Anyone have another idea for me to try?

Thanks for all your efforts,


.........Steve
Marino Meloni_1
Honored Contributor

Re: No Hardware Compression with HP Surestore dat40 (C5683A)



What are the cause of this behaviours:
-uncompressable data (like mp3, jpg, mpg,avi...)or compressed directory or disk
-Sw conpression enabled in the same time as Hw compression
-bad quality tape (you should found in diagnostic(L&TT) some errors logged)
- dat not in streaming mode, them space is lost, (you can see this in L&TT also)
-all or combinations of above causes

the test you can run with L&TT:

in the L&TT there is a test called compression test, this will write on your tape and give you at the end a ratio, a normal ration for this known data is 2.1/1,
you can run also the media validation test which will check if you tape is good or poor.
if you generate a support ticket, loking in the errors logged you can check if you had in the past read/write problems.
if everithing is ok, then you can try to disable the hardware compression and try to use software compression.
in order to do this , you have to move some jumper on the DAT itself:

dip 1 /dip 2 / Data Compression /Controll Compression
ON / ON / ENABLE / HOST CONTROL
ON /OFF / ENABLE /NO HOST CONTROL
OFF/ ON / DISABLE/ HOST CONTROL
OFF/ OFF/ DISABLE/NO HOST CONTROL

put the dip 1 and 2 in off

marino
Terri Harris
Honored Contributor

Re: No Hardware Compression with HP Surestore dat40 (C5683A)

What is the history on this tape drive? At what point did you notice the issue with no compression?
Steve Benson_2
Occasional Visitor

Re: No Hardware Compression with HP Surestore dat40 (C5683A)

The drive was not in use prior to last week.

It was in a system but a tape library DLT was used on another system for server backups.

When migrating to new servers I thought (silly me :)) while I was re-configuring the old servers I'd go ahead and configure this unused drive for potential use.

So, it's not a critical exercise but something of a frustration that it doesn't seem to be working correctly.

I cleaned the drive with a new cleaning tape. The tapes I'm useing are not new but have been used very little and are HP gold dds4 tapes.

I've checked the tapes with the media validation tests and they pass.

I've used the same tapes for the L&TT compression ratio test and they work fine, compression ratio reported by L&TT is 2.23:1.

All the L&TT tests (I've run each one several times) pass.

S/W compression has never been used, always hardware only or none (none used in the test of the 2-3 off test enable/no host control).

This is especially frustrating since I've been configuring backup systems with Backup Exec and Arcserve (and one Leggato Network Archivest) for many years, since '91 and have never encountered this problem before.

Admittedly this is the first time I've used an HP DAT 4.

I thought I'd create a directory and fill it with text only files in excess of 20GB and see what happens when I backup that dir.

I think that would eliminate the possiblitity of this all being caused by compression ratios on diff file types.

Any thoughts?




Steve Benson_2
Occasional Visitor

Re: No Hardware Compression with HP Surestore dat40 (C5683A)

Good news, I think.

I created a couple of simple ascii text files of 200 and 300 MB and then made duplicate copies in a directory until I had 29.5GB of data.

To my chagrin when I ran a backup it took the entire 29.5 GB on one tape.

Seems the compression algorythm on this drive is unable to compress 90+% of the files on my server.

Most of the files on this server are binary in nature, very few text files.

Of course I realize the compression ratio varies with the file types.

This was just cooincidentally getting a 1:1 or less ratio on the first tape which I mistook for a limitation due to the tape's native capacity.

When I've used other drives, mostly Exabytes, the compression seemed to work on most files and gave close to the specification compression ratio.

Well, live and learn I guess.

I certainly would like to thank everyone for their input and time.

Sorry it seems to have been such a silly thing.

........ Steve