Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem installing latest tape tools 3.5 SR1 on hp 11.00

MarkW_1
Regular Advisor

Problem installing latest tape tools 3.5 SR1 on hp 11.00

Getting the following response when trying to install as root:

# ./install_hpltt
Installing HP Library and Tape Tools...

Install requires approximately 10MB of free space under /opt
Beginning swinstall process of HP_LTT to /opt/ltt/

======= 02/15/05 09:16:40 MST BEGIN swinstall SESSION
(non-interactive)

* Session started for user "root@tiwal1".

* Beginning Selection
* Target connection succeeded for "tiwal1:/".
ERROR: "tiwal1:/tmp/HP_LTT35.depot": You do not have the required
permissions to perform this operation. Check permissions
using the "swacl" command or see your system administrator for
assistance. Or, to manage applications designed and packaged
for nonprivileged mode, see the "run_as_superuser" option in
the "sd" man page.
* Source connection failed for "tiwal1:/tmp/HP_LTT35.depot".
WARNING: More information may be found in the daemon logfile on this
target (default location is tiwal1:/var/adm/sw/swagentd.log).
* Selection had errors.



======= 02/15/05 09:16:46 MST END swinstall SESSION (non-interactive)
2 REPLIES
Curtis Ballard
Honored Contributor

Re: Problem installing latest tape tools 3.5 SR1 on hp 11.00

I've seen that error twice on other software products. It could be the same problem here.

Uncompressing a software package onto a shared drive as a different user caused the problem. I downloaded a depot.gz and did the gunzip as myself then switched to root but I had run gunzip from the server and was installing from a client. I had permissions set wrong and root on the client couldn't read the depot file.

Having the /opt directory mounted from another system and root on my system didn't have write permission.

Don't know if either of those are you problem but can be things to check. Generally whenever I am root and run into a permission problem I find it has something to do with mounted file systems.
MarkW_1
Regular Advisor

Re: Problem installing latest tape tools 3.5 SR1 on hp 11.00

I ended up rebooting the server for another purpoes, which cleared up the issue.