Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

TL891DLX: got an SDLT tape stuck in a DLT drive!

Matt Hearn
Regular Advisor

TL891DLX: got an SDLT tape stuck in a DLT drive!

We just onboarded a customer that included a bunch of Alphaservers with Tru64; I'm completely unfamiliar with that hardware and OS, so I'm learning as I go.

A production server has an SDLT tape library attached. The app guys wanted to refresh their DEV environment, so I had the tape operators recall a set of backups from offsite and asked them to mount them in the library for the development server, which turned out to be a TL891DLX with DLT drives in it. I moved one of the tapes into a drive, and suddenly I'm getting I/O errors and robot failures and all kinds of ugly stuff, the end result of which I had the operator reboot the library, and now it's just coming up with Tape Stow errors.

None of this is surprising, now that I realize that the library is DLT only, and there's a separate stand-alone SDLT drive hidden inside the server rack for these refreshes. There was much agonized laughter when I discovered this useful tidbit of information that's not listed ANYWHERE in my documentation.

Now I'm left with an SDLT tape stuck in the DLT drive in the library, and I dunno how to get it out. I was at least able to get the magazine out, so I can reach in and feel the tape in the drive, but pressing what I believe to be the "unload" button isn't having any effect. I can't really SEE what I'm doing, so I'm not even sure if the tape is all the way in the drive or not.

Any ideas what I might be able to do to shake this tape loose? I've put a call in to our hardware vendor, but I can't honestly say when to expect them onsite.

Thanks!!!
2 REPLIES
Mark Poeschl_2
Honored Contributor

Re: TL891DLX: got an SDLT tape stuck in a DLT drive!

Given the differences in the physical media, I suspect a) that your SDLT cartridge is ruined and b) that the H/W field engineer is the only one who's going to be able to get the tape out.

Is the face of the cartridge flush with the front of the drive - or nearly so? If so the cartridge is "all the way in."
Matt Hearn
Regular Advisor

Re: TL891DLX: got an SDLT tape stuck in a DLT drive!

Get this: our hardware vendor gets onsite, disassembles the library, and manages to get the tape out. After a few minutes, he determines that a tape leader is still in the drive, so I'm thinking crap, the tape's destroyed. I look in the tape and don't see a leader, which seems to confirm this. But then I check the other SDLT tapes and don't see leaders either, at least not the ones I expected to see (like the DLT ones). On a whim, I mounted the tape in the actual SDLT drive, and it didn't spit out any errors. Weird. I ran the restore, and it completed fine! Strange situation.

As far as I can tell, somewhere along the way a leader got ripped out of an actual DLT tape and screwed up the the drive; when I tried to mount an SDLT tape in it, it didn't even attempt to grab the leader.

Weird. Anyway, we're all fixed now.