Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

SOLVED
Go to solution

Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

Hello ALL,

I'm facing performance problems with HP Storageworks (2 SDLT 160/320).
Performance: 4Mb/s

I don't know why but I can go with 15Mb/s with this tape library and SDLT drivers.

I know that performance problems are very dificult to solve, but here it is my landscape:

Software:
Windows 2000 Server
Legato Networker 6.2
Server Protect

Hardware:
HP ML370
2 proc P3 1.4 Ghz
4 HD 18.2 Ghz (2 arrays=0+1)
768 Mb RAM
4 NIC with Gigabit


What I did:
1) Upgrade on server: +1 proc, +256 memory, +2 HD for paging file;
2) New SCSI-3 controller from HP dealer, the performance remains very bad - Performance: 4Mb/s;
3) New SCSI-3 controller from Adaptec (mod:29160) - Performance: 4Mb/s;


It's ridiculous but I did many stupid things on this situation. It's only because I'm desesperate !

Many many thanks,
Bruno Evangelista

12 REPLIES
Claudio Ruzza_1
Valued Contributor
Solution

Re: Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

Bruno,
have you tried to test your library with LTT?
There's a test that can help you to determine if your hardware is working fine

Get ltt here: http://www.hp.com/support/tapetools

Install it, choose a drive, mount a cartridge in it, run "test", choose "Write test" and check the performance.
This test write to drive a pattern generated in the server's RAM, no network and software involved.

This is a good startin point, i believe.

HTH
Claudio
Ingo Duschl
Frequent Advisor

Re: Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

have a look a the blocksize settings in the backupsoftware in arcserve there is setting for it.it makes it much faster to set high as possible

Re: Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

The block size is 64 Kb and Legato Networker doesn't allow me do change this settings.

Thank you for your help.

Re: Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

Here it is the results of test:

Transfer rate : 4.9 MB/s (during test execution - write)
Transfer rate : 10.0 MB/s (during test execution - read)
Read/Write Test - PASSED.


The Device Analysis was completed and no problems were found. This does not guarantee a failure-free device, but rather indicates that no known problem was identified on the device.
Device Analysis - PASSED.


Connectivity Test - PASSED.


Test Script - PASSED.


What could be wrong? Why I can't increase transfer rate?

Thanks you,
Bruno
Marino Meloni_1
Honored Contributor

Re: Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

I would recommend to run the device performance test and system performmance test from LTT, the first check the path from the server to the drive, the second the path from disk to server memory, it should be a bit longer than the write test and let you select various setting, just usefull for tuning based on results.

Can you also attach a support ticket collected just after the test took place, and if possible with the tape still in the drive.

The problem may be with bad tapes, or read/write problems. this also can cause poor performnace due to lots of retry.
Another cause may be due to tape drivers or scsi drivers, try to install from differents vendors

marino
Claudio Ruzza_1
Valued Contributor

Re: Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

Bruno,
you got a very important information: your drive(s) write at a low speed.
Try the second drive too, just to make sure you have the same problem.

I've ran once in a similar problem. It turnd out it was a setting on the SCSI card.
In my case the customer and me were dealing with an Adaptec card.
We walked thru the SCSI card Bios and we increase the SCSI speed.

Are your SCSI cards dual bus? If yes, did you connect both drives to the same bus? Try to split drives in two buses.

HTH
Claudio

Re: Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

Hello ALL,

I'm putting here what I did since yesterday:

With LTT
SDLT 2
Transfer rate : 14.3 MB/s (during test execution - write)
Transfer rate : 10.0 MB/s (during test execution - read)
Read/Write Test - PASSED.


SDTL 1
Transfer rate : 14.3 MB/s (during test execution - write)
Transfer rate : 10.0 MB/s (during test execution - read)
Read/Write Test - PASSED.


Write test with 64K of block size
C:\ - Files Read: 21094
1721 MB read (21094 files) in 245 seconds with rate 7 MB/sec
TOTAL: 1721 MB read (21094 files) in 245 seconds with rate 7 MB/sec
1279 MB written (80 files) in 247 seconds at 5 MB/sec


Write test with 512K of block size
C:\ - Files Read: 21095
1721 MB read (21095 files) in 229 seconds with rate 7 MB/sec
TOTAL: 1721 MB read (21095 files) in 229 seconds with rate 7 MB/sec


Write test with 1024K of block size
C:\ - Files Read: 21095
1718 MB read (21095 files) in 265 seconds with rate 6 MB/sec
TOTAL: 1718 MB read (21095 files) in 265 seconds with rate 6 MB/sec

Checking Firmware version
MSL5026
Current Revision 0423
New Revision 0507

Firmware revision 512 has ZERO bytes (ftp://ftp.hp.com/pub/information_storage/software/ltt/firmware/LTT_COMPAQ_MSL5000_Series_0512.frm) (It's strange!)

SDLT
Current Revision v085 (both)

I think that this firmware version help me in this issue.

Now when I try to make a local backup, the speed goes to 12 Mb/sec. Very nice !

If we make the same test using other server over a network (2 NIC in HP teaming connected with 1 Gigabit, each) the speeds is 4 Mb/s.

I read a lot other problems in HP foruns and many message all over internet and my question is: Did you change anything in TCP/IP registry to improve speed in backup?
I'm meaning about:
TcpWindowSize
GlobalMaxTcpWindowSize
Tcp1323Opts


Thank you again for support and sorry for delay.
Bruno



Marino Meloni_1
Honored Contributor

Re: Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

let me summarize :

performance writing on two sdlt220 are poor

During backup you reach 4 MB/sec

running the device performance test (not sure this is what you run), you can reach 14,3 MB/s with both devices.

system performance ( I suppose this is the test you run) give max 7 MB/s reading data from HDD

From these result it appear that the sdlt are fine. the problem is comming from the source of your data.
Your hdd is slow, or the access is slow, or your data are highly fragmented.

If you are running backup from the lan, for sure some tuning may be neccessary to allow max throughput during Backups.

I personaly cannot give you info on these parameters, but may be Veritas can

marino
Marino Meloni_1
Honored Contributor

Re: Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

Forgot to say that you are running last fw on drives, v085 is ok,
last FW for library is 5.07, 5.12 has been suspended for a latent problem, new version available soon.

Re: Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

Hello ALL,

Marino, you are correct, the tape drivers are OK, my problem should be network performance of fragmented files.

Thanks for all help,

Bruno
Claudio Ruzza_1
Valued Contributor

Re: Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

Bruno,
make sure your server's NICs and Ethernet Switches ports are NOT set in AutoSense Mode. Force them at their maximum capable speed (100 Mb full duplex or more).

You can also optimize legato networker. In a client saveset field if you enter a single volume/file system you generate a single session; if you split your filesystem in multiple entries (subdirectories), you generate many session. Then you increase you networker drive's parallelism, and you'll hopefully get better performances.

Claudio

Re: Tape Library MSL 5026 - SDLT 160/320 - 4Mb/s only !!!!!!!

Hello ALL,

Claudio, Thank you for attention!
My client saveset has all directories separated. I do not use "All" configuration.

Thank you once a time again for everybody.

Bruno