Tape Libraries and Drives
cancel
Showing results for 
Search instead for 
Did you mean: 

Tape device "busy"

SOLVED
Go to solution
Carol Runyan
Occasional Visitor

Tape device "busy"

Hi,
I'm pretty new to Unix so please bear with me.

I have an HP-UX B.11.11 U 9000/800 Unix Box.
I have an external tape jukebox with 4 tape devices on it:
***********************************************
tape 38 0/4/1/0.2.11.0.0.1.0 atdd CLAIMED DEVICE IBM ULTRIUM-TD2
/dev/rmt/38m /dev/rmt/38mnb /dev/rmt/87mn /dev/rmt/c17t1d0BESTb
/dev/rmt/38mb /dev/rmt/87m /dev/rmt/87mnb /dev/rmt/c17t1d0BESTn
/dev/rmt/38mn /dev/rmt/87mb /dev/rmt/c17t1d0BEST /dev/rmt/c17t1d0BESTnb
***********************************************
I use Backup Express 2.2 from a Windows Server to run my backups.

When I run a full back on a particular drive, the tape drive sporatically becomes "busy" for that tape drive. We have tried to reboot the Backup Express Windows Server with no good results. We have reset the tape device with no good results....we have to reboot the Unix box to release it. The other 3 out of the 4 tape units are accessible.


My question is:
Is there anyone out there that knows of a way to get a tape unit "unbusy" without rebooting the entire box?

Thanks,
Carol
3 REPLIES
Russell C. Smith
Valued Contributor
Solution

Re: Tape device "busy"

Hi Carol,

I'm not an "expert" in HP-UX or tape libraries (as opposed to stand-alone drives) but what I could advise you to do is to run the "sam" command at the command prompt. "sam" is the HP-UX System Administration Manager and through it you can do things like reconfigure your devices or create new device file names. If you select hardware options somewhere along the lines of Peripheral Devices > Tape Drives then you may find your device there and you may find an option that allows you to reconfigure or re-initialize it. Also, have you by chance tried the IBM documentation for your tape jukebox?

Hope this helps,
Russell
Carol Runyan
Occasional Visitor

Re: Tape device "busy"

I did try that...makes me feel better that I am on the right track....but it tells me that no tape drives are assigned... I'm "guessing" it's cause they are external to this box?
Yang Qin_1
Honored Contributor

Re: Tape device "busy"

You can load a tape to that tape drive then from your HPUX server run a tar test:

mt -t /dev/rmt/#mn rew (to rewin the tape)
tar cfv /dev/rmt/#mn /tmp (store some file to the tape)
mt -t /dev/rmt/#mn rew
tar tfv /dev/rmt/#mn (to list the files you stored on the tape)

If you have no problem with "tar" on HPUX server, you may need to check the Backup Express configuration, maybe there is a typo in device configuration for example.

Yang